CTC_Incentive Namespace

Control Technology Corporation Incentive PLC/EtherCAT Application Programming Interface.

CTC has created a very powerful tool for .Net programmers, a tightly integrated dynamic link library (DLL) interface which allows users to program the PC based controller using C#, Managed C++, and VB.Net. This DLL includes the complete MSB motion control language, axis properties, registers, variant storage, as well as variable access by register and symbolic names. It works both standalone or in conjunction with QuickBuilder application programs where programs run in mixed mode where .Net programs control one aspect of the automation and QuickBuilder does another. Typically QuickBuilder would be used where absolute real-time is required whereas .Net can be leveraged to coordinate larger systems, perform database queries, provide vision control interfaces, complex calculations, HMI updates, and/or real-time motion control of some of the axis, limited only by the programmer’s imagination. The only difference between QuickBuilder and the .Net interface is that the .Net program will execute under the Windows operating system (non-realtime) whereas QuickBuilder runs in real-time on a dedicated processor core.

Some of the features of the API are as follows:

• Portable .Net DLL, written in C#, abstracting the user from unmanaged code.

• Sample Applications included.

• Connection based high speed parallel interface to both the PLC logic and EtherCAT Master processes.

• Full support and mapping of the QuickBuilder Motion language to .Net. .Net Methods mimic those of the QuickBuilder MSB language helping to shorten learning curves when moving between programming environments.

• Full register interface, including Variant support.

• Exception based error processing.

• Requests are passed to the real-time processes where they execute using existing MSB instruction objects, thus executes exactly as an MSB would.

• Full access to a QuickBuilder programs’ symbol tables for variable reference, both at the QuickBuilder and MSB level. All axis properties are directly supported as well as access to user variables. This allows QuickBuilder programs to be re-compiled, variable registers re-assigned, and still work with .Net since the symbol name is the reference, not the low level register number.

• System state control to restart programs, restart EtherCAT, monitor current execution state, etc.

There are a number of classes that make up the API. The two primary ones are PLCLogic and Axis. Each interfacing directly with a different real-time process. PLCLogic interfaces with the CTPLC_1 process which executed the QuickBuilder programs and presents a register based interface. Axis interfaces with the CTECAT_1 and CTECAT_2 EtherCAT Master network processes which control all EtherCAT motion and IO. The entire QuickBuilder MSB instruction set and axis properties are available via the API, with only a few exceptions. .Net program logic can initiate parallel, multi-threaded connections, to each class, as required. Note that a connection to the Axis class occupies an MSB slot, with a limitation of 32 per axis.

Sample Visual Studio 2013 projects are available in C# (IncentiveAPI_CSharp), Managed C++ (IncentiveAPI_Cplus), and VB.Net (IncentiveAPI_VBNet). All perform the same task and look identical. Each may optionally monitor or actively control servo motors and access controller symbols, variables, and axis properties.

Classes

 | Class | Description
Public class | Controller | Class Controller.
Public class | Controller..::..Axis | Class Axis used to interact with EtherCAT axis directly, for example MSB level.
Public class | Controller..::..Axis..::..cbit | Common bit index class
Public class | Controller..::..Axis..::..ctr | Counter.
Public class | Controller..::..Axis..::..cvar | Common variable index class
Public class | Controller..::..Axis..::..IncentiveAxisException | Class IncentiveAxisException, error handler. Throws enum MOTION_FAULTS.
Public class | Controller..::..AxisSupervisor | Class AxisSupervisor used to interact with the EtherCAT Master when the PLC logic process is not running or wish to control a single network directly.
Public class | Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException | Class IncentiveAxisSupervisorException, error handler. Throws enum Axis.MOTION_FAULTS.
Public class | Controller..::..PLCLogic | Class PLCLogic for access to QuickBuilder registers
Public class | Controller..::..PLCLogic..::..IncentivePLCException | Class IncentivePLCException. Throws enum PLC_FAULTS.
Public class | Controller..::..PLCLogic..::..SimpleStringComparer | Class SimpleStringComparer, used as Binary Search comparison for controller symbols.
Public class | Controller..::..Symbol | QuickBuilder Symbol structure stored within a running program.
Public class | Variant | Class Variant, define the different data types and limitations.

Structures

 | Structure | Description
Public structure | Controller..::..Axis..::..COMMAND_EXT_RESULTS | Struct COMMAND_EXT_RESULTS, Extended command to capture drive information more efficiently.
Public structure | Controller..::..Axis..::..MOVE_PARAM | Struct MOVE_PARAM, typically used internally to request and pass parameters for certain motion commands.
Public structure | Controller..::..Axis..::..SDO_READ_RESULTS | Struct SDO_READ_RESULTS, Extended command results from reading a drive property over EtherCAT.
Public structure | Variant..::..VARIANT_PLC_RESOURCES | Struct VARIANT_PLC_RESOURCES: Resources available for use within the PLC/EtherCAT runtimes.
Public structure | Variant..::..VARIANT_STORAGE | Struct VARIANT_STORAGE: Universal data type access structure.
Public structure | Variant..::..VARIANT_STORAGE_BLOCK | Struct VARIANT_STORAGE_BLOCK: Universal data type access structure for block transfer of same type.
Public structure | Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER | Struct VARIANT_STORAGE_TRANSFER
Public structure | Variant..::..VARIANT_STORAGE_TRANSFER | Struct VARIANT_STORAGE_TRANSFER

Enumerations

 | Enumeration | Description
Public enumeration | Controller..::..Axis..::..CAP_REFERENCE | Enum CAP_REFERENCE, Capture window references.
Public enumeration | Controller..::..Axis..::..CAPTURE_TRANSISTIONS | Enum TRANSISTIONS, Edge transistions for capture.
Public enumeration | Controller..::..Axis..::..DRIVE_TYPES | Enum DRIVE_TYPES, specific drive types supported.
Public enumeration | Controller..::..Axis..::..ECAT_OBJECT_SIZE | ECAT_OBJECT_SIZE, Size of EtherCAT object data in bytes as defined by EtherCAT object.
Public enumeration | Controller..::..Axis..::..ETHERCAT_MODES | Enum ETHERCAT_MODES, EtherCAT support motion modes
Public enumeration | Controller..::..Axis..::..MASTER_MODES | Enum MASTER_MODES, master feedback position modes, referencing master_feedback variable for axis.
Public enumeration | Controller..::..Axis..::..MOTION_FAULTS | Enum MOTION_FAULTS, Errors returned by axis functions.
Public enumeration | Controller..::..Axis..::..MOVE_CMD | Enum MOVE_CMD
Public enumeration | Controller..::..Axis..::..PSTATES | Enum PSTATES, present motion state of axis
Public enumeration | Controller..::..Axis..::..TABLE_MOVES | Enum TABLE_MOVES, table computational modes.
Public enumeration | Controller..::..AxisSupervisor..::..SCAN_STATES | Enum SCAN_STATES, EtherCAT scanner states
Public enumeration | Controller..::..PLCLogic..::..PLC_CONNECT_MODES | enum PLC_CONNECT_MODES, Defines what to do after successful connection to PLC Logic. Optionally stop QuickBuilder program and restart EtherCAT Network.
Public enumeration | Controller..::..PLCLogic..::..PLC_RETVAL | Enum MOTION_FAULTS, Errors returned by axis functions.
Public enumeration | Controller..::..PLCLogic..::..PLC_STATES | enum PLC_STATES, PLC controller states, register 13054.
Public enumeration | Controller..::..PLCLogic..::..REGISTERS | enum REGISTERS, some popular registers, reference the 5300 Quick Reference guide to additional details.
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Controller Class

Class Controller.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class Controller
Public Class Controller
public ref class Controller

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller

See Also

Controller Members
CTC_Incentive Namespace


Controller Members

The Controller type exposes the following members.

Constructors

 | Name | Description
Public method | Controller | Initializes a new instance of the Controller class. Contains class interfaces for both PLCLogic and Axis process access.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller Class


Controller Constructor

Initializes a new instance of the Controller class. Contains class interfaces for both PLCLogic and Axis process access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller()
Public Sub New
public:
Controller()

See Also

Controller Class


Controller Methods

The Controller type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller Class


Controller.Axis Class

Incentive .Net API

Controller..::..Axis Class

Class Axis used to interact with EtherCAT axis directly, for example MSB level.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class Axis
Public Class Axis
public ref class Axis

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..Axis

See Also

Controller..::..Axis Members


Controller.Axis Members

Controller..::..Axis Members

The Controller..::..Axis type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..Axis | Class creation for an Axis.

Methods

 | Name | Description
Public method | _fpos | Read feedback position for a specific axis.
Public method | _tpos | Read target position for specific axis.
Public method | closeConnection | This method closes a connection to the EtherCAT Master runtime.
Public method | clrout | Clear drive outputs.
Public method | dc_sync | This method requests DC Sync mode with the drive attached to this axis. It does not return until completely executed and the drive is updated so there could be a delay.
Public method | delayMSB | Delays the specified milliseconds using an MSB delay loop.
Public method | drive_disable | Disable the drive, turning voltage off to it. Drive will then free wheel and will continue to have its position tracked.
Public method | drive_enable | Enables the axis, if not already. This tells the drive to activate voltage and prepare for operation via EtherCAT.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | gear_at | Changes the gear ratio of a slaved axis to the specified values.
Public method | gear_at_in | Changes the gear ratio of a slaved axis to the specified values over some number of master counts.
Public method | gear_at_in_after | Changes the gear ratio of a slaved axis to the specified values over some number of master counts.
Public method | gear_for_in | Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts.
Public method | gear_for_in_after | Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts after certain number of counts.
Public method | get_drive_properties | Get drive properties, reads COMMAND_EXT_RESULTS drive properties all at once versus individually.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getResources | Gets the resources.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVar | Gets the variable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | move_at_for(Double, Double, Double, Double) | Move relative, speed limited, trapazoidal.
Public method | move_at_for(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_for(Double, Double) | Move relative, speed limited, trapazoidal using default acc and dec.
Public method | move_at_for(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal using default acc and dec. Extended drive information
Public method | move_at_to(Double, Double, Double, Double) | Move absolute, speed limited, trapazoidal.
Public method | move_at_to(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_to(Double, Double) | Move absolute, speed limited, trapazoidal, use default acc and dec.
Public method | move_at_to(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal, use default acc and dec. Extended drive information results.
Public method | move_for(Double, Double, Double) | Move relative, triangular.
Public method | move_for(Double) | Move relative, triangular. Uses default acc and dec.
Public method | move_in_for(Double, Double, Double) | Move relative, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_for(Double, Double) | Move relative, trapazoidal, in time requested.
Public method | move_in_to(Double, Double, Double) | Move absolute, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_to(Double, Double) | Move absolute, trapazoidal, in time requested.
Public method | move_to(Double, Double, Double) | Move absolute, triangular.
Public method | move_to(Double) | Move absolute, triangular. Uses default acc and dec.
Public method | move_trap_for | Move relative, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.
Public method | move_trap_to | Move absolute, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.
Public method | new_endposition | Modifies the end point of an active move command to an absolute position. If not moving then ignored.
Public method | new_endposition_relative | Modifies the end point of an active move command relative to current position. If not moving then ignored.
Public method | offset_position | Modify the target and feedback positions simultaneously by adding the offset to both.
Public method | offset_position_counts | Modify the target and feedback positions simultaneously by adding the offset to both.
Public method | offset_slave_by | Offsets the position (and therefore phase) of the axis such that a 'slavecounts' correction (offset) occurs over a period of 'time'.
Public method | openConnection | This method opens a connection to the EtherCAT Master runtime for motion control.
Public method | pulse | Pulse the specifed output for the desired number of milliseconds.
Public method | sdo_read | Read an object property of the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.
Public method | sdo_write | Write an object property to the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.
Public method | segmove_accdec_to_for | Adds an acc/dec segment from the current velocity to the new 'velocity' over some 'displacement'.
Public method | segmove_accdec_to_using | Adds an acc/dec segment from the current velocity to the new 'velocity' at the specified 'rate'.
Public method | segmove_clear | Clears the specified segment table.
Public method | segmove_slew_until_position | This method adds a constant velocity segment until reaching some specified absolute 'position' from the start of the profile. Prior segments in the table must represent movement before this command is accedpted otherwise an error will occur.
Public method | segmove_start_relative | Starts a relative segmented move, 'zero feedback position' occurs automatically upon executing this command.
Public method | segmove_stop_at | Stops motion at the specified 'position', with a given 'rate'. This will cause motion to stop at an absolute position at the specified decelaration rate. Prior segments in the table must represent movement before this command is accepted.
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32, Int32, Boolean) | Initializes the parameters to be used for all captures on this axis, specifying the input to use and the optional gated input. If gating is specified then the specified gating input must be at the specified gating state.
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32) | Initializes the parameters to be used for all captures on this axis, specifying the input to use.
Public method | set_capwin_range | Initializes a window to be monitored for valid captures to occur, anything outside this window is considered invalid and ignored.
Public method | set_common_bit | Set_common_bits the specified number.
Public method | set_common_var | Sets the common var, 1 to 255 to the specified value.
Public method | set_feedback_position | Set feedback position.
Public method | set_master | Sets the source of the master axis encoder.
Public method | set_mode | Set desired operating mode of the axis, positioning or tracking.
Public method | set_simulated_feedback | Set simulated feedback position mode (true/false).
Public method | set_target_position | Set target position.
Public method | setout | Set drive outputs.
Public method | setVar | Sets the variable.
Public method | slew_at_in | Alters the current slew velocity, changing smoothly over the specified time. For immediate change set time to 0.0.
Public method | slew_begin | Changes the operating mode of the axis to slewing.
Public method | slew_end | Changes the operating mode of the axis to positioning from slewing.
Public method | slew_for | Alters the current slew velocity, over time, to a slew velocity of 0.0 such that some displacement is consumed.
Public method | stop()()()() | Stops the axis quickly.
Public method | stop(Single) | Stops the axis at the specified slew rate.
Public method | table_clear | Clear the specified table of all entries.
Public method | table_continue | Continues a cam table that was stopped by the 'stop table' command. Note that this command should only be used if the master position stopped at the beginning of the next table row position otherwise any row that is currently being executed during a 'stop table' will be re-executed.
Public method | table_precompute | Readies a table for use by a spline/CAM motion. After points have been added to a table, there are a series of computations that need to occur before the table can be utilized for spline and CAM motion operations.
Public method | table_start | Starts spline motion using the specified table.
Public method | table_start_cam | Starts CAM motion using the specified table.
Public method | table_stop | Stops spline or CAM motion. If in CAM motion then the current table state is saved in case a 'table continue' command is executed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | wait_capture | Waits for the capture and arms the capture input. If the capture occurs control will be returned else returns after the specified 'limit'.
Public method | wait_common_bit | Wait for a common bit to be true or false.
Public method | wait_common_var(Int32, Int32) | Wait for a common var to be a certain value. This method will wait until the condition is true to get a message back.
Public method | wait_common_var(Int32, Boolean, Int32, Int32) | Wait for a common var to be in or out of range. This method will wait until the condition is true to get a message back.
Public method | wait_for_in_pos | Wait for motion in position (inpos == 1) or timeout.
Public method | wait_master | Waits until the specified number of master encoder counts has been generated.
Public method | wait_slave | Waits until the specified number of slave (target position) counts has been generated.
Public method | zero_counters | Zero temporary master or slave counters
Public method | zero_feedback_position | Zeros the feedback position, but maintains the following error. Operates the same as 'zero feedback position'.
Public method | zero_following_error | Zeros the feedback position (fpos/fposc) and target position (tpos), thereby removing any following error.
Public method | zero_target_position | Zeros the target position, but maintains the following error. Operates the same as 'zero feedback position'.

Fields

 | Name | Description
Public field | axis | Axis this class will be interacting with, 1 to N.
Public field | connected | Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.
Public field | driveEnabled | true if the axis has been enabled, false if not. Always double check with the property from the axis as this just records drive_enable method result.
Public field | errorCode | Last function call operation result code in case fails
Public field | errString | Last function call operation error string information if available.
Public field | name | Name of process accessing, typically CTECAT_1 or CTECAT_2.
Public field | resources | Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

Properties

 | Name | Description
Public property | acc | Acceleration rate. Read/write.
Public property | accVector | Acceleration vector, if circular then in radians/sec2. Read only.
Public property | accX | Acceleration along X axis. Read/write.
Public property | accY | Acceleration along Y axis. Read/write.
Public property | accZ | Acceleration along Z axis. Read/write.
Public property | activeBG_MSBs | Number of background MSBs. Read only.
Public property | activeCAM_row | CAM table active and processing. Read/write.
Public property | activeFG_MSBs | Number of foreground MSBs, should be 0 for EtherCAT, only use background. Read only.
Public property | angle | Interpolated move angle. Read/write.
Public property | angleSweep | Degrees of sweep for circular interpolation. Read/write.
Public property | antibackup | Master antibackup accumilate, 0 ignore, 1 accumilate. Read/write.
Public property | axisnum | Our MSB axis number, 1 to N. Read only.
Public property | axisptr | Axis pointer to determine whose axis properties to access. Read/write.
Public property | axisY | Axis to use for interpolation Y control. Read/write.
Public property | axisZ | Axis to use for interpolation Z control. Read/write.
Public property | camming_invertend | If set inverts the meaning of invertmaster with regards to camtable end. Read/write.
Public property | camRequest | CAM file load request, 0-idle, 1-active, else error code. Read only.
Public property | capArmed | Capture armed. Read/write.
Public property | capEdge | Capture edge setting. Read only.
Public property | capGate | Capture gate value. Read only.
Public property | capGateState | Capture gate state, on or off. Read only.
Public property | capInput | Capture input setting. Read only.
Public property | capLimit | Capture limit value. Read/write.
Public property | capLimitflag | Capture limit present. Read only.
Public property | capMod | Capture modulus, 0 disables. Read/write.
Public property | capOffset | Amount to move, offset, after registration occurs. Read/write.
Public property | cappos | Capture position = cappos/ppr, user units. Read only.
Public property | capposc | Capture position counts. Read only.
Public property | capStatus | Capture status, not used. Read only.
Public property | capTriggered | Capture occured. Read/write.
Public property | capWait | Capture wait. Read only.
Public property | capwinEnd | Capture window end. Read/write.
Public property | capwinStart | Capture window start. Read/write.
Public property | capwinType | Capture window type. Read only.
Public property | cmode | Command mode for drive, EtherCAT mode. Read/write.
Public property | Command_timout_ms | Gets or sets the motion command timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 10 seconds.
Public property | ctr0 | mappable input edge counter 0. Read only.
Public property | ctr1 | mappable input edge counter 1. Read only.
Public property | ctr2 | mappable input edge counter 2. Read only.
Public property | ctr3 | mappable input edge counter 3. Read only.
Public property | ctr4 | mappable input edge counter 4. Read only.
Public property | ctr5 | mappable input edge counter 5. Read only.
Public property | ctr6 | mappable input edge counter 6. Read only.
Public property | ctr7 | mappable input edge counter 7. Read only.
Public property | dac_mv | DAC millivolts, not used. Read only.
Public property | debugTable | Diagnostic table selection index. Read/write.
Public property | debugTableRow | Diagnostic table row selection. Read/write.
Public property | debugTableRows | Diagnostic table selected index number of rows. Read only.
Public property | debugTableX | Diagnostic table row X value. Read only.
Public property | debugTableY | Diagnostic table row Y value. Read only.
Public property | dec | Deceleration rate. Read/write.
Public property | decVector | Deceleration vector, if circular then in radians/sec2. Read only.
Public property | decX | Deceleration along X axis. Read/write.
Public property | decY | Deceleration along Y axis. Read/write.
Public property | decZ | Deceleration along Z axis. Read/write.
Public property | din1 | Drive digital input 1, drive dependent. Read only.
Public property | din10 | Drive digital input 10, drive dependent. Read only.
Public property | din2 | Drive digital input 2, drive dependent. Read only.
Public property | din3 | Drive digital input 3, drive dependent. Read only.
Public property | din4 | Drive digital input 4, drive dependent. Read only.
Public property | din5 | Drive digital input 5, drive dependent. Read only.
Public property | din6 | Drive digital input 6, drive dependent. Read only.
Public property | din7 | Drive digital input 7, drive dependent. Read only.
Public property | din8 | Drive digital input 8, drive dependent. Read only.
Public property | din9 | Drive digital input 9, drive dependent. Read only.
Public property | dins | Drive digital inputs, drive dependent. Read only.
Public property | dout1 | Drive digital output 1, drive dependent. Read/write.
Public property | dout10 | Drive digital output 10, drive dependent. Read/write.
Public property | dout2 | Drive digital output 2, drive dependent. Read/write.
Public property | dout3 | Drive digital output 3, drive dependent. Read/write.
Public property | dout4 | Drive digital output 4, drive dependent. Read/write.
Public property | dout5 | drive digital output 5, drive dependent. Read/write.
Public property | dout6 | Drive digital output 6, drive dependent. Read/write.
Public property | dout7 | Drive digital output 7, drive dependent. Read/write.
Public property | dout8 | Drive digital output 8, drive dependent. Read/write.
Public property | dout9 | Drive digital output 9, drive dependent. Read/write.
Public property | douts | Drive digital outputs, drive dependent. Read only.
Public property | driveenable | Drive enable output number, turned on with drive_enable() if set. Read/write.
Public property | driveType | Type of drive, manufacturer. Read only.
Public property | dwSlaveID | Assigned EtherCAT slave ID to the axis. Read only.
Public property | enabled | Drive enabled, nonzero. Read only.
Public property | encoder_mode | Encoder mode, set to 1 if absolute position mode. Read/write.
Public property | encoderZ | Encoder Z, not currently used, drive specific. Read/write.
Public property | encoderZ3 | Encoder combo A B, not used. Read/write.
Public property | fault1 | Fault bit group 1. Read only.
Public property | fault2 | Fault bit group 2. Read only.
Public property | fault3 | Fault bit group 3. Read only.
Public property | fault4 | Fault bit group 4. Read only.
Public property | faulted | Faulted, nonzero. Read only.
Public property | fpos | Feedback position = fposc/ppr. Read only.
Public property | fposc | Feedback position counts. Read only.
Public property | global_flags1 | General global flags 1. Read/write.
Public property | global_flags2 | General global flags 2. Read/write.
Public property | global_flags3 | General global flags 3. Read/write.
Public property | global_flags4 | General global flags 4. Read/write.
Public property | global_flags5 | General global flags 5. Read/write.
Public property | global_inputs | EtherCAT global inputs. Read only.
Public property | global_outputs | EtherCAT global outputs. Read/write.
Public property | global_reg1 | General global register 1. Read/write.
Public property | global_reg10 | General global register 10. Read/write.
Public property | global_reg11 | General global register 11. Read/write.
Public property | global_reg12 | General global register 12. Read/write.
Public property | global_reg13 | General global register 13. Read/write.
Public property | global_reg14 | General global register 14. Read/write.
Public property | global_reg15 | General global register 15. Read/write.
Public property | global_reg16 | General global register 16. Read/write.
Public property | global_reg17 | General global register 17. Read/write.
Public property | global_reg18 | General global register 18. Read/write.
Public property | global_reg19 | General global register 19. Read/write.
Public property | global_reg2 | General global register 2. Read/write.
Public property | global_reg20 | General global register 20. Read/write.
Public property | global_reg21 | General global register 21. Read/write.
Public property | global_reg22 | General global register 22. Read/write.
Public property | global_reg23 | General global register 23. Read/write.
Public property | global_reg24 | General global register 24. Read/write.
Public property | global_reg25 | General global register 25. Read/write.
Public property | global_reg26 | General global register 26. Read/write.
Public property | global_reg27 | General global register 27. Read/write.
Public property | global_reg28 | General global register 28. Read/write.
Public property | global_reg29 | General global register 29. Read/write.
Public property | global_reg3 | General global register 3. Read/write.
Public property | global_reg30 | General global register 30. Read/write.
Public property | global_reg31 | General global register 31. Read/write.
Public property | global_reg32 | General global register 32. Read/write.
Public property | global_reg4 | General global register 4. Read/write.
Public property | global_reg5 | General global register 5. Read/write.
Public property | global_reg6 | General global register 6. Read/write.
Public property | global_reg7 | General global register 7. Read/write.
Public property | global_reg8 | General global register 8. Read/write.
Public property | global_reg9 | General global register 9. Read/write.
Public property | gratio | Present gear ration. Read only.
Public property | homing_method | Homing method if available, drive dependent support, see manual. Read/write.
Public property | homing_speed1 | Homing speed 1 if available, drive dependent support, see manual. Read/write.
Public property | homing_speed2 | Homing speed 2 if available, drive dependent support, see manual. Read/write.
Public property | IAI_alarmcode | IAI alarm register code. Read/write.
Public property | IAI_control | IAI control register. Read/write.
Public property | inpos | In position, nonzero. Read only.
Public property | inpos_t | Required in position time, drive dependent. Read/write.
Public property | inpos_w | In position window, drive dependent. Read/write.
Public property | inposw | In position window, user units. Read/write.
Public property | inputPolarity | Exclusive OR of dins to set active low or high inputs, default is 0 where 1 = closed. Read/write.
Public property | invel_t | In velocity time, drive dependent. Read/write.
Public property | invel_w | In velocity window, drive dependent. Read/write.
Public property | invertfeed | Invert feedback encoder, nonzero. Read/write.
Public property | invertmaster | Invert master encoder, user units. Read/write.
Public property | ipos | Initial position. Read only.
Public property | jerk_a | Jerk - acceleration used, S-curve. Read only.
Public property | jerk_a_req | Jerk - acceleration request. Read/write.
Public property | jerk_d | Jerk - deceleration used, S-curve. Read only.
Public property | jerk_d_req | Jerk - deceleration request. Read/write.
Public property | jogging | Jogging, not currently implemented. Read only.
Public property | last_ALStatusCode | Last EtherCAT AL register status code. Read/write.
Public property | last_errorCode | Last EtherCAT error code, typcially object 0x603f. Read/write.
Public property | last_errorRegister | Last EtherCAT register value, object 0x1001. Read/write.
Public property | last_errorType | Last EtherCAT error type. Read/write.
Public property | loopperiod | Axis loop period. Read only.
Public property | looprate | Axis loop rate. Read only.
Public property | magnitude | Linear interpolation vector size. Read/write.
Public property | master_feedback | Set master feedback or target, master drive axis for EtherCAT 1 to N. Read/write.
Public property | mcinv | Mposc 1 to 5 inversion bit mask, not currently used. Read/write.
Public property | mdelta1 | Last master position counter 1, not currently used. Read only.
Public property | mdelta2 | Last master position counter 2, not currently used. Read only.
Public property | mdelta3 | Last master position counter 3, not currently used. Read only.
Public property | mdelta4 | Last master position counter 4, not currently used. Read only.
Public property | mdelta5 | Last master position counter 5, not currently used. Read only.
Public property | mmc | mposc 1 to 5 modulus. Read/write only.
Public property | move_master_counts | Move master command rate target. Read only.
Public property | move_master_ramp | Move master ramp setting. Read only.
Public property | move_master_rate | Current move master rate. Read only.
Public property | move_master_rate_target | Move master command ramp. Read only.
Public property | mpgai | master position delta in last gear at in. Read only.
Public property | mpgfi | master position delta in last gear for in. Read only.
Public property | mpos | Master position, user units. Read only.
Public property | mposc | Master position in counts. Read only.
Public property | mposc1 | master position counter 1, not currently used. Read/write.
Public property | mposc2 | master position counter 2, not currently used. Read/write.
Public property | mposc3 | master position counter 3, not currently used. Read/write.
Public property | mposc4 | master position counter 4, not currently used. Read/write.
Public property | mposc5 | master position counter 5, not currently used. Read/write.
Public property | mppr | Master pulses per revolution. Read/write.
Public property | msource | Master source. Read/write.
Public property | neglim | Negative overtravel limits, user units. Read/write.
Public property | newvel | New velocity request for 'newposition' move command. Read/write.
Public property | overneg | Negative overtravel, nonzero. Read only.
Public property | overnegin | Overtravel negative input #. Read/write.
Public property | overpos | Positive overtravel, nonzero. Read only.
Public property | overposin | Overtravel positive input #. Read/write.
Public property | overtrq | In torque limit, nonzero. Read only.
Public property | perr | Position error, in user units. Read only.
Public property | perrlimit | Following error limit (0 = disabled). Read/write.
Public property | poslim | Positive overtravel limits, user units. Read/write.
Public property | ppr | Pulses per revolution. Read/write.
Public property | pstate | Axis state. Read only.
Public property | QS2_Status | QS2 status interface. Read only.
Public property | radius | Circular interpolation radius. Read/write.
Public property | RFID_address | RFID channel address to access. Read/write.
Public property | RFID_bytesTotal | Total number of bytes to transfer to/from RFID tag. Read/write.
Public property | RFID_bytesTransferred | Current number of bytes actually transfered from RFID tag. Read/write.
Public property | RFID_channel | RFID ones based index to reference RFID channel to operate on. Read/write.
Public property | RFID_control | RFID channel control register. Read/write.
Public property | RFID_controlActive | RFID channel control register currently written to RFID reader. Read only.
Public property | RFID_count | Number of bytes in an RFID block read - 1. Read only.
Public property | RFID_data_readh | Second 4 bytes of RFID read array. Read/write.
Public property | RFID_data_readl | First 4 bytes of RFID read array. Read/write.
Public property | RFID_data_writeh | Second 4 bytes of RFID write array. Read/write.
Public property | RFID_data_writel | First 4 bytes of RFID write array. Read/write.
Public property | RFID_error | RFID error catagory and description. Read only.
Public property | RFID_index | Index to RFID read and write array, 1 to 32. Read/write.
Public property | RFID_lasttagIDh | Last RFID unique tag ID high. Read/write.
Public property | RFID_lasttagIDl | Last RFID unique tag ID low. Read/write.
Public property | RFID_state | Current state of RFID read/write logic. Read/write.
Public property | RFID_status | RFID channel status register. Read only.
Public property | RFID_tagIDh | Current RFID unique tag ID high 4 bytes. Read/write.
Public property | RFID_tagIDl | Current RFID unique tag ID low 4 bytes. Read/write.
Public property | RFID_totalChannels | Total channels of RFID readers available. Read only.
Public property | rmstrq | RMS torque, typically actual torque or current, also drive specific features. Read only.
Public property | running | Turns on output # if MSB running on axis. Read/write.
Public property | runv | runv - Present velocity. Read/write.
Public property | sdc | Slave decrement counter. Read/write.
Public property | settling | Settling time in seconds for new position command change of direction, default 0. Read/write.
Public property | sfmod | Secondary feedback modulus, counts. Read/write.
Public property | sfpos | Secondary position, sfposc/ppr, user units. Read only.
Public property | sfposc | Secondary feedback position counts. Read/write.
Public property | sign | sign - Direction of move, plus or minus. Read Only.
Public property | smark | Slave marker position, not currently used. Read only.
Public property | smarkfall | Input bit mask fall, determines when smark is calculated, not currently used. Read/write.
Public property | smarkrise | Input bit mask rise, determines when smark is calculated, not currently used. Read/write.
Public property | smod | Smodc modulus. Read/write.
Public property | smodc | Slave position counter. Read/write only.
Public property | spgai | Slave position delta in last gear at in. Read only.
Public property | spgfi | Slave position delta in last gear for in. Read only.
Public property | sphase | Slave marker phase position, not currently used. Read only.
Public property | sppr | Stepper pulses/rev, not currently used Read/write only.
Public property | stepsout | Stepper pulses output, not currently used. Read only.
Public property | stoprate | Stop rate. Read/write.
Public property | theta | Motor angle. Read only.
Public property | time | Time, incremented by loop period each interrupt. Read/write.
Public property | tlim | Torque limit. Read/write.
Public property | tmax | Max torque or current, % actual depending on drive support. Read/write.
Public property | tmc1 | Temporary master counter 1. Read/write.
Public property | tmc2 | Temporary master counter 2. Read/write.
Public property | tmodc | Master position counter mod mmc. Read/write.
Public property | touchProbeStatus | Drive position registration latch status. Read only.
Public property | tpos | Target position = tposc/ppr. Read only.
Public property | tposc | Target position counts. Read only.
Public property | tracking_pstate | Slave axis state of move command during tracking. Read only.
Public property | tracking_sign | Direction to move, 1 for positive, -1 for negative. Read only.
Public property | tracking_status | QS2 status for tracking, state of motion slope for move. Read only.
Public property | tracking_tpos | Relative position of move command during tracking, 0 base. Read only.
Public property | tracking_tposc | Relative counts of move command during tracking, 0 base. Read only.
Public property | trqc | Torque command, not presently used. Read/write.
Public property | tsc1 | Temporary slave counter 1. Read/write.
Public property | tsc1fall | Input bit mask (fall) determines when tsc1 is cleared. Read/write.
Public property | tsc1rise | Input bit mask (rise) determines when tsc1 is cleared. Read/write.
Public property | tsc2 | Temporary slave counter 2. Read/write.
Public property | tsc2fall | Input bit mask (fall) determines when tsc2 is cleared. Read/write.
Public property | tsc2rise | Input bit mask (rise) determines when tsc2 is cleared. Read/write.
Public property | uud | User units denominator. Read/write.
Public property | uun | User units numerator. Read/write.
Public property | Variable_timeout_ms | Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.
Public property | vcmd | Velocity command, drive specific use. Read/write.
Public property | vectorY | Y axis move distance for linear interpolation. Read/write.
Public property | vectorZ | Z axis move distance for linear interpolation. Read/write.
Public property | vel | Velocity, in user units. Read only.
Public property | velVector | Velocity vector, if circular then in radians/sec. Read/write.
Public property | velX | Velocity along X axis. Read/write.
Public property | velY | Velocity along Y axis. Read/write.
Public property | velZ | Velocity along Z axis. Read/write.
Public property | verr | Velocity error, not used with EtherCAT. Read only.
Public property | vmax | Max velocity. Read/write.
Public property | vmdelta | Virtual master delta counts. Read only.
Public property | wControlWord | Current EtherCAT control word written. Read only.
Public property | wStatus | Current EtherCAT PDO status read. Read only.
Public property | zone_limit_neg | IAI linear actuator zone negative limit. Read/write.
Public property | zone_limit_pos | IAI linear actuator zone positive limit. Read/write.
Public property | zpulse | Zpulse seen, drive specific. Read only.
Public property | ZPULSE_NEG | Z pulse negative direction, drive specific. Read only.
Public property | ZPULSE_POS | Z pulse positive direction, drive specific. Read only.
Public property | ztheta | Motor angle of Z. Read only.

See Also

Controller..::..Axis Class


Axis Constructor

Class creation for an Axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Axis(
    int axis
)
Public Sub New ( _
    axis As Integer _
)
public:
Axis(
    int^ axis
)

Parameters

axis
Type: Int32
The axis on which to open a new MSB connection, where 1 is the first.

See Also

Controller..::..Axis Class


Controller.Axis Fields

Controller..::..Axis Fields

The Controller..::..Axis type exposes the following members.

Fields

 | Name | Description
Public field | axis | Axis this class will be interacting with, 1 to N.
Public field | connected | Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.
Public field | driveEnabled | true if the axis has been enabled, false if not. Always double check with the property from the axis as this just records drive_enable method result.
Public field | errorCode | Last function call operation result code in case fails
Public field | errString | Last function call operation error string information if available.
Public field | name | Name of process accessing, typically CTECAT_1 or CTECAT_2.
Public field | resources | Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

See Also

Controller..::..Axis Class


axis Field

Axis..::..axis Field

Axis this class will be interacting with, 1 to N.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int axis
Public axis As Integer
public:
int^ axis

See Also

Controller..::..Axis Class


connected Field

Axis..::..connected Field

Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool connected
Public connected As Boolean
public:
bool^ connected

See Also

Controller..::..Axis Class


driveEnabled Field

Axis..::..driveEnabled Field

true if the axis has been enabled, false if not. Always double check with the property from the axis as this just records drive_enable method result.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool driveEnabled
Public driveEnabled As Boolean
public:
bool^ driveEnabled

See Also

Controller..::..Axis Class


errorCode Field

Axis..::..errorCode Field

Last function call operation result code in case fails

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int errorCode
Public errorCode As Integer
public:
int^ errorCode

See Also

Controller..::..Axis Class


errString Field

Axis..::..errString Field

Last function call operation error string information if available.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string errString
Public errString As String
public:
String^ errString

See Also

Controller..::..Axis Class


name Field

Axis..::..name Field

Name of process accessing, typically CTECAT_1 or CTECAT_2.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string name
Public name As String
public:
String^ name

See Also

Controller..::..Axis Class


resources Field

Axis..::..resources Field

Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Variant..::..VARIANT_PLC_RESOURCES resources
Public resources As Variant..::..VARIANT_PLC_RESOURCES
public:
Variant..::..VARIANT_PLC_RESOURCES^ resources

See Also

Controller..::..Axis Class


userObject1 Field

Axis..::..userObject1 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject1
Public userObject1 As Object
public:
Object^ userObject1

See Also

Controller..::..Axis Class


userObject2 Field

Axis..::..userObject2 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject2
Public userObject2 As Object
public:
Object^ userObject2

See Also

Controller..::..Axis Class


Controller.Axis Methods

Controller..::..Axis Methods

The Controller..::..Axis type exposes the following members.

Methods

 | Name | Description
Public method | _fpos | Read feedback position for a specific axis.
Public method | _tpos | Read target position for specific axis.
Public method | closeConnection | This method closes a connection to the EtherCAT Master runtime.
Public method | clrout | Clear drive outputs.
Public method | dc_sync | This method requests DC Sync mode with the drive attached to this axis. It does not return until completely executed and the drive is updated so there could be a delay.
Public method | delayMSB | Delays the specified milliseconds using an MSB delay loop.
Public method | drive_disable | Disable the drive, turning voltage off to it. Drive will then free wheel and will continue to have its position tracked.
Public method | drive_enable | Enables the axis, if not already. This tells the drive to activate voltage and prepare for operation via EtherCAT.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | gear_at | Changes the gear ratio of a slaved axis to the specified values.
Public method | gear_at_in | Changes the gear ratio of a slaved axis to the specified values over some number of master counts.
Public method | gear_at_in_after | Changes the gear ratio of a slaved axis to the specified values over some number of master counts.
Public method | gear_for_in | Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts.
Public method | gear_for_in_after | Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts after certain number of counts.
Public method | get_drive_properties | Get drive properties, reads COMMAND_EXT_RESULTS drive properties all at once versus individually.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getResources | Gets the resources.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getVar | Gets the variable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | move_at_for(Double, Double, Double, Double) | Move relative, speed limited, trapazoidal.
Public method | move_at_for(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_for(Double, Double) | Move relative, speed limited, trapazoidal using default acc and dec.
Public method | move_at_for(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal using default acc and dec. Extended drive information
Public method | move_at_to(Double, Double, Double, Double) | Move absolute, speed limited, trapazoidal.
Public method | move_at_to(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_to(Double, Double) | Move absolute, speed limited, trapazoidal, use default acc and dec.
Public method | move_at_to(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal, use default acc and dec. Extended drive information results.
Public method | move_for(Double, Double, Double) | Move relative, triangular.
Public method | move_for(Double) | Move relative, triangular. Uses default acc and dec.
Public method | move_in_for(Double, Double, Double) | Move relative, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_for(Double, Double) | Move relative, trapazoidal, in time requested.
Public method | move_in_to(Double, Double, Double) | Move absolute, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_to(Double, Double) | Move absolute, trapazoidal, in time requested.
Public method | move_to(Double, Double, Double) | Move absolute, triangular.
Public method | move_to(Double) | Move absolute, triangular. Uses default acc and dec.
Public method | move_trap_for | Move relative, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.
Public method | move_trap_to | Move absolute, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.
Public method | new_endposition | Modifies the end point of an active move command to an absolute position. If not moving then ignored.
Public method | new_endposition_relative | Modifies the end point of an active move command relative to current position. If not moving then ignored.
Public method | offset_position | Modify the target and feedback positions simultaneously by adding the offset to both.
Public method | offset_position_counts | Modify the target and feedback positions simultaneously by adding the offset to both.
Public method | offset_slave_by | Offsets the position (and therefore phase) of the axis such that a 'slavecounts' correction (offset) occurs over a period of 'time'.
Public method | openConnection | This method opens a connection to the EtherCAT Master runtime for motion control.
Public method | pulse | Pulse the specifed output for the desired number of milliseconds.
Public method | sdo_read | Read an object property of the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.
Public method | sdo_write | Write an object property to the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.
Public method | segmove_accdec_to_for | Adds an acc/dec segment from the current velocity to the new 'velocity' over some 'displacement'.
Public method | segmove_accdec_to_using | Adds an acc/dec segment from the current velocity to the new 'velocity' at the specified 'rate'.
Public method | segmove_clear | Clears the specified segment table.
Public method | segmove_slew_until_position | This method adds a constant velocity segment until reaching some specified absolute 'position' from the start of the profile. Prior segments in the table must represent movement before this command is accedpted otherwise an error will occur.
Public method | segmove_start_relative | Starts a relative segmented move, 'zero feedback position' occurs automatically upon executing this command.
Public method | segmove_stop_at | Stops motion at the specified 'position', with a given 'rate'. This will cause motion to stop at an absolute position at the specified decelaration rate. Prior segments in the table must represent movement before this command is accepted.
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32, Int32, Boolean) | Initializes the parameters to be used for all captures on this axis, specifying the input to use and the optional gated input. If gating is specified then the specified gating input must be at the specified gating state.
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32) | Initializes the parameters to be used for all captures on this axis, specifying the input to use.
Public method | set_capwin_range | Initializes a window to be monitored for valid captures to occur, anything outside this window is considered invalid and ignored.
Public method | set_common_bit | Set_common_bits the specified number.
Public method | set_common_var | Sets the common var, 1 to 255 to the specified value.
Public method | set_feedback_position | Set feedback position.
Public method | set_master | Sets the source of the master axis encoder.
Public method | set_mode | Set desired operating mode of the axis, positioning or tracking.
Public method | set_simulated_feedback | Set simulated feedback position mode (true/false).
Public method | set_target_position | Set target position.
Public method | setout | Set drive outputs.
Public method | setVar | Sets the variable.
Public method | slew_at_in | Alters the current slew velocity, changing smoothly over the specified time. For immediate change set time to 0.0.
Public method | slew_begin | Changes the operating mode of the axis to slewing.
Public method | slew_end | Changes the operating mode of the axis to positioning from slewing.
Public method | slew_for | Alters the current slew velocity, over time, to a slew velocity of 0.0 such that some displacement is consumed.
Public method | stop()()()() | Stops the axis quickly.
Public method | stop(Single) | Stops the axis at the specified slew rate.
Public method | table_clear | Clear the specified table of all entries.
Public method | table_continue | Continues a cam table that was stopped by the 'stop table' command. Note that this command should only be used if the master position stopped at the beginning of the next table row position otherwise any row that is currently being executed during a 'stop table' will be re-executed.
Public method | table_precompute | Readies a table for use by a spline/CAM motion. After points have been added to a table, there are a series of computations that need to occur before the table can be utilized for spline and CAM motion operations.
Public method | table_start | Starts spline motion using the specified table.
Public method | table_start_cam | Starts CAM motion using the specified table.
Public method | table_stop | Stops spline or CAM motion. If in CAM motion then the current table state is saved in case a 'table continue' command is executed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | wait_capture | Waits for the capture and arms the capture input. If the capture occurs control will be returned else returns after the specified 'limit'.
Public method | wait_common_bit | Wait for a common bit to be true or false.
Public method | wait_common_var(Int32, Int32) | Wait for a common var to be a certain value. This method will wait until the condition is true to get a message back.
Public method | wait_common_var(Int32, Boolean, Int32, Int32) | Wait for a common var to be in or out of range. This method will wait until the condition is true to get a message back.
Public method | wait_for_in_pos | Wait for motion in position (inpos == 1) or timeout.
Public method | wait_master | Waits until the specified number of master encoder counts has been generated.
Public method | wait_slave | Waits until the specified number of slave (target position) counts has been generated.
Public method | zero_counters | Zero temporary master or slave counters
Public method | zero_feedback_position | Zeros the feedback position, but maintains the following error. Operates the same as 'zero feedback position'.
Public method | zero_following_error | Zeros the feedback position (fpos/fposc) and target position (tpos), thereby removing any following error.
Public method | zero_target_position | Zeros the target position, but maintains the following error. Operates the same as 'zero feedback position'.

See Also

Controller..::..Axis Class


_fpos Method

Axis..::.._fpos Method

Read feedback position for a specific axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double _fpos(
    int _axis
)
Public Function _fpos ( _
    _axis As Integer _
) As Double
public:
double^ _fpos(
    int^ _axis
)

Parameters

_axis
Type: Int32
The _axis.

Return Value

System.Double.

See Also

Controller..::..Axis Class


_tpos Method

Axis..::.._tpos Method

Read target position for specific axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double _tpos(
    int _axis
)
Public Function _tpos ( _
    _axis As Integer _
) As Double
public:
double^ _tpos(
    int^ _axis
)

Parameters

_axis
Type: Int32
The _axis.

Return Value

System.Double.

See Also

Controller..::..Axis Class


closeConnection Method

Axis..::..closeConnection Method

This method closes a connection to the EtherCAT Master runtime.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool closeConnection()
Public Function closeConnection As Boolean
public:
bool^ closeConnection()

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


clrout Method

Axis..::..clrout Method

Clear drive outputs.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool clrout(
    int outputs
)
Public Function clrout ( _
    outputs As Integer _
) As Boolean
public:
bool^ clrout(
    int^ outputs
)

Parameters

outputs
Type: Int32
Outputs to clear, bit set. Upper 16 bits is global output, lower is on drive.

Return Value

true if command accepted, false otherwise.

See Also

Controller..::..Axis Class


dc_sync Method

Axis..::..dc_sync Method

This method requests DC Sync mode with the drive attached to this axis. It does not return until completely executed and the drive is updated so there could be a delay.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool dc_sync(
    int sdo_slave,
    double sync0_time,
    double sync1_time,
    double sync0_shift,
    double start_delay
)
Public Function dc_sync ( _
    sdo_slave As Integer, _
    sync0_time As Double, _
    sync1_time As Double, _
    sync0_shift As Double, _
    start_delay As Double _
) As Boolean
public:
bool^ dc_sync(
    int^ sdo_slave,
    double^ sync0_time,
    double^ sync1_time,
    double^ sync0_shift,
    double^ start_delay
)

Parameters

sdo_slave
Type: Int32
The slave address from an EtherCAT perspective, use -1 for current axis.
sync0_time
Type: Double
Sync 0 time in nanoseconds, typically the cycle time of 1 ms, 1000000.
sync1_time
Type: Double
Sync 1 time in nanoseconds.
sync0_shift
Type: Double
Sync 0 shift for PDO clock in nanoseconds, typically 0 to 250us.
start_delay
Type: Double
How long to delay in nanoseconds until attempt to implement DC sync, typically around 100 milliseconds.

Return Value

true if executes properly and drive communicated with, false otherwise.

See Also

Controller..::..Axis Class


delayMSB Method

Axis..::..delayMSB Method

Delays the specified milliseconds using an MSB delay loop.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool delayMSB(
    int time_ms
)
Public Function delayMSB ( _
    time_ms As Integer _
) As Boolean
public:
bool^ delayMSB(
    int^ time_ms
)

Parameters

time_ms
Type: Int32
Time in milliseconds to delay, delay can be done using Windows Thread.Sleep command as well and not delay using MSB level logic.

Return Value

true if delayed proper amount, false otherwise.

See Also

Controller..::..Axis Class


drive_disable Method

Axis..::..drive_disable Method

Disable the drive, turning voltage off to it. Drive will then free wheel and will continue to have its position tracked.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool drive_disable()
Public Function drive_disable As Boolean
public:
bool^ drive_disable()

Return Value

true if disabled successfully, false otherwise.

See Also

Controller..::..Axis Class


drive_enable Method

Axis..::..drive_enable Method

Enables the axis, if not already. This tells the drive to activate voltage and prepare for operation via EtherCAT.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool drive_enable()
Public Function drive_enable As Boolean
public:
bool^ drive_enable()

Return Value

true if enabled successfully, false otherwise.

See Also

Controller..::..Axis Class


gear_at Method

Axis..::..gear_at Method

Changes the gear ratio of a slaved axis to the specified values.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool gear_at(
    double numerator,
    double denominator
)
Public Function gear_at ( _
    numerator As Double, _
    denominator As Double _
) As Boolean
public:
bool^ gear_at(
    double^ numerator,
    double^ denominator
)

Parameters

numerator
Type: Double
Numerator part of ratio.
denominator
Type: Double
Denominator part of ratio.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


gear_at_in Method

Axis..::..gear_at_in Method

Changes the gear ratio of a slaved axis to the specified values over some number of master counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool gear_at_in(
    double numerator,
    double denominator,
    int master_counts
)
Public Function gear_at_in ( _
    numerator As Double, _
    denominator As Double, _
    master_counts As Integer _
) As Boolean
public:
bool^ gear_at_in(
    double^ numerator,
    double^ denominator,
    int^ master_counts
)

Parameters

numerator
Type: Double
Numerator part of ratio.
denominator
Type: Double
Denominator part of ratio.
master_counts
Type: Int32
Number of master encoder counts to wait.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


gear_at_in_after Method

Axis..::..gear_at_in_after Method

Changes the gear ratio of a slaved axis to the specified values over some number of master counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool gear_at_in_after(
    double numerator,
    double denominator,
    int master_counts,
    int slave_counts
)
Public Function gear_at_in_after ( _
    numerator As Double, _
    denominator As Double, _
    master_counts As Integer, _
    slave_counts As Integer _
) As Boolean
public:
bool^ gear_at_in_after(
    double^ numerator,
    double^ denominator,
    int^ master_counts,
    int^ slave_counts
)

Parameters

numerator
Type: Double
Numerator part of ratio.
denominator
Type: Double
Denominator part of ratio.
master_counts
Type: Int32
Number of master encoder counts to wait.
slave_counts
Type: Int32
Number of slave encoder counts to wait before begin gear_at_in.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


gear_for_in Method

Axis..::..gear_for_in Method

Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool gear_for_in(
    int slave_counts,
    int in_master_counts
)
Public Function gear_for_in ( _
    slave_counts As Integer, _
    in_master_counts As Integer _
) As Boolean
public:
bool^ gear_for_in(
    int^ slave_counts,
    int^ in_master_counts
)

Parameters

slave_counts
Type: Int32
Slave axis correction, offset.
in_master_counts
Type: Int32
Number of master counts to occur before occurs.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


gear_for_in_after Method

Axis..::..gear_for_in_after Method

Temporarily changes the gear ratio of a slaved axis such that a slave_counts correction (offset) occurs over a master-feedback displacement of master_counts after certain number of counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool gear_for_in_after(
    int slave_counts,
    int in_master_counts,
    int after_counts
)
Public Function gear_for_in_after ( _
    slave_counts As Integer, _
    in_master_counts As Integer, _
    after_counts As Integer _
) As Boolean
public:
bool^ gear_for_in_after(
    int^ slave_counts,
    int^ in_master_counts,
    int^ after_counts
)

Parameters

slave_counts
Type: Int32
Slave axis correction, offset.
in_master_counts
Type: Int32
Number of master counts to occur before occurs.
after_counts
Type: Int32
Number of slave encoder counts to occur before gear_for_in begins.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


get_drive_properties Method

Axis..::..get_drive_properties Method

Get drive properties, reads COMMAND_EXT_RESULTS drive properties all at once versus individually.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool get_drive_properties(
    ref Controller..::..Axis..::..COMMAND_EXT_RESULTS results
)
Public Function get_drive_properties ( _
    ByRef results As Controller..::..Axis..::..COMMAND_EXT_RESULTS _
) As Boolean
public:
bool^ get_drive_properties(
    Controller..::..Axis..::..COMMAND_EXT_RESULTS^% results
)

Parameters

results
Type: CTC_Incentive..::..Controller..::..Axis..::..COMMAND_EXT_RESULTS %
Extended results with drive information returned.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


getResources Method

Axis..::..getResources Method

Gets the resources.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getResources(
    ref Variant..::..VARIANT_PLC_RESOURCES blk
)
Public Function getResources ( _
    ByRef blk As Variant..::..VARIANT_PLC_RESOURCES _
) As Boolean
public:
bool^ getResources(
    Variant..::..VARIANT_PLC_RESOURCES^% blk
)

Parameters

blk
Type: CTC_Incentive..::..Variant..::..VARIANT_PLC_RESOURCES %
VARIANT_PLC_RESOURCES for reading resource information from the controller.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


getVar Method

Axis..::..getVar Method

Gets the variable.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getVar(
    Controller..::..Axis..::..MOVE_PARAM v,
    ref Variant..::..VARIANT_STORAGE var
)
Public Function getVar ( _
    v As Controller..::..Axis..::..MOVE_PARAM, _
    ByRef var As Variant..::..VARIANT_STORAGE _
) As Boolean
public:
bool^ getVar(
    Controller..::..Axis..::..MOVE_PARAM^ v,
    Variant..::..VARIANT_STORAGE^% var
)

Parameters

v
Type: CTC_Incentive..::..Controller..::..Axis..::..MOVE_PARAM
The v.
var
Type: CTC_Incentive..::..Variant..::..VARIANT_STORAGE %
The variable.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


move_at_for Method

Axis..::..move_at_for Method

Overload List

 | Name | Description
Public method | move_at_for(Double, Double, Double, Double) | Move relative, speed limited, trapazoidal.
Public method | move_at_for(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_for(Double, Double) | Move relative, speed limited, trapazoidal using default acc and dec.
Public method | move_at_for(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move relative, speed limited, trapazoidal using default acc and dec. Extended drive information

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_at_for Method (Double, Double, Double, Double)

Axis..::..move_at_for Method (Double, Double, Double, Double)

Move relative, speed limited, trapazoidal.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_for(
    double max_velocity,
    double displacement,
    double acc,
    double dec
)
Public Function move_at_for ( _
    max_velocity As Double, _
    displacement As Double, _
    acc As Double, _
    dec As Double _
) As Boolean
public:
bool^ move_at_for(
    double^ max_velocity,
    double^ displacement,
    double^ acc,
    double^ dec
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
displacement
Type: Double
Relative position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_for Overload


move_at_for Method (Double, Double, Double, Double, COMMAND_EXT_RESULTS)

Axis..::..move_at_for Method (Double, Double, Double, Double, COMMAND_EXT_RESULTS%)

Move relative, speed limited, trapazoidal. Extended drive information results.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_for(
    double max_velocity,
    double displacement,
    double acc,
    double dec,
    ref Controller..::..Axis..::..COMMAND_EXT_RESULTS results
)
Public Function move_at_for ( _
    max_velocity As Double, _
    displacement As Double, _
    acc As Double, _
    dec As Double, _
    ByRef results As Controller..::..Axis..::..COMMAND_EXT_RESULTS _
) As Boolean
public:
bool^ move_at_for(
    double^ max_velocity,
    double^ displacement,
    double^ acc,
    double^ dec,
    Controller..::..Axis..::..COMMAND_EXT_RESULTS^% results
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
displacement
Type: Double
Relative position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.
results
Type: CTC_Incentive..::..Controller..::..Axis..::..COMMAND_EXT_RESULTS %
Extended results with drive information returned.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_for Overload


move_at_for Method (Double, Double)

Axis..::..move_at_for Method (Double, Double)

Move relative, speed limited, trapazoidal using default acc and dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_for(
    double max_velocity,
    double displacement
)
Public Function move_at_for ( _
    max_velocity As Double, _
    displacement As Double _
) As Boolean
public:
bool^ move_at_for(
    double^ max_velocity,
    double^ displacement
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
displacement
Type: Double
Relative position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_for Overload


move_at_for Method (Double, Double, COMMAND_EXT_RESULTS)

Axis..::..move_at_for Method (Double, Double, COMMAND_EXT_RESULTS%)

Move relative, speed limited, trapazoidal using default acc and dec. Extended drive information

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_for(
    double max_velocity,
    double displacement,
    ref Controller..::..Axis..::..COMMAND_EXT_RESULTS results
)
Public Function move_at_for ( _
    max_velocity As Double, _
    displacement As Double, _
    ByRef results As Controller..::..Axis..::..COMMAND_EXT_RESULTS _
) As Boolean
public:
bool^ move_at_for(
    double^ max_velocity,
    double^ displacement,
    Controller..::..Axis..::..COMMAND_EXT_RESULTS^% results
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
displacement
Type: Double
Relative position, user units.
results
Type: CTC_Incentive..::..Controller..::..Axis..::..COMMAND_EXT_RESULTS %
Extended results with drive information returned.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_for Overload


move_at_to Method

Axis..::..move_at_to Method

Overload List

 | Name | Description
Public method | move_at_to(Double, Double, Double, Double) | Move absolute, speed limited, trapazoidal.
Public method | move_at_to(Double, Double, Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal. Extended drive information results.
Public method | move_at_to(Double, Double) | Move absolute, speed limited, trapazoidal, use default acc and dec.
Public method | move_at_to(Double, Double, Controller..::..Axis..::..COMMAND_EXT_RESULTS%) | Move absolute, speed limited, trapazoidal, use default acc and dec. Extended drive information results.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_at_to Method (Double, Double, Double, Double)

Axis..::..move_at_to Method (Double, Double, Double, Double)

Move absolute, speed limited, trapazoidal.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_to(
    double max_velocity,
    double position,
    double acc,
    double dec
)
Public Function move_at_to ( _
    max_velocity As Double, _
    position As Double, _
    acc As Double, _
    dec As Double _
) As Boolean
public:
bool^ move_at_to(
    double^ max_velocity,
    double^ position,
    double^ acc,
    double^ dec
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
position
Type: Double
Absolute end position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_to Overload


move_at_to Method (Double, Double, Double, Double, COMMAND_EXT_RESULTS)

Axis..::..move_at_to Method (Double, Double, Double, Double, COMMAND_EXT_RESULTS%)

Move absolute, speed limited, trapazoidal. Extended drive information results.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_to(
    double max_velocity,
    double position,
    double acc,
    double dec,
    ref Controller..::..Axis..::..COMMAND_EXT_RESULTS results
)
Public Function move_at_to ( _
    max_velocity As Double, _
    position As Double, _
    acc As Double, _
    dec As Double, _
    ByRef results As Controller..::..Axis..::..COMMAND_EXT_RESULTS _
) As Boolean
public:
bool^ move_at_to(
    double^ max_velocity,
    double^ position,
    double^ acc,
    double^ dec,
    Controller..::..Axis..::..COMMAND_EXT_RESULTS^% results
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
position
Type: Double
Absolute end position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.
results
Type: CTC_Incentive..::..Controller..::..Axis..::..COMMAND_EXT_RESULTS %
Extended results with drive information returned.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_to Overload


move_at_to Method (Double, Double)

Axis..::..move_at_to Method (Double, Double)

Move absolute, speed limited, trapazoidal, use default acc and dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_to(
    double max_velocity,
    double position
)
Public Function move_at_to ( _
    max_velocity As Double, _
    position As Double _
) As Boolean
public:
bool^ move_at_to(
    double^ max_velocity,
    double^ position
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
position
Type: Double
Absolute end position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_to Overload


move_at_to Method (Double, Double, COMMAND_EXT_RESULTS)

Axis..::..move_at_to Method (Double, Double, COMMAND_EXT_RESULTS%)

Move absolute, speed limited, trapazoidal, use default acc and dec. Extended drive information results.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_at_to(
    double max_velocity,
    double position,
    ref Controller..::..Axis..::..COMMAND_EXT_RESULTS results
)
Public Function move_at_to ( _
    max_velocity As Double, _
    position As Double, _
    ByRef results As Controller..::..Axis..::..COMMAND_EXT_RESULTS _
) As Boolean
public:
bool^ move_at_to(
    double^ max_velocity,
    double^ position,
    Controller..::..Axis..::..COMMAND_EXT_RESULTS^% results
)

Parameters

max_velocity
Type: Double
Maximum velocity to attain, if not possible becomes a triangular move, user units/sec.
position
Type: Double
Absolute end position, user units.
results
Type: CTC_Incentive..::..Controller..::..Axis..::..COMMAND_EXT_RESULTS %
Extended results with drive information returned.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_at_to Overload


move_for Method

Axis..::..move_for Method

Overload List

 | Name | Description
Public method | move_for(Double, Double, Double) | Move relative, triangular.
Public method | move_for(Double) | Move relative, triangular. Uses default acc and dec.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_for Method (Double, Double, Double)

Axis..::..move_for Method (Double, Double, Double)

Move relative, triangular.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_for(
    double displacement,
    double acc,
    double dec
)
Public Function move_for ( _
    displacement As Double, _
    acc As Double, _
    dec As Double _
) As Boolean
public:
bool^ move_for(
    double^ displacement,
    double^ acc,
    double^ dec
)

Parameters

displacement
Type: Double
Relative position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_for Overload


move_for Method (Double)

Axis..::..move_for Method (Double)

Move relative, triangular. Uses default acc and dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_for(
    double displacement
)
Public Function move_for ( _
    displacement As Double _
) As Boolean
public:
bool^ move_for(
    double^ displacement
)

Parameters

displacement
Type: Double
Relative position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_for Overload


move_in_for Method

Axis..::..move_in_for Method

Overload List

 | Name | Description
Public method | move_in_for(Double, Double, Double) | Move relative, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_for(Double, Double) | Move relative, trapazoidal, in time requested.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_in_for Method (Double, Double, Double)

Axis..::..move_in_for Method (Double, Double, Double)

Move relative, trapazoidal, in time requested with acc/dec ramp multiplier.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_in_for(
    double time_ms,
    double displacement,
    double acc_dec_multiplier
)
Public Function move_in_for ( _
    time_ms As Double, _
    displacement As Double, _
    acc_dec_multiplier As Double _
) As Boolean
public:
bool^ move_in_for(
    double^ time_ms,
    double^ displacement,
    double^ acc_dec_multiplier
)

Parameters

time_ms
Type: Double
Time in milliseconds to make the move.
displacement
Type: Double
Relative desired position, user units.
acc_dec_multiplier
Type: Double
Default acc/dec is ramp multiplier.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_in_for Overload


move_in_for Method (Double, Double)

Axis..::..move_in_for Method (Double, Double)

Move relative, trapazoidal, in time requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_in_for(
    double time_ms,
    double displacment
)
Public Function move_in_for ( _
    time_ms As Double, _
    displacment As Double _
) As Boolean
public:
bool^ move_in_for(
    double^ time_ms,
    double^ displacment
)

Parameters

time_ms
Type: Double
Time in milliseconds to make the move.
displacment
Type: Double
Relative desired position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_in_for Overload


move_in_to Method

Axis..::..move_in_to Method

Overload List

 | Name | Description
Public method | move_in_to(Double, Double, Double) | Move absolute, trapazoidal, in time requested with acc/dec ramp multiplier.
Public method | move_in_to(Double, Double) | Move absolute, trapazoidal, in time requested.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_in_to Method (Double, Double, Double)

Axis..::..move_in_to Method (Double, Double, Double)

Move absolute, trapazoidal, in time requested with acc/dec ramp multiplier.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_in_to(
    double time_ms,
    double position,
    double acc_dec_multiplier
)
Public Function move_in_to ( _
    time_ms As Double, _
    position As Double, _
    acc_dec_multiplier As Double _
) As Boolean
public:
bool^ move_in_to(
    double^ time_ms,
    double^ position,
    double^ acc_dec_multiplier
)

Parameters

time_ms
Type: Double
Time in milliseconds to make the move.
position
Type: Double
Absolute desired end position, user units.
acc_dec_multiplier
Type: Double
Default acc/dec is ramp multiplier.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_in_to Overload


move_in_to Method (Double, Double)

Axis..::..move_in_to Method (Double, Double)

Move absolute, trapazoidal, in time requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_in_to(
    double time_ms,
    double position
)
Public Function move_in_to ( _
    time_ms As Double, _
    position As Double _
) As Boolean
public:
bool^ move_in_to(
    double^ time_ms,
    double^ position
)

Parameters

time_ms
Type: Double
Time in milliseconds to make the move.
position
Type: Double
Absolute desired end position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_in_to Overload


move_to Method

Axis..::..move_to Method

Overload List

 | Name | Description
Public method | move_to(Double, Double, Double) | Move absolute, triangular.
Public method | move_to(Double) | Move absolute, triangular. Uses default acc and dec.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


move_to Method (Double, Double, Double)

Axis..::..move_to Method (Double, Double, Double)

Move absolute, triangular.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_to(
    double position,
    double acc,
    double dec
)
Public Function move_to ( _
    position As Double, _
    acc As Double, _
    dec As Double _
) As Boolean
public:
bool^ move_to(
    double^ position,
    double^ acc,
    double^ dec
)

Parameters

position
Type: Double
Absolute end position, user units.
acc
Type: Double
Acceleration rate, user units/sec/sec.
dec
Type: Double
Deceleration rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_to Overload


move_to Method (Double)

Axis..::..move_to Method (Double)

Move absolute, triangular. Uses default acc and dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_to(
    double position
)
Public Function move_to ( _
    position As Double _
) As Boolean
public:
bool^ move_to(
    double^ position
)

Parameters

position
Type: Double
Absolute end position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class
move_to Overload


move_trap_for Method

Axis..::..move_trap_for Method

Move relative, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_trap_for(
    double displacement,
    double rate
)
Public Function move_trap_for ( _
    displacement As Double, _
    rate As Double _
) As Boolean
public:
bool^ move_trap_for(
    double^ displacement,
    double^ rate
)

Parameters

displacement
Type: Double
Relative position, user units.
rate
Type: Double
Acc/dec rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


move_trap_to Method

Axis..::..move_trap_to Method

Move absolute, trapazoidal 1/3 acc, 1/3 constant, 1/3 dec.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool move_trap_to(
    double position,
    double rate
)
Public Function move_trap_to ( _
    position As Double, _
    rate As Double _
) As Boolean
public:
bool^ move_trap_to(
    double^ position,
    double^ rate
)

Parameters

position
Type: Double
Absolute end position, user units.
rate
Type: Double
Acc/dec rate, user units/sec/sec.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


new_endposition Method

Axis..::..new_endposition Method

Modifies the end point of an active move command to an absolute position. If not moving then ignored.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool new_endposition(
    double position,
    double rate
)
Public Function new_endposition ( _
    position As Double, _
    rate As Double _
) As Boolean
public:
bool^ new_endposition(
    double^ position,
    double^ rate
)

Parameters

position
Type: Double
New absolute end position.
rate
Type: Double
Acc/dec rate for new position.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


new_endposition_relative Method

Axis..::..new_endposition_relative Method

Modifies the end point of an active move command relative to current position. If not moving then ignored.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool new_endposition_relative(
    double displacement,
    double rate
)
Public Function new_endposition_relative ( _
    displacement As Double, _
    rate As Double _
) As Boolean
public:
bool^ new_endposition_relative(
    double^ displacement,
    double^ rate
)

Parameters

displacement
Type: Double
New relative position.
rate
Type: Double
Acc/dec rate for new position.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


offset_position Method

Axis..::..offset_position Method

Modify the target and feedback positions simultaneously by adding the offset to both.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool offset_position(
    double value
)
Public Function offset_position ( _
    value As Double _
) As Boolean
public:
bool^ offset_position(
    double^ value
)

Parameters

value
Type: Double
Amount to offset in user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


offset_position_counts Method

Axis..::..offset_position_counts Method

Modify the target and feedback positions simultaneously by adding the offset to both.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool offset_position_counts(
    double counts
)
Public Function offset_position_counts ( _
    counts As Double _
) As Boolean
public:
bool^ offset_position_counts(
    double^ counts
)

Parameters

counts
Type: Double
Amount to offset in counts.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


offset_slave_by Method

Axis..::..offset_slave_by Method

Offsets the position (and therefore phase) of the axis such that a 'slavecounts' correction (offset) occurs over a period of 'time'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool offset_slave_by(
    int slave_counts,
    double time_sec
)
Public Function offset_slave_by ( _
    slave_counts As Integer, _
    time_sec As Double _
) As Boolean
public:
bool^ offset_slave_by(
    int^ slave_counts,
    double^ time_sec
)

Parameters

slave_counts
Type: Int32
Slave axis correction, offset.
time_sec
Type: Double
Time in seconds in which to occur.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


openConnection Method

Axis..::..openConnection Method

This method opens a connection to the EtherCAT Master runtime for motion control.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool openConnection(
    string node,
    string our_mailbox_name
)
Public Function openConnection ( _
    node As String, _
    our_mailbox_name As String _
) As Boolean
public:
bool^ openConnection(
    String^ node,
    String^ our_mailbox_name
)

Parameters

node
Type: String
EtherCAT runtime name, typically CTECAT_1.
our_mailbox_name
Type: String
Base name of our queue, limited to 8 characters.

Return Value

true if successful, false if failed.

Exceptions

Exception | Condition
[INtimeException] |

See Also

Controller..::..Axis Class


pulse Method

Axis..::..pulse Method

Pulse the specifed output for the desired number of milliseconds.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool pulse(
    int output,
    int time_ms
)
Public Function pulse ( _
    output As Integer, _
    time_ms As Integer _
) As Boolean
public:
bool^ pulse(
    int^ output,
    int^ time_ms
)

Parameters

output
Type: Int32
The output number to pulse.
time_ms
Type: Int32
The time_ms in milliseconds for pulse width.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


sdo_read Method

Axis..::..sdo_read Method

Read an object property of the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool sdo_read(
    int sdo_slave,
    int object_num,
    int index,
    Controller..::..Axis..::..ECAT_OBJECT_SIZE length,
    ref Controller..::..Axis..::..SDO_READ_RESULTS results
)
Public Function sdo_read ( _
    sdo_slave As Integer, _
    object_num As Integer, _
    index As Integer, _
    length As Controller..::..Axis..::..ECAT_OBJECT_SIZE, _
    ByRef results As Controller..::..Axis..::..SDO_READ_RESULTS _
) As Boolean
public:
bool^ sdo_read(
    int^ sdo_slave,
    int^ object_num,
    int^ index,
    Controller..::..Axis..::..ECAT_OBJECT_SIZE^ length,
    Controller..::..Axis..::..SDO_READ_RESULTS^% results
)

Parameters

sdo_slave
Type: Int32
The sdo slave address or -1 if current axis.
object_num
Type: Int32
The object number to access in the drive as defined by manufacturer manual.
index
Type: Int32
The index of the object in the drive, 0 to N.
length
Type: CTC_Incentive..::..Controller..::..Axis..::..ECAT_OBJECT_SIZE
The size of the object as defined by EtherCAT, ECAT_OBJECT_SIZE.
results
Type: CTC_Incentive..::..Controller..::..Axis..::..SDO_READ_RESULTS %
SDO_READ_RESULTS results contains command result and value of object on return.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


sdo_write Method

Axis..::..sdo_write Method

Write an object property to the drive over EtherCAT. This call is blocking and can take about 7 milliseconds to execute. SDO access should only be done intermittantly.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool sdo_write(
    int sdo_slave,
    int object_num,
    int index,
    Controller..::..Axis..::..ECAT_OBJECT_SIZE length,
    int value
)
Public Function sdo_write ( _
    sdo_slave As Integer, _
    object_num As Integer, _
    index As Integer, _
    length As Controller..::..Axis..::..ECAT_OBJECT_SIZE, _
    value As Integer _
) As Boolean
public:
bool^ sdo_write(
    int^ sdo_slave,
    int^ object_num,
    int^ index,
    Controller..::..Axis..::..ECAT_OBJECT_SIZE^ length,
    int^ value
)

Parameters

sdo_slave
Type: Int32
The sdo slave address or -1 if current axis.
object_num
Type: Int32
The object number to access in the drive as defined by manufacturer manual.
index
Type: Int32
The index of the object in the drive, 0 to N.
length
Type: CTC_Incentive..::..Controller..::..Axis..::..ECAT_OBJECT_SIZE
The size of the object as defined by EtherCAT, ECAT_OBJECT_SIZE.
value
Type: Int32
Data value to write to EtherCAT object.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_accdec_to_for Method

Axis..::..segmove_accdec_to_for Method

Adds an acc/dec segment from the current velocity to the new 'velocity' over some 'displacement'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_accdec_to_for(
    int table,
    double velocity,
    double displacement
)
Public Function segmove_accdec_to_for ( _
    table As Integer, _
    velocity As Double, _
    displacement As Double _
) As Boolean
public:
bool^ segmove_accdec_to_for(
    int^ table,
    double^ velocity,
    double^ displacement
)

Parameters

table
Type: Int32
which table to add to 1 to 16.
velocity
Type: Double
velocity, user-units/sec.
displacement
Type: Double
incremental position, user-units.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_accdec_to_using Method

Axis..::..segmove_accdec_to_using Method

Adds an acc/dec segment from the current velocity to the new 'velocity' at the specified 'rate'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_accdec_to_using(
    int table,
    double velocity,
    double rate
)
Public Function segmove_accdec_to_using ( _
    table As Integer, _
    velocity As Double, _
    rate As Double _
) As Boolean
public:
bool^ segmove_accdec_to_using(
    int^ table,
    double^ velocity,
    double^ rate
)

Parameters

table
Type: Int32
which table to add to 1 to 16.
velocity
Type: Double
velocity, user-units/sec.
rate
Type: Double
acceleration/deceleration rate, user-units/sec/sec.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_clear Method

Axis..::..segmove_clear Method

Clears the specified segment table.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_clear(
    int table
)
Public Function segmove_clear ( _
    table As Integer _
) As Boolean
public:
bool^ segmove_clear(
    int^ table
)

Parameters

table
Type: Int32
desired table number, 1 to 16.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_slew_until_position Method

Axis..::..segmove_slew_until_position Method

This method adds a constant velocity segment until reaching some specified absolute 'position' from the start of the profile. Prior segments in the table must represent movement before this command is accedpted otherwise an error will occur.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_slew_until_position(
    int table,
    double position
)
Public Function segmove_slew_until_position ( _
    table As Integer, _
    position As Double _
) As Boolean
public:
bool^ segmove_slew_until_position(
    int^ table,
    double^ position
)

Parameters

table
Type: Int32
which table to add to 1 to 16.
position
Type: Double
desired position, user units.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_start_relative Method

Axis..::..segmove_start_relative Method

Starts a relative segmented move, 'zero feedback position' occurs automatically upon executing this command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_start_relative(
    int table
)
Public Function segmove_start_relative ( _
    table As Integer _
) As Boolean
public:
bool^ segmove_start_relative(
    int^ table
)

Parameters

table
Type: Int32
which table to add to 1 to 16.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


segmove_stop_at Method

Axis..::..segmove_stop_at Method

Stops motion at the specified 'position', with a given 'rate'. This will cause motion to stop at an absolute position at the specified decelaration rate. Prior segments in the table must represent movement before this command is accepted.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool segmove_stop_at(
    int table,
    double position,
    double rate
)
Public Function segmove_stop_at ( _
    table As Integer, _
    position As Double, _
    rate As Double _
) As Boolean
public:
bool^ segmove_stop_at(
    int^ table,
    double^ position,
    double^ rate
)

Parameters

table
Type: Int32
which table to add to 1 to 16.
position
Type: Double
position to stop at, user-units.
rate
Type: Double
acceleration/deceleration rate, user-units/sec/sec.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


set_capture Method

Axis..::..set_capture Method

Overload List

 | Name | Description
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32, Int32, Boolean) | Initializes the parameters to be used for all captures on this axis, specifying the input to use and the optional gated input. If gating is specified then the specified gating input must be at the specified gating state.
Public method | set_capture(Controller..::..Axis..::..CAPTURE_TRANSISTIONS, Int32) | Initializes the parameters to be used for all captures on this axis, specifying the input to use.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


set_capture Method (CAPTURE_TRANSISTIONS, Int32, Int32, Boolean)

Axis..::..set_capture Method (CAPTURE_TRANSISTIONS, Int32, Int32, Boolean)

Initializes the parameters to be used for all captures on this axis, specifying the input to use and the optional gated input. If gating is specified then the specified gating input must be at the specified gating state.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_capture(
    Controller..::..Axis..::..CAPTURE_TRANSISTIONS transistion,
    int input,
    int gateinput,
    bool gatestate
)
Public Function set_capture ( _
    transistion As Controller..::..Axis..::..CAPTURE_TRANSISTIONS, _
    input As Integer, _
    gateinput As Integer, _
    gatestate As Boolean _
) As Boolean
public:
bool^ set_capture(
    Controller..::..Axis..::..CAPTURE_TRANSISTIONS^ transistion,
    int^ input,
    int^ gateinput,
    bool^ gatestate
)

Parameters

transistion
Type: CTC_Incentive..::..Controller..::..Axis..::..CAPTURE_TRANSISTIONS
CAPTURE_TRANSISTIONS RISE, FALL, or EDGE, specifying what looking for with respect to 'input'.
input
Type: Int32
Input #1 to 10.
gateinput
Type: Int32
0 if not used else gate input #1 to 10.
gatestate
Type: Boolean
State of 'gateinput' looking for before monitor for 'input'.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class
set_capture Overload


set_capture Method (CAPTURE_TRANSISTIONS, Int32)

Axis..::..set_capture Method (CAPTURE_TRANSISTIONS, Int32)

Initializes the parameters to be used for all captures on this axis, specifying the input to use.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_capture(
    Controller..::..Axis..::..CAPTURE_TRANSISTIONS transistion,
    int input
)
Public Function set_capture ( _
    transistion As Controller..::..Axis..::..CAPTURE_TRANSISTIONS, _
    input As Integer _
) As Boolean
public:
bool^ set_capture(
    Controller..::..Axis..::..CAPTURE_TRANSISTIONS^ transistion,
    int^ input
)

Parameters

transistion
Type: CTC_Incentive..::..Controller..::..Axis..::..CAPTURE_TRANSISTIONS
CAPTURE_TRANSISTIONS RISE, FALL, or EDGE, specifying what looking for with respect to 'input'.
input
Type: Int32
Input #1 to 10.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class
set_capture Overload


set_capwin_range Method

Axis..::..set_capwin_range Method

Initializes a window to be monitored for valid captures to occur, anything outside this window is considered invalid and ignored.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_capwin_range(
    long start,
    long end,
    Controller..::..Axis..::..CAP_REFERENCE reference,
    bool arm
)
Public Function set_capwin_range ( _
    start As Long, _
    end As Long, _
    reference As Controller..::..Axis..::..CAP_REFERENCE, _
    arm As Boolean _
) As Boolean
public:
bool^ set_capwin_range(
    long long^ start,
    long long^ end,
    Controller..::..Axis..::..CAP_REFERENCE^ reference,
    bool^ arm
)

Parameters

start
Type: Int64
Start window position to compare against 'reference', 'reference' >= 'start'.
end
Type: Int64
End window position to compare against 'reference', 'reference' less than or = 'end'.
reference
Type: CTC_Incentive..::..Controller..::..Axis..::..CAP_REFERENCE
The encoder count scaled reference variable to compare to.
arm
Type: Boolean
Set true to arm else use the Wait or On command to arm.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


set_common_bit Method

Axis..::..set_common_bit Method

Set_common_bits the specified number.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_common_bit(
    int number,
    bool state
)
Public Function set_common_bit ( _
    number As Integer, _
    state As Boolean _
) As Boolean
public:
bool^ set_common_bit(
    int^ number,
    bool^ state
)

Parameters

number
Type: Int32
Common bit number, 1 to 255.
state
Type: Boolean
If true set the bit, else clear.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


set_common_var Method

Axis..::..set_common_var Method

Sets the common var, 1 to 255 to the specified value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_common_var(
    int number,
    int value
)
Public Function set_common_var ( _
    number As Integer, _
    value As Integer _
) As Boolean
public:
bool^ set_common_var(
    int^ number,
    int^ value
)

Parameters

number
Type: Int32
Common var number, 1 to 255.
value
Type: Int32
Value to set the common var to.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


set_feedback_position Method

Axis..::..set_feedback_position Method

Set feedback position.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_feedback_position(
    double position
)
Public Function set_feedback_position ( _
    position As Double _
) As Boolean
public:
bool^ set_feedback_position(
    double^ position
)

Parameters

position
Type: Double
New feedback position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


set_master Method

Axis..::..set_master Method

Sets the source of the master axis encoder.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_master(
    Controller..::..Axis..::..MASTER_MODES master_source_type
)
Public Function set_master ( _
    master_source_type As Controller..::..Axis..::..MASTER_MODES _
) As Boolean
public:
bool^ set_master(
    Controller..::..Axis..::..MASTER_MODES^ master_source_type
)

Parameters

master_source_type
Type: CTC_Incentive..::..Controller..::..Axis..::..MASTER_MODES
Master encoder source type is FEEDBACK (fpos), TARGET (tpos), VIRTUAL.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


set_mode Method

Axis..::..set_mode Method

Set desired operating mode of the axis, positioning or tracking.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_mode(
    bool tracking
)
Public Function set_mode ( _
    tracking As Boolean _
) As Boolean
public:
bool^ set_mode(
    bool^ tracking
)

Parameters

tracking
Type: Boolean
false = position , true = tracking.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


set_simulated_feedback Method

Axis..::..set_simulated_feedback Method

Set simulated feedback position mode (true/false).

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_simulated_feedback(
    bool on
)
Public Function set_simulated_feedback ( _
    on As Boolean _
) As Boolean
public:
bool^ set_simulated_feedback(
    bool^ on
)

Parameters

on
Type: Boolean
True to enable, false to disable.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


set_target_position Method

Axis..::..set_target_position Method

Set target position.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool set_target_position(
    double position
)
Public Function set_target_position ( _
    position As Double _
) As Boolean
public:
bool^ set_target_position(
    double^ position
)

Parameters

position
Type: Double
New target position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


setout Method

Axis..::..setout Method

Set drive outputs.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool setout(
    int outputs
)
Public Function setout ( _
    outputs As Integer _
) As Boolean
public:
bool^ setout(
    int^ outputs
)

Parameters

outputs
Type: Int32
Outputs to set, bit set. Upper 16 bits is global output, lower is on drive.

Return Value

true if command accepted, false otherwise.

See Also

Controller..::..Axis Class


setVar Method

Axis..::..setVar Method

Sets the variable.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool setVar(
    Controller..::..Axis..::..MOVE_PARAM v
)
Public Function setVar ( _
    v As Controller..::..Axis..::..MOVE_PARAM _
) As Boolean
public:
bool^ setVar(
    Controller..::..Axis..::..MOVE_PARAM^ v
)

Parameters

v
Type: CTC_Incentive..::..Controller..::..Axis..::..MOVE_PARAM
MOVE_PARAM, move request definitions.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


slew_at_in Method

Axis..::..slew_at_in Method

Alters the current slew velocity, changing smoothly over the specified time. For immediate change set time to 0.0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool slew_at_in(
    double velocity,
    double time_sec
)
Public Function slew_at_in ( _
    velocity As Double, _
    time_sec As Double _
) As Boolean
public:
bool^ slew_at_in(
    double^ velocity,
    double^ time_sec
)

Parameters

velocity
Type: Double
new slew velocity, user units/sec.
time_sec
Type: Double
time in seconds.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


slew_begin Method

Axis..::..slew_begin Method

Changes the operating mode of the axis to slewing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool slew_begin()
Public Function slew_begin As Boolean
public:
bool^ slew_begin()

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


slew_end Method

Axis..::..slew_end Method

Changes the operating mode of the axis to positioning from slewing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool slew_end()
Public Function slew_end As Boolean
public:
bool^ slew_end()

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


slew_for Method

Axis..::..slew_for Method

Alters the current slew velocity, over time, to a slew velocity of 0.0 such that some displacement is consumed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool slew_for(
    double displacement
)
Public Function slew_for ( _
    displacement As Double _
) As Boolean
public:
bool^ slew_for(
    double^ displacement
)

Parameters

displacement
Type: Double
ending relative slew position, user units.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


stop Method

Axis..::..stop Method

Overload List

 | Name | Description
Public method | stop()()()() | Stops the axis quickly.
Public method | stop(Single) | Stops the axis at the specified slew rate.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


stop Method

Axis..::..stop Method

Stops the axis quickly.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool stop()
Public Function stop As Boolean
public:
bool^ stop()

Return Value

true if command accepted, false otherwise.

See Also

Controller..::..Axis Class
stop Overload


stop Method (Single)

Axis..::..stop Method (Single)

Stops the axis at the specified slew rate.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool stop(
    float rate
)
Public Function stop ( _
    rate As Single _
) As Boolean
public:
bool^ stop(
    float^ rate
)

Parameters

rate
Type: Single
Deceleration, user units.

Return Value

true if command accepted, false otherwise.

See Also

Controller..::..Axis Class
stop Overload


table_clear Method

Axis..::..table_clear Method

Clear the specified table of all entries.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_clear(
    int table
)
Public Function table_clear ( _
    table As Integer _
) As Boolean
public:
bool^ table_clear(
    int^ table
)

Parameters

table
Type: Int32
table to clear

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


table_continue Method

Axis..::..table_continue Method

Continues a cam table that was stopped by the 'stop table' command. Note that this command should only be used if the master position stopped at the beginning of the next table row position otherwise any row that is currently being executed during a 'stop table' will be re-executed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_continue(
    int table
)
Public Function table_continue ( _
    table As Integer _
) As Boolean
public:
bool^ table_continue(
    int^ table
)

Parameters

table
Type: Int32
Which table to add to 1 to 16.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


table_precompute Method

Axis..::..table_precompute Method

Readies a table for use by a spline/CAM motion. After points have been added to a table, there are a series of computations that need to occur before the table can be utilized for spline and CAM motion operations.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_precompute(
    int table
)
Public Function table_precompute ( _
    table As Integer _
) As Boolean
public:
bool^ table_precompute(
    int^ table
)

Parameters

table
Type: Int32
Which table to add to 1 to 16..

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


table_start Method

Axis..::..table_start Method

Starts spline motion using the specified table.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_start(
    int table,
    Controller..::..Axis..::..TABLE_MOVES imethod,
    double tscale,
    double rpscale,
    int repeatcount
)
Public Function table_start ( _
    table As Integer, _
    imethod As Controller..::..Axis..::..TABLE_MOVES, _
    tscale As Double, _
    rpscale As Double, _
    repeatcount As Integer _
) As Boolean
public:
bool^ table_start(
    int^ table,
    Controller..::..Axis..::..TABLE_MOVES^ imethod,
    double^ tscale,
    double^ rpscale,
    int^ repeatcount
)

Parameters

table
Type: Int32
the table to utilize for motion, 1 to 16.
imethod
Type: CTC_Incentive..::..Controller..::..Axis..::..TABLE_MOVES
Type of TABLE_MOVES motion; LINEAR, QUADRATIC, or CUBIC.
tscale
Type: Double
Time scale factor: the values in the 'x' column (time) in the table are effectively divided by this number.
rpscale
Type: Double
Relative position scle factor: the values in the 'y' column (relative position) in the table are effectively multiplied by this number.
repeatcount
Type: Int32
Number of times to run through the table.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


table_start_cam Method

Axis..::..table_start_cam Method

Starts CAM motion using the specified table.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_start_cam(
    int table,
    Controller..::..Axis..::..TABLE_MOVES imethod,
    double mpscale,
    double spscale,
    int repeatcount
)
Public Function table_start_cam ( _
    table As Integer, _
    imethod As Controller..::..Axis..::..TABLE_MOVES, _
    mpscale As Double, _
    spscale As Double, _
    repeatcount As Integer _
) As Boolean
public:
bool^ table_start_cam(
    int^ table,
    Controller..::..Axis..::..TABLE_MOVES^ imethod,
    double^ mpscale,
    double^ spscale,
    int^ repeatcount
)

Parameters

table
Type: Int32
The table to utilize for motion, 1 to 16.
imethod
Type: CTC_Incentive..::..Controller..::..Axis..::..TABLE_MOVES
Type of TABLE_MOVES motion; LINEAR, QUADRATIC, or CUBIC.
mpscale
Type: Double
Master-position scale factor: the values in the 'x' column (master-position) in the table are effectively divided by this number.
spscale
Type: Double
Relative slave-position scale factor: the values in the 'y' column (relative slave position) in the table are effectively multiplied by this number.
repeatcount
Type: Int32
Number of times to run through the table.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


table_stop Method

Axis..::..table_stop Method

Stops spline or CAM motion. If in CAM motion then the current table state is saved in case a 'table continue' command is executed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool table_stop()
Public Function table_stop As Boolean
public:
bool^ table_stop()

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


wait_capture Method

Axis..::..wait_capture Method

Waits for the capture and arms the capture input. If the capture occurs control will be returned else returns after the specified 'limit'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_capture(
    long limit
)
Public Function wait_capture ( _
    limit As Long _
) As Boolean
public:
bool^ wait_capture(
    long long^ limit
)

Parameters

limit
Type: Int64
Master encoder count limit, zero to ignore.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


wait_common_bit Method

Axis..::..wait_common_bit Method

Wait for a common bit to be true or false.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_common_bit(
    int number,
    bool set
)
Public Function wait_common_bit ( _
    number As Integer, _
    set As Boolean _
) As Boolean
public:
bool^ wait_common_bit(
    int^ number,
    bool^ set
)

Parameters

number
Type: Int32
Common bit number, 1 to 255.
set
Type: Boolean
If true wait for set, else clear.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


wait_common_var Method

Axis..::..wait_common_var Method

Overload List

 | Name | Description
Public method | wait_common_var(Int32, Int32) | Wait for a common var to be a certain value. This method will wait until the condition is true to get a message back.
Public method | wait_common_var(Int32, Boolean, Int32, Int32) | Wait for a common var to be in or out of range. This method will wait until the condition is true to get a message back.

See Also

Controller..::..Axis Class
Controller..::..Axis Members


wait_common_var Method (Int32, Int32)

Axis..::..wait_common_var Method (Int32, Int32)

Wait for a common var to be a certain value. This method will wait until the condition is true to get a message back.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_common_var(
    int number,
    int target_value
)
Public Function wait_common_var ( _
    number As Integer, _
    target_value As Integer _
) As Boolean
public:
bool^ wait_common_var(
    int^ number,
    int^ target_value
)

Parameters

number
Type: Int32
Common var number, 1 to 255.
target_value
Type: Int32
Value to wait for before return.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class
wait_common_var Overload


wait_common_var Method (Int32, Boolean, Int32, Int32)

Axis..::..wait_common_var Method (Int32, Boolean, Int32, Int32)

Wait for a common var to be in or out of range. This method will wait until the condition is true to get a message back.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_common_var(
    int number,
    bool in_range,
    int range_from,
    int range_to
)
Public Function wait_common_var ( _
    number As Integer, _
    in_range As Boolean, _
    range_from As Integer, _
    range_to As Integer _
) As Boolean
public:
bool^ wait_common_var(
    int^ number,
    bool^ in_range,
    int^ range_from,
    int^ range_to
)

Parameters

number
Type: Int32
Common var number, 1 to 255.
in_range
Type: Boolean
If true then inclusive range, else exclusive.
range_from
Type: Int32
From range value.
range_to
Type: Int32
To range value.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class
wait_common_var Overload


wait_for_in_pos Method

Axis..::..wait_for_in_pos Method

Wait for motion in position (inpos == 1) or timeout.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_for_in_pos(
    int ms_timeout
)
Public Function wait_for_in_pos ( _
    ms_timeout As Integer _
) As Boolean
public:
bool^ wait_for_in_pos(
    int^ ms_timeout
)

Parameters

ms_timeout
Type: Int32
Number of milliseconds to wait until motion is in position, -1 is forever.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


wait_master Method

Axis..::..wait_master Method

Waits until the specified number of master encoder counts has been generated.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_master(
    int counts
)
Public Function wait_master ( _
    counts As Integer _
) As Boolean
public:
bool^ wait_master(
    int^ counts
)

Parameters

counts
Type: Int32
Number of master encoder counts.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


wait_slave Method

Axis..::..wait_slave Method

Waits until the specified number of slave (target position) counts has been generated.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool wait_slave(
    int counts
)
Public Function wait_slave ( _
    counts As Integer _
) As Boolean
public:
bool^ wait_slave(
    int^ counts
)

Parameters

counts
Type: Int32
Number of master encoder counts.

Return Value

true if successful, false if failed.

See Also

Controller..::..Axis Class


zero_counters Method

Axis..::..zero_counters Method

Zero temporary master or slave counters

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool zero_counters(
    bool master
)
Public Function zero_counters ( _
    master As Boolean _
) As Boolean
public:
bool^ zero_counters(
    bool^ master
)

Parameters

master
Type: Boolean
If set to true [master], else slave.

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


zero_feedback_position Method

Axis..::..zero_feedback_position Method

Zeros the feedback position, but maintains the following error. Operates the same as 'zero feedback position'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool zero_feedback_position()
Public Function zero_feedback_position As Boolean
public:
bool^ zero_feedback_position()

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


zero_following_error Method

Axis..::..zero_following_error Method

Zeros the feedback position (fpos/fposc) and target position (tpos), thereby removing any following error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool zero_following_error()
Public Function zero_following_error As Boolean
public:
bool^ zero_following_error()

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


zero_target_position Method

Axis..::..zero_target_position Method

Zeros the target position, but maintains the following error. Operates the same as 'zero feedback position'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool zero_target_position()
Public Function zero_target_position As Boolean
public:
bool^ zero_target_position()

Return Value

true if successful, false otherwise.

See Also

Controller..::..Axis Class


Controller.Axis Properties

Controller..::..Axis Properties

The Controller..::..Axis type exposes the following members.

Properties

 | Name | Description
Public property | acc | Acceleration rate. Read/write.
Public property | accVector | Acceleration vector, if circular then in radians/sec2. Read only.
Public property | accX | Acceleration along X axis. Read/write.
Public property | accY | Acceleration along Y axis. Read/write.
Public property | accZ | Acceleration along Z axis. Read/write.
Public property | activeBG_MSBs | Number of background MSBs. Read only.
Public property | activeCAM_row | CAM table active and processing. Read/write.
Public property | activeFG_MSBs | Number of foreground MSBs, should be 0 for EtherCAT, only use background. Read only.
Public property | angle | Interpolated move angle. Read/write.
Public property | angleSweep | Degrees of sweep for circular interpolation. Read/write.
Public property | antibackup | Master antibackup accumilate, 0 ignore, 1 accumilate. Read/write.
Public property | axisnum | Our MSB axis number, 1 to N. Read only.
Public property | axisptr | Axis pointer to determine whose axis properties to access. Read/write.
Public property | axisY | Axis to use for interpolation Y control. Read/write.
Public property | axisZ | Axis to use for interpolation Z control. Read/write.
Public property | camming_invertend | If set inverts the meaning of invertmaster with regards to camtable end. Read/write.
Public property | camRequest | CAM file load request, 0-idle, 1-active, else error code. Read only.
Public property | capArmed | Capture armed. Read/write.
Public property | capEdge | Capture edge setting. Read only.
Public property | capGate | Capture gate value. Read only.
Public property | capGateState | Capture gate state, on or off. Read only.
Public property | capInput | Capture input setting. Read only.
Public property | capLimit | Capture limit value. Read/write.
Public property | capLimitflag | Capture limit present. Read only.
Public property | capMod | Capture modulus, 0 disables. Read/write.
Public property | capOffset | Amount to move, offset, after registration occurs. Read/write.
Public property | cappos | Capture position = cappos/ppr, user units. Read only.
Public property | capposc | Capture position counts. Read only.
Public property | capStatus | Capture status, not used. Read only.
Public property | capTriggered | Capture occured. Read/write.
Public property | capWait | Capture wait. Read only.
Public property | capwinEnd | Capture window end. Read/write.
Public property | capwinStart | Capture window start. Read/write.
Public property | capwinType | Capture window type. Read only.
Public property | cmode | Command mode for drive, EtherCAT mode. Read/write.
Public property | Command_timout_ms | Gets or sets the motion command timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 10 seconds.
Public property | ctr0 | mappable input edge counter 0. Read only.
Public property | ctr1 | mappable input edge counter 1. Read only.
Public property | ctr2 | mappable input edge counter 2. Read only.
Public property | ctr3 | mappable input edge counter 3. Read only.
Public property | ctr4 | mappable input edge counter 4. Read only.
Public property | ctr5 | mappable input edge counter 5. Read only.
Public property | ctr6 | mappable input edge counter 6. Read only.
Public property | ctr7 | mappable input edge counter 7. Read only.
Public property | dac_mv | DAC millivolts, not used. Read only.
Public property | debugTable | Diagnostic table selection index. Read/write.
Public property | debugTableRow | Diagnostic table row selection. Read/write.
Public property | debugTableRows | Diagnostic table selected index number of rows. Read only.
Public property | debugTableX | Diagnostic table row X value. Read only.
Public property | debugTableY | Diagnostic table row Y value. Read only.
Public property | dec | Deceleration rate. Read/write.
Public property | decVector | Deceleration vector, if circular then in radians/sec2. Read only.
Public property | decX | Deceleration along X axis. Read/write.
Public property | decY | Deceleration along Y axis. Read/write.
Public property | decZ | Deceleration along Z axis. Read/write.
Public property | din1 | Drive digital input 1, drive dependent. Read only.
Public property | din10 | Drive digital input 10, drive dependent. Read only.
Public property | din2 | Drive digital input 2, drive dependent. Read only.
Public property | din3 | Drive digital input 3, drive dependent. Read only.
Public property | din4 | Drive digital input 4, drive dependent. Read only.
Public property | din5 | Drive digital input 5, drive dependent. Read only.
Public property | din6 | Drive digital input 6, drive dependent. Read only.
Public property | din7 | Drive digital input 7, drive dependent. Read only.
Public property | din8 | Drive digital input 8, drive dependent. Read only.
Public property | din9 | Drive digital input 9, drive dependent. Read only.
Public property | dins | Drive digital inputs, drive dependent. Read only.
Public property | dout1 | Drive digital output 1, drive dependent. Read/write.
Public property | dout10 | Drive digital output 10, drive dependent. Read/write.
Public property | dout2 | Drive digital output 2, drive dependent. Read/write.
Public property | dout3 | Drive digital output 3, drive dependent. Read/write.
Public property | dout4 | Drive digital output 4, drive dependent. Read/write.
Public property | dout5 | drive digital output 5, drive dependent. Read/write.
Public property | dout6 | Drive digital output 6, drive dependent. Read/write.
Public property | dout7 | Drive digital output 7, drive dependent. Read/write.
Public property | dout8 | Drive digital output 8, drive dependent. Read/write.
Public property | dout9 | Drive digital output 9, drive dependent. Read/write.
Public property | douts | Drive digital outputs, drive dependent. Read only.
Public property | driveenable | Drive enable output number, turned on with drive_enable() if set. Read/write.
Public property | driveType | Type of drive, manufacturer. Read only.
Public property | dwSlaveID | Assigned EtherCAT slave ID to the axis. Read only.
Public property | enabled | Drive enabled, nonzero. Read only.
Public property | encoder_mode | Encoder mode, set to 1 if absolute position mode. Read/write.
Public property | encoderZ | Encoder Z, not currently used, drive specific. Read/write.
Public property | encoderZ3 | Encoder combo A B, not used. Read/write.
Public property | fault1 | Fault bit group 1. Read only.
Public property | fault2 | Fault bit group 2. Read only.
Public property | fault3 | Fault bit group 3. Read only.
Public property | fault4 | Fault bit group 4. Read only.
Public property | faulted | Faulted, nonzero. Read only.
Public property | fpos | Feedback position = fposc/ppr. Read only.
Public property | fposc | Feedback position counts. Read only.
Public property | global_flags1 | General global flags 1. Read/write.
Public property | global_flags2 | General global flags 2. Read/write.
Public property | global_flags3 | General global flags 3. Read/write.
Public property | global_flags4 | General global flags 4. Read/write.
Public property | global_flags5 | General global flags 5. Read/write.
Public property | global_inputs | EtherCAT global inputs. Read only.
Public property | global_outputs | EtherCAT global outputs. Read/write.
Public property | global_reg1 | General global register 1. Read/write.
Public property | global_reg10 | General global register 10. Read/write.
Public property | global_reg11 | General global register 11. Read/write.
Public property | global_reg12 | General global register 12. Read/write.
Public property | global_reg13 | General global register 13. Read/write.
Public property | global_reg14 | General global register 14. Read/write.
Public property | global_reg15 | General global register 15. Read/write.
Public property | global_reg16 | General global register 16. Read/write.
Public property | global_reg17 | General global register 17. Read/write.
Public property | global_reg18 | General global register 18. Read/write.
Public property | global_reg19 | General global register 19. Read/write.
Public property | global_reg2 | General global register 2. Read/write.
Public property | global_reg20 | General global register 20. Read/write.
Public property | global_reg21 | General global register 21. Read/write.
Public property | global_reg22 | General global register 22. Read/write.
Public property | global_reg23 | General global register 23. Read/write.
Public property | global_reg24 | General global register 24. Read/write.
Public property | global_reg25 | General global register 25. Read/write.
Public property | global_reg26 | General global register 26. Read/write.
Public property | global_reg27 | General global register 27. Read/write.
Public property | global_reg28 | General global register 28. Read/write.
Public property | global_reg29 | General global register 29. Read/write.
Public property | global_reg3 | General global register 3. Read/write.
Public property | global_reg30 | General global register 30. Read/write.
Public property | global_reg31 | General global register 31. Read/write.
Public property | global_reg32 | General global register 32. Read/write.
Public property | global_reg4 | General global register 4. Read/write.
Public property | global_reg5 | General global register 5. Read/write.
Public property | global_reg6 | General global register 6. Read/write.
Public property | global_reg7 | General global register 7. Read/write.
Public property | global_reg8 | General global register 8. Read/write.
Public property | global_reg9 | General global register 9. Read/write.
Public property | gratio | Present gear ration. Read only.
Public property | homing_method | Homing method if available, drive dependent support, see manual. Read/write.
Public property | homing_speed1 | Homing speed 1 if available, drive dependent support, see manual. Read/write.
Public property | homing_speed2 | Homing speed 2 if available, drive dependent support, see manual. Read/write.
Public property | IAI_alarmcode | IAI alarm register code. Read/write.
Public property | IAI_control | IAI control register. Read/write.
Public property | inpos | In position, nonzero. Read only.
Public property | inpos_t | Required in position time, drive dependent. Read/write.
Public property | inpos_w | In position window, drive dependent. Read/write.
Public property | inposw | In position window, user units. Read/write.
Public property | inputPolarity | Exclusive OR of dins to set active low or high inputs, default is 0 where 1 = closed. Read/write.
Public property | invel_t | In velocity time, drive dependent. Read/write.
Public property | invel_w | In velocity window, drive dependent. Read/write.
Public property | invertfeed | Invert feedback encoder, nonzero. Read/write.
Public property | invertmaster | Invert master encoder, user units. Read/write.
Public property | ipos | Initial position. Read only.
Public property | jerk_a | Jerk - acceleration used, S-curve. Read only.
Public property | jerk_a_req | Jerk - acceleration request. Read/write.
Public property | jerk_d | Jerk - deceleration used, S-curve. Read only.
Public property | jerk_d_req | Jerk - deceleration request. Read/write.
Public property | jogging | Jogging, not currently implemented. Read only.
Public property | last_ALStatusCode | Last EtherCAT AL register status code. Read/write.
Public property | last_errorCode | Last EtherCAT error code, typcially object 0x603f. Read/write.
Public property | last_errorRegister | Last EtherCAT register value, object 0x1001. Read/write.
Public property | last_errorType | Last EtherCAT error type. Read/write.
Public property | loopperiod | Axis loop period. Read only.
Public property | looprate | Axis loop rate. Read only.
Public property | magnitude | Linear interpolation vector size. Read/write.
Public property | master_feedback | Set master feedback or target, master drive axis for EtherCAT 1 to N. Read/write.
Public property | mcinv | Mposc 1 to 5 inversion bit mask, not currently used. Read/write.
Public property | mdelta1 | Last master position counter 1, not currently used. Read only.
Public property | mdelta2 | Last master position counter 2, not currently used. Read only.
Public property | mdelta3 | Last master position counter 3, not currently used. Read only.
Public property | mdelta4 | Last master position counter 4, not currently used. Read only.
Public property | mdelta5 | Last master position counter 5, not currently used. Read only.
Public property | mmc | mposc 1 to 5 modulus. Read/write only.
Public property | move_master_counts | Move master command rate target. Read only.
Public property | move_master_ramp | Move master ramp setting. Read only.
Public property | move_master_rate | Current move master rate. Read only.
Public property | move_master_rate_target | Move master command ramp. Read only.
Public property | mpgai | master position delta in last gear at in. Read only.
Public property | mpgfi | master position delta in last gear for in. Read only.
Public property | mpos | Master position, user units. Read only.
Public property | mposc | Master position in counts. Read only.
Public property | mposc1 | master position counter 1, not currently used. Read/write.
Public property | mposc2 | master position counter 2, not currently used. Read/write.
Public property | mposc3 | master position counter 3, not currently used. Read/write.
Public property | mposc4 | master position counter 4, not currently used. Read/write.
Public property | mposc5 | master position counter 5, not currently used. Read/write.
Public property | mppr | Master pulses per revolution. Read/write.
Public property | msource | Master source. Read/write.
Public property | neglim | Negative overtravel limits, user units. Read/write.
Public property | newvel | New velocity request for 'newposition' move command. Read/write.
Public property | overneg | Negative overtravel, nonzero. Read only.
Public property | overnegin | Overtravel negative input #. Read/write.
Public property | overpos | Positive overtravel, nonzero. Read only.
Public property | overposin | Overtravel positive input #. Read/write.
Public property | overtrq | In torque limit, nonzero. Read only.
Public property | perr | Position error, in user units. Read only.
Public property | perrlimit | Following error limit (0 = disabled). Read/write.
Public property | poslim | Positive overtravel limits, user units. Read/write.
Public property | ppr | Pulses per revolution. Read/write.
Public property | pstate | Axis state. Read only.
Public property | QS2_Status | QS2 status interface. Read only.
Public property | radius | Circular interpolation radius. Read/write.
Public property | RFID_address | RFID channel address to access. Read/write.
Public property | RFID_bytesTotal | Total number of bytes to transfer to/from RFID tag. Read/write.
Public property | RFID_bytesTransferred | Current number of bytes actually transfered from RFID tag. Read/write.
Public property | RFID_channel | RFID ones based index to reference RFID channel to operate on. Read/write.
Public property | RFID_control | RFID channel control register. Read/write.
Public property | RFID_controlActive | RFID channel control register currently written to RFID reader. Read only.
Public property | RFID_count | Number of bytes in an RFID block read - 1. Read only.
Public property | RFID_data_readh | Second 4 bytes of RFID read array. Read/write.
Public property | RFID_data_readl | First 4 bytes of RFID read array. Read/write.
Public property | RFID_data_writeh | Second 4 bytes of RFID write array. Read/write.
Public property | RFID_data_writel | First 4 bytes of RFID write array. Read/write.
Public property | RFID_error | RFID error catagory and description. Read only.
Public property | RFID_index | Index to RFID read and write array, 1 to 32. Read/write.
Public property | RFID_lasttagIDh | Last RFID unique tag ID high. Read/write.
Public property | RFID_lasttagIDl | Last RFID unique tag ID low. Read/write.
Public property | RFID_state | Current state of RFID read/write logic. Read/write.
Public property | RFID_status | RFID channel status register. Read only.
Public property | RFID_tagIDh | Current RFID unique tag ID high 4 bytes. Read/write.
Public property | RFID_tagIDl | Current RFID unique tag ID low 4 bytes. Read/write.
Public property | RFID_totalChannels | Total channels of RFID readers available. Read only.
Public property | rmstrq | RMS torque, typically actual torque or current, also drive specific features. Read only.
Public property | running | Turns on output # if MSB running on axis. Read/write.
Public property | runv | runv - Present velocity. Read/write.
Public property | sdc | Slave decrement counter. Read/write.
Public property | settling | Settling time in seconds for new position command change of direction, default 0. Read/write.
Public property | sfmod | Secondary feedback modulus, counts. Read/write.
Public property | sfpos | Secondary position, sfposc/ppr, user units. Read only.
Public property | sfposc | Secondary feedback position counts. Read/write.
Public property | sign | sign - Direction of move, plus or minus. Read Only.
Public property | smark | Slave marker position, not currently used. Read only.
Public property | smarkfall | Input bit mask fall, determines when smark is calculated, not currently used. Read/write.
Public property | smarkrise | Input bit mask rise, determines when smark is calculated, not currently used. Read/write.
Public property | smod | Smodc modulus. Read/write.
Public property | smodc | Slave position counter. Read/write only.
Public property | spgai | Slave position delta in last gear at in. Read only.
Public property | spgfi | Slave position delta in last gear for in. Read only.
Public property | sphase | Slave marker phase position, not currently used. Read only.
Public property | sppr | Stepper pulses/rev, not currently used Read/write only.
Public property | stepsout | Stepper pulses output, not currently used. Read only.
Public property | stoprate | Stop rate. Read/write.
Public property | theta | Motor angle. Read only.
Public property | time | Time, incremented by loop period each interrupt. Read/write.
Public property | tlim | Torque limit. Read/write.
Public property | tmax | Max torque or current, % actual depending on drive support. Read/write.
Public property | tmc1 | Temporary master counter 1. Read/write.
Public property | tmc2 | Temporary master counter 2. Read/write.
Public property | tmodc | Master position counter mod mmc. Read/write.
Public property | touchProbeStatus | Drive position registration latch status. Read only.
Public property | tpos | Target position = tposc/ppr. Read only.
Public property | tposc | Target position counts. Read only.
Public property | tracking_pstate | Slave axis state of move command during tracking. Read only.
Public property | tracking_sign | Direction to move, 1 for positive, -1 for negative. Read only.
Public property | tracking_status | QS2 status for tracking, state of motion slope for move. Read only.
Public property | tracking_tpos | Relative position of move command during tracking, 0 base. Read only.
Public property | tracking_tposc | Relative counts of move command during tracking, 0 base. Read only.
Public property | trqc | Torque command, not presently used. Read/write.
Public property | tsc1 | Temporary slave counter 1. Read/write.
Public property | tsc1fall | Input bit mask (fall) determines when tsc1 is cleared. Read/write.
Public property | tsc1rise | Input bit mask (rise) determines when tsc1 is cleared. Read/write.
Public property | tsc2 | Temporary slave counter 2. Read/write.
Public property | tsc2fall | Input bit mask (fall) determines when tsc2 is cleared. Read/write.
Public property | tsc2rise | Input bit mask (rise) determines when tsc2 is cleared. Read/write.
Public property | uud | User units denominator. Read/write.
Public property | uun | User units numerator. Read/write.
Public property | Variable_timeout_ms | Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.
Public property | vcmd | Velocity command, drive specific use. Read/write.
Public property | vectorY | Y axis move distance for linear interpolation. Read/write.
Public property | vectorZ | Z axis move distance for linear interpolation. Read/write.
Public property | vel | Velocity, in user units. Read only.
Public property | velVector | Velocity vector, if circular then in radians/sec. Read/write.
Public property | velX | Velocity along X axis. Read/write.
Public property | velY | Velocity along Y axis. Read/write.
Public property | velZ | Velocity along Z axis. Read/write.
Public property | verr | Velocity error, not used with EtherCAT. Read only.
Public property | vmax | Max velocity. Read/write.
Public property | vmdelta | Virtual master delta counts. Read only.
Public property | wControlWord | Current EtherCAT control word written. Read only.
Public property | wStatus | Current EtherCAT PDO status read. Read only.
Public property | zone_limit_neg | IAI linear actuator zone negative limit. Read/write.
Public property | zone_limit_pos | IAI linear actuator zone positive limit. Read/write.
Public property | zpulse | Zpulse seen, drive specific. Read only.
Public property | ZPULSE_NEG | Z pulse negative direction, drive specific. Read only.
Public property | ZPULSE_POS | Z pulse positive direction, drive specific. Read only.
Public property | ztheta | Motor angle of Z. Read only.

See Also

Controller..::..Axis Class


acc Property

Axis..::..acc Property

Acceleration rate. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float acc { get; set; }
Public Property acc As Single
    Get
    Set
public:
property float^ acc {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


accVector Property

Axis..::..accVector Property

Acceleration vector, if circular then in radians/sec2. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double accVector { get; }
Public ReadOnly Property accVector As Double
    Get
public:
property double^ accVector {
    double^ get ();
}

See Also

Controller..::..Axis Class


accX Property

Axis..::..accX Property

Acceleration along X axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double accX { get; set; }
Public Property accX As Double
    Get
    Set
public:
property double^ accX {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


accY Property

Axis..::..accY Property

Acceleration along Y axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double accY { get; set; }
Public Property accY As Double
    Get
    Set
public:
property double^ accY {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


accZ Property

Axis..::..accZ Property

Acceleration along Z axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double accZ { get; set; }
Public Property accZ As Double
    Get
    Set
public:
property double^ accZ {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


activeBG_MSBs Property

Axis..::..activeBG_MSBs Property

Number of background MSBs. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int activeBG_MSBs { get; }
Public ReadOnly Property activeBG_MSBs As Integer
    Get
public:
property int^ activeBG_MSBs {
    int^ get ();
}

See Also

Controller..::..Axis Class


activeCAM_row Property

Axis..::..activeCAM_row Property

CAM table active and processing. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int activeCAM_row { get; set; }
Public Property activeCAM_row As Integer
    Get
    Set
public:
property int^ activeCAM_row {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


activeFG_MSBs Property

Axis..::..activeFG_MSBs Property

Number of foreground MSBs, should be 0 for EtherCAT, only use background. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int activeFG_MSBs { get; }
Public ReadOnly Property activeFG_MSBs As Integer
    Get
public:
property int^ activeFG_MSBs {
    int^ get ();
}

See Also

Controller..::..Axis Class


angle Property

Axis..::..angle Property

Interpolated move angle. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float angle { get; set; }
Public Property angle As Single
    Get
    Set
public:
property float^ angle {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


angleSweep Property

Axis..::..angleSweep Property

Degrees of sweep for circular interpolation. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double angleSweep { get; set; }
Public Property angleSweep As Double
    Get
    Set
public:
property double^ angleSweep {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


antibackup Property

Axis..::..antibackup Property

Master antibackup accumilate, 0 ignore, 1 accumilate. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int antibackup { get; set; }
Public Property antibackup As Integer
    Get
    Set
public:
property int^ antibackup {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


axisnum Property

Axis..::..axisnum Property

Our MSB axis number, 1 to N. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int axisnum { get; }
Public ReadOnly Property axisnum As Integer
    Get
public:
property int^ axisnum {
    int^ get ();
}

See Also

Controller..::..Axis Class


axisptr Property

Axis..::..axisptr Property

Axis pointer to determine whose axis properties to access. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int axisptr { get; set; }
Public Property axisptr As Integer
    Get
    Set
public:
property int^ axisptr {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


axisY Property

Axis..::..axisY Property

Axis to use for interpolation Y control. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int axisY { get; set; }
Public Property axisY As Integer
    Get
    Set
public:
property int^ axisY {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


axisZ Property

Axis..::..axisZ Property

Axis to use for interpolation Z control. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int axisZ { get; set; }
Public Property axisZ As Integer
    Get
    Set
public:
property int^ axisZ {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


camming_invertend Property

Axis..::..camming_invertend Property

If set inverts the meaning of invertmaster with regards to camtable end. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int camming_invertend { get; set; }
Public Property camming_invertend As Integer
    Get
    Set
public:
property int^ camming_invertend {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


camRequest Property

Axis..::..camRequest Property

CAM file load request, 0-idle, 1-active, else error code. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int camRequest { get; }
Public ReadOnly Property camRequest As Integer
    Get
public:
property int^ camRequest {
    int^ get ();
}

See Also

Controller..::..Axis Class


capArmed Property

Axis..::..capArmed Property

Capture armed. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capArmed { get; set; }
Public Property capArmed As Integer
    Get
    Set
public:
property int^ capArmed {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


capEdge Property

Axis..::..capEdge Property

Capture edge setting. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capEdge { get; }
Public ReadOnly Property capEdge As Integer
    Get
public:
property int^ capEdge {
    int^ get ();
}

See Also

Controller..::..Axis Class


capGate Property

Axis..::..capGate Property

Capture gate value. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capGate { get; }
Public ReadOnly Property capGate As Integer
    Get
public:
property int^ capGate {
    int^ get ();
}

See Also

Controller..::..Axis Class


capGateState Property

Axis..::..capGateState Property

Capture gate state, on or off. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capGateState { get; }
Public ReadOnly Property capGateState As Integer
    Get
public:
property int^ capGateState {
    int^ get ();
}

See Also

Controller..::..Axis Class


capInput Property

Axis..::..capInput Property

Capture input setting. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capInput { get; }
Public ReadOnly Property capInput As Integer
    Get
public:
property int^ capInput {
    int^ get ();
}

See Also

Controller..::..Axis Class


capLimit Property

Axis..::..capLimit Property

Capture limit value. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long capLimit { get; set; }
Public Property capLimit As Long
    Get
    Set
public:
property long long^ capLimit {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


capLimitflag Property

Axis..::..capLimitflag Property

Capture limit present. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capLimitflag { get; }
Public ReadOnly Property capLimitflag As Integer
    Get
public:
property int^ capLimitflag {
    int^ get ();
}

See Also

Controller..::..Axis Class


capMod Property

Axis..::..capMod Property

Capture modulus, 0 disables. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capMod { get; set; }
Public Property capMod As Integer
    Get
    Set
public:
property int^ capMod {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


capOffset Property

Axis..::..capOffset Property

Amount to move, offset, after registration occurs. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long capOffset { get; set; }
Public Property capOffset As Long
    Get
    Set
public:
property long long^ capOffset {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


cappos Property

Axis..::..cappos Property

Capture position = cappos/ppr, user units. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double cappos { get; }
Public ReadOnly Property cappos As Double
    Get
public:
property double^ cappos {
    double^ get ();
}

See Also

Controller..::..Axis Class


capposc Property

Axis..::..capposc Property

Capture position counts. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long capposc { get; }
Public ReadOnly Property capposc As Long
    Get
public:
property long long^ capposc {
    long long^ get ();
}

See Also

Controller..::..Axis Class


capStatus Property

Axis..::..capStatus Property

Capture status, not used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capStatus { get; }
Public ReadOnly Property capStatus As Integer
    Get
public:
property int^ capStatus {
    int^ get ();
}

See Also

Controller..::..Axis Class


capTriggered Property

Axis..::..capTriggered Property

Capture occured. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capTriggered { get; set; }
Public Property capTriggered As Integer
    Get
    Set
public:
property int^ capTriggered {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


capWait Property

Axis..::..capWait Property

Capture wait. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capWait { get; }
Public ReadOnly Property capWait As Integer
    Get
public:
property int^ capWait {
    int^ get ();
}

See Also

Controller..::..Axis Class


capwinEnd Property

Axis..::..capwinEnd Property

Capture window end. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long capwinEnd { get; set; }
Public Property capwinEnd As Long
    Get
    Set
public:
property long long^ capwinEnd {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


capwinStart Property

Axis..::..capwinStart Property

Capture window start. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long capwinStart { get; set; }
Public Property capwinStart As Long
    Get
    Set
public:
property long long^ capwinStart {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


capwinType Property

Axis..::..capwinType Property

Capture window type. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int capwinType { get; }
Public ReadOnly Property capwinType As Integer
    Get
public:
property int^ capwinType {
    int^ get ();
}

See Also

Controller..::..Axis Class


cmode Property

Axis..::..cmode Property

Command mode for drive, EtherCAT mode. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..Axis..::..ETHERCAT_MODES cmode { get; set; }
Public Property cmode As Controller..::..Axis..::..ETHERCAT_MODES
    Get
    Set
public:
property Controller..::..Axis..::..ETHERCAT_MODES^ cmode {
    Controller..::..Axis..::..ETHERCAT_MODES^ get ();
    void set (Controller..::..Axis..::..ETHERCAT_MODES^ value);
}

See Also

Controller..::..Axis Class


Command_timout_ms Property

Axis..::..Command_timout_ms Property

Gets or sets the motion command timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 10 seconds.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int Command_timout_ms { get; set; }
Public Property Command_timout_ms As Integer
    Get
    Set
public:
property int^ Command_timout_ms {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


ctr0 Property

Axis..::..ctr0 Property

mappable input edge counter 0. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr0 { get; }
Public ReadOnly Property ctr0 As Long
    Get
public:
property long long^ ctr0 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr1 Property

Axis..::..ctr1 Property

mappable input edge counter 1. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr1 { get; }
Public ReadOnly Property ctr1 As Long
    Get
public:
property long long^ ctr1 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr2 Property

Axis..::..ctr2 Property

mappable input edge counter 2. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr2 { get; }
Public ReadOnly Property ctr2 As Long
    Get
public:
property long long^ ctr2 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr3 Property

Axis..::..ctr3 Property

mappable input edge counter 3. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr3 { get; }
Public ReadOnly Property ctr3 As Long
    Get
public:
property long long^ ctr3 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr4 Property

Axis..::..ctr4 Property

mappable input edge counter 4. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr4 { get; }
Public ReadOnly Property ctr4 As Long
    Get
public:
property long long^ ctr4 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr5 Property

Axis..::..ctr5 Property

mappable input edge counter 5. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr5 { get; }
Public ReadOnly Property ctr5 As Long
    Get
public:
property long long^ ctr5 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr6 Property

Axis..::..ctr6 Property

mappable input edge counter 6. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr6 { get; }
Public ReadOnly Property ctr6 As Long
    Get
public:
property long long^ ctr6 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


ctr7 Property

Axis..::..ctr7 Property

mappable input edge counter 7. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long ctr7 { get; }
Public ReadOnly Property ctr7 As Long
    Get
public:
property long long^ ctr7 {
    long long^ get ();
}

See Also

Controller..::..Axis Class


dac_mv Property

Axis..::..dac_mv Property

DAC millivolts, not used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dac_mv { get; }
Public ReadOnly Property dac_mv As Integer
    Get
public:
property int^ dac_mv {
    int^ get ();
}

See Also

Controller..::..Axis Class


debugTable Property

Axis..::..debugTable Property

Diagnostic table selection index. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int debugTable { get; set; }
Public Property debugTable As Integer
    Get
    Set
public:
property int^ debugTable {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


debugTableRow Property

Axis..::..debugTableRow Property

Diagnostic table row selection. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int debugTableRow { get; set; }
Public Property debugTableRow As Integer
    Get
    Set
public:
property int^ debugTableRow {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


debugTableRows Property

Axis..::..debugTableRows Property

Diagnostic table selected index number of rows. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int debugTableRows { get; }
Public ReadOnly Property debugTableRows As Integer
    Get
public:
property int^ debugTableRows {
    int^ get ();
}

See Also

Controller..::..Axis Class


debugTableX Property

Axis..::..debugTableX Property

Diagnostic table row X value. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float debugTableX { get; }
Public ReadOnly Property debugTableX As Single
    Get
public:
property float^ debugTableX {
    float^ get ();
}

See Also

Controller..::..Axis Class


debugTableY Property

Axis..::..debugTableY Property

Diagnostic table row Y value. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float debugTableY { get; }
Public ReadOnly Property debugTableY As Single
    Get
public:
property float^ debugTableY {
    float^ get ();
}

See Also

Controller..::..Axis Class


dec Property

Axis..::..dec Property

Deceleration rate. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float dec { get; set; }
Public Property dec As Single
    Get
    Set
public:
property float^ dec {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


decVector Property

Axis..::..decVector Property

Deceleration vector, if circular then in radians/sec2. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double decVector { get; }
Public ReadOnly Property decVector As Double
    Get
public:
property double^ decVector {
    double^ get ();
}

See Also

Controller..::..Axis Class


decX Property

Axis..::..decX Property

Deceleration along X axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double decX { get; set; }
Public Property decX As Double
    Get
    Set
public:
property double^ decX {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


decY Property

Axis..::..decY Property

Deceleration along Y axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double decY { get; set; }
Public Property decY As Double
    Get
    Set
public:
property double^ decY {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


decZ Property

Axis..::..decZ Property

Deceleration along Z axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double decZ { get; set; }
Public Property decZ As Double
    Get
    Set
public:
property double^ decZ {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


din1 Property

Axis..::..din1 Property

Drive digital input 1, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din1 { get; }
Public ReadOnly Property din1 As Integer
    Get
public:
property int^ din1 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din10 Property

Axis..::..din10 Property

Drive digital input 10, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din10 { get; }
Public ReadOnly Property din10 As Integer
    Get
public:
property int^ din10 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din2 Property

Axis..::..din2 Property

Drive digital input 2, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din2 { get; }
Public ReadOnly Property din2 As Integer
    Get
public:
property int^ din2 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din3 Property

Axis..::..din3 Property

Drive digital input 3, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din3 { get; }
Public ReadOnly Property din3 As Integer
    Get
public:
property int^ din3 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din4 Property

Axis..::..din4 Property

Drive digital input 4, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din4 { get; }
Public ReadOnly Property din4 As Integer
    Get
public:
property int^ din4 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din5 Property

Axis..::..din5 Property

Drive digital input 5, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din5 { get; }
Public ReadOnly Property din5 As Integer
    Get
public:
property int^ din5 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din6 Property

Axis..::..din6 Property

Drive digital input 6, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din6 { get; }
Public ReadOnly Property din6 As Integer
    Get
public:
property int^ din6 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din7 Property

Axis..::..din7 Property

Drive digital input 7, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din7 { get; }
Public ReadOnly Property din7 As Integer
    Get
public:
property int^ din7 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din8 Property

Axis..::..din8 Property

Drive digital input 8, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din8 { get; }
Public ReadOnly Property din8 As Integer
    Get
public:
property int^ din8 {
    int^ get ();
}

See Also

Controller..::..Axis Class


din9 Property

Axis..::..din9 Property

Drive digital input 9, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int din9 { get; }
Public ReadOnly Property din9 As Integer
    Get
public:
property int^ din9 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dins Property

Axis..::..dins Property

Drive digital inputs, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dins { get; }
Public ReadOnly Property dins As Integer
    Get
public:
property int^ dins {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout1 Property

Axis..::..dout1 Property

Drive digital output 1, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout1 { get; }
Public ReadOnly Property dout1 As Integer
    Get
public:
property int^ dout1 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout10 Property

Axis..::..dout10 Property

Drive digital output 10, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout10 { get; }
Public ReadOnly Property dout10 As Integer
    Get
public:
property int^ dout10 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout2 Property

Axis..::..dout2 Property

Drive digital output 2, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout2 { get; }
Public ReadOnly Property dout2 As Integer
    Get
public:
property int^ dout2 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout3 Property

Axis..::..dout3 Property

Drive digital output 3, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout3 { get; }
Public ReadOnly Property dout3 As Integer
    Get
public:
property int^ dout3 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout4 Property

Axis..::..dout4 Property

Drive digital output 4, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout4 { get; }
Public ReadOnly Property dout4 As Integer
    Get
public:
property int^ dout4 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout5 Property

Axis..::..dout5 Property

drive digital output 5, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout5 { get; }
Public ReadOnly Property dout5 As Integer
    Get
public:
property int^ dout5 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout6 Property

Axis..::..dout6 Property

Drive digital output 6, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout6 { get; }
Public ReadOnly Property dout6 As Integer
    Get
public:
property int^ dout6 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout7 Property

Axis..::..dout7 Property

Drive digital output 7, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout7 { get; }
Public ReadOnly Property dout7 As Integer
    Get
public:
property int^ dout7 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout8 Property

Axis..::..dout8 Property

Drive digital output 8, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout8 { get; }
Public ReadOnly Property dout8 As Integer
    Get
public:
property int^ dout8 {
    int^ get ();
}

See Also

Controller..::..Axis Class


dout9 Property

Axis..::..dout9 Property

Drive digital output 9, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dout9 { get; }
Public ReadOnly Property dout9 As Integer
    Get
public:
property int^ dout9 {
    int^ get ();
}

See Also

Controller..::..Axis Class


douts Property

Axis..::..douts Property

Drive digital outputs, drive dependent. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int douts { get; }
Public ReadOnly Property douts As Integer
    Get
public:
property int^ douts {
    int^ get ();
}

See Also

Controller..::..Axis Class


driveenable Property

Axis..::..driveenable Property

Drive enable output number, turned on with drive_enable() if set. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int driveenable { get; set; }
Public Property driveenable As Integer
    Get
    Set
public:
property int^ driveenable {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


driveType Property

Axis..::..driveType Property

Type of drive, manufacturer. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..Axis..::..DRIVE_TYPES driveType { get; }
Public ReadOnly Property driveType As Controller..::..Axis..::..DRIVE_TYPES
    Get
public:
property Controller..::..Axis..::..DRIVE_TYPES^ driveType {
    Controller..::..Axis..::..DRIVE_TYPES^ get ();
}

See Also

Controller..::..Axis Class


dwSlaveID Property

Axis..::..dwSlaveID Property

Assigned EtherCAT slave ID to the axis. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int dwSlaveID { get; }
Public ReadOnly Property dwSlaveID As Integer
    Get
public:
property int^ dwSlaveID {
    int^ get ();
}

See Also

Controller..::..Axis Class


enabled Property

Axis..::..enabled Property

Drive enabled, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int enabled { get; }
Public ReadOnly Property enabled As Integer
    Get
public:
property int^ enabled {
    int^ get ();
}

See Also

Controller..::..Axis Class


encoder_mode Property

Axis..::..encoder_mode Property

Encoder mode, set to 1 if absolute position mode. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int encoder_mode { get; set; }
Public Property encoder_mode As Integer
    Get
    Set
public:
property int^ encoder_mode {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


encoderZ Property

Axis..::..encoderZ Property

Encoder Z, not currently used, drive specific. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long encoderZ { get; set; }
Public Property encoderZ As Long
    Get
    Set
public:
property long long^ encoderZ {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


encoderZ3 Property

Axis..::..encoderZ3 Property

Encoder combo A B, not used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long encoderZ3 { get; set; }
Public Property encoderZ3 As Long
    Get
    Set
public:
property long long^ encoderZ3 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


fault1 Property

Axis..::..fault1 Property

Fault bit group 1. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int fault1 { get; }
Public ReadOnly Property fault1 As Integer
    Get
public:
property int^ fault1 {
    int^ get ();
}

See Also

Controller..::..Axis Class


fault2 Property

Axis..::..fault2 Property

Fault bit group 2. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int fault2 { get; }
Public ReadOnly Property fault2 As Integer
    Get
public:
property int^ fault2 {
    int^ get ();
}

See Also

Controller..::..Axis Class


fault3 Property

Axis..::..fault3 Property

Fault bit group 3. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int fault3 { get; }
Public ReadOnly Property fault3 As Integer
    Get
public:
property int^ fault3 {
    int^ get ();
}

See Also

Controller..::..Axis Class


fault4 Property

Axis..::..fault4 Property

Fault bit group 4. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int fault4 { get; }
Public ReadOnly Property fault4 As Integer
    Get
public:
property int^ fault4 {
    int^ get ();
}

See Also

Controller..::..Axis Class


faulted Property

Axis..::..faulted Property

Faulted, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int faulted { get; }
Public ReadOnly Property faulted As Integer
    Get
public:
property int^ faulted {
    int^ get ();
}

See Also

Controller..::..Axis Class


fpos Property

Axis..::..fpos Property

Feedback position = fposc/ppr. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double fpos { get; }
Public ReadOnly Property fpos As Double
    Get
public:
property double^ fpos {
    double^ get ();
}

See Also

Controller..::..Axis Class


fposc Property

Axis..::..fposc Property

Feedback position counts. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long fposc { get; }
Public ReadOnly Property fposc As Long
    Get
public:
property long long^ fposc {
    long long^ get ();
}

See Also

Controller..::..Axis Class


global_flags1 Property

Axis..::..global_flags1 Property

General global flags 1. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_flags1 { get; set; }
Public Property global_flags1 As Integer
    Get
    Set
public:
property int^ global_flags1 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_flags2 Property

Axis..::..global_flags2 Property

General global flags 2. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_flags2 { get; set; }
Public Property global_flags2 As Integer
    Get
    Set
public:
property int^ global_flags2 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_flags3 Property

Axis..::..global_flags3 Property

General global flags 3. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_flags3 { get; set; }
Public Property global_flags3 As Integer
    Get
    Set
public:
property int^ global_flags3 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_flags4 Property

Axis..::..global_flags4 Property

General global flags 4. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_flags4 { get; set; }
Public Property global_flags4 As Integer
    Get
    Set
public:
property int^ global_flags4 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_flags5 Property

Axis..::..global_flags5 Property

General global flags 5. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_flags5 { get; set; }
Public Property global_flags5 As Integer
    Get
    Set
public:
property int^ global_flags5 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_inputs Property

Axis..::..global_inputs Property

EtherCAT global inputs. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_inputs { get; }
Public ReadOnly Property global_inputs As Integer
    Get
public:
property int^ global_inputs {
    int^ get ();
}

See Also

Controller..::..Axis Class


global_outputs Property

Axis..::..global_outputs Property

EtherCAT global outputs. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int global_outputs { get; set; }
Public Property global_outputs As Integer
    Get
    Set
public:
property int^ global_outputs {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


global_reg1 Property

Axis..::..global_reg1 Property

General global register 1. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg1 { get; set; }
Public Property global_reg1 As Long
    Get
    Set
public:
property long long^ global_reg1 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg10 Property

Axis..::..global_reg10 Property

General global register 10. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg10 { get; set; }
Public Property global_reg10 As Long
    Get
    Set
public:
property long long^ global_reg10 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg11 Property

Axis..::..global_reg11 Property

General global register 11. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg11 { get; set; }
Public Property global_reg11 As Long
    Get
    Set
public:
property long long^ global_reg11 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg12 Property

Axis..::..global_reg12 Property

General global register 12. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg12 { get; set; }
Public Property global_reg12 As Long
    Get
    Set
public:
property long long^ global_reg12 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg13 Property

Axis..::..global_reg13 Property

General global register 13. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg13 { get; set; }
Public Property global_reg13 As Long
    Get
    Set
public:
property long long^ global_reg13 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg14 Property

Axis..::..global_reg14 Property

General global register 14. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg14 { get; set; }
Public Property global_reg14 As Long
    Get
    Set
public:
property long long^ global_reg14 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg15 Property

Axis..::..global_reg15 Property

General global register 15. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg15 { get; set; }
Public Property global_reg15 As Long
    Get
    Set
public:
property long long^ global_reg15 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg16 Property

Axis..::..global_reg16 Property

General global register 16. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg16 { get; set; }
Public Property global_reg16 As Long
    Get
    Set
public:
property long long^ global_reg16 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg17 Property

Axis..::..global_reg17 Property

General global register 17. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg17 { get; set; }
Public Property global_reg17 As Long
    Get
    Set
public:
property long long^ global_reg17 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg18 Property

Axis..::..global_reg18 Property

General global register 18. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg18 { get; set; }
Public Property global_reg18 As Long
    Get
    Set
public:
property long long^ global_reg18 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg19 Property

Axis..::..global_reg19 Property

General global register 19. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg19 { get; set; }
Public Property global_reg19 As Long
    Get
    Set
public:
property long long^ global_reg19 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg2 Property

Axis..::..global_reg2 Property

General global register 2. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg2 { get; set; }
Public Property global_reg2 As Long
    Get
    Set
public:
property long long^ global_reg2 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg20 Property

Axis..::..global_reg20 Property

General global register 20. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg20 { get; set; }
Public Property global_reg20 As Long
    Get
    Set
public:
property long long^ global_reg20 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg21 Property

Axis..::..global_reg21 Property

General global register 21. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg21 { get; set; }
Public Property global_reg21 As Long
    Get
    Set
public:
property long long^ global_reg21 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg22 Property

Axis..::..global_reg22 Property

General global register 22. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg22 { get; set; }
Public Property global_reg22 As Long
    Get
    Set
public:
property long long^ global_reg22 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg23 Property

Axis..::..global_reg23 Property

General global register 23. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg23 { get; set; }
Public Property global_reg23 As Long
    Get
    Set
public:
property long long^ global_reg23 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg24 Property

Axis..::..global_reg24 Property

General global register 24. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg24 { get; set; }
Public Property global_reg24 As Long
    Get
    Set
public:
property long long^ global_reg24 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg25 Property

Axis..::..global_reg25 Property

General global register 25. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg25 { get; set; }
Public Property global_reg25 As Long
    Get
    Set
public:
property long long^ global_reg25 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg26 Property

Axis..::..global_reg26 Property

General global register 26. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg26 { get; set; }
Public Property global_reg26 As Long
    Get
    Set
public:
property long long^ global_reg26 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg27 Property

Axis..::..global_reg27 Property

General global register 27. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg27 { get; set; }
Public Property global_reg27 As Long
    Get
    Set
public:
property long long^ global_reg27 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg28 Property

Axis..::..global_reg28 Property

General global register 28. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg28 { get; set; }
Public Property global_reg28 As Long
    Get
    Set
public:
property long long^ global_reg28 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg29 Property

Axis..::..global_reg29 Property

General global register 29. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg29 { get; set; }
Public Property global_reg29 As Long
    Get
    Set
public:
property long long^ global_reg29 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg3 Property

Axis..::..global_reg3 Property

General global register 3. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg3 { get; set; }
Public Property global_reg3 As Long
    Get
    Set
public:
property long long^ global_reg3 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg30 Property

Axis..::..global_reg30 Property

General global register 30. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg30 { get; set; }
Public Property global_reg30 As Long
    Get
    Set
public:
property long long^ global_reg30 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg31 Property

Axis..::..global_reg31 Property

General global register 31. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg31 { get; set; }
Public Property global_reg31 As Long
    Get
    Set
public:
property long long^ global_reg31 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg32 Property

Axis..::..global_reg32 Property

General global register 32. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg32 { get; set; }
Public Property global_reg32 As Long
    Get
    Set
public:
property long long^ global_reg32 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg4 Property

Axis..::..global_reg4 Property

General global register 4. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg4 { get; set; }
Public Property global_reg4 As Long
    Get
    Set
public:
property long long^ global_reg4 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg5 Property

Axis..::..global_reg5 Property

General global register 5. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg5 { get; set; }
Public Property global_reg5 As Long
    Get
    Set
public:
property long long^ global_reg5 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg6 Property

Axis..::..global_reg6 Property

General global register 6. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg6 { get; set; }
Public Property global_reg6 As Long
    Get
    Set
public:
property long long^ global_reg6 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg7 Property

Axis..::..global_reg7 Property

General global register 7. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg7 { get; set; }
Public Property global_reg7 As Long
    Get
    Set
public:
property long long^ global_reg7 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg8 Property

Axis..::..global_reg8 Property

General global register 8. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg8 { get; set; }
Public Property global_reg8 As Long
    Get
    Set
public:
property long long^ global_reg8 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


global_reg9 Property

Axis..::..global_reg9 Property

General global register 9. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long global_reg9 { get; set; }
Public Property global_reg9 As Long
    Get
    Set
public:
property long long^ global_reg9 {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


gratio Property

Axis..::..gratio Property

Present gear ration. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float gratio { get; }
Public ReadOnly Property gratio As Single
    Get
public:
property float^ gratio {
    float^ get ();
}

See Also

Controller..::..Axis Class


homing_method Property

Axis..::..homing_method Property

Homing method if available, drive dependent support, see manual. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int homing_method { get; set; }
Public Property homing_method As Integer
    Get
    Set
public:
property int^ homing_method {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


homing_speed1 Property

Axis..::..homing_speed1 Property

Homing speed 1 if available, drive dependent support, see manual. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float homing_speed1 { get; set; }
Public Property homing_speed1 As Single
    Get
    Set
public:
property float^ homing_speed1 {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


homing_speed2 Property

Axis..::..homing_speed2 Property

Homing speed 2 if available, drive dependent support, see manual. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float homing_speed2 { get; set; }
Public Property homing_speed2 As Single
    Get
    Set
public:
property float^ homing_speed2 {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


IAI_alarmcode Property

Axis..::..IAI_alarmcode Property

IAI alarm register code. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int IAI_alarmcode { get; set; }
Public Property IAI_alarmcode As Integer
    Get
    Set
public:
property int^ IAI_alarmcode {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


IAI_control Property

Axis..::..IAI_control Property

IAI control register. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int IAI_control { get; set; }
Public Property IAI_control As Integer
    Get
    Set
public:
property int^ IAI_control {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


inpos Property

Axis..::..inpos Property

In position, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int inpos { get; }
Public ReadOnly Property inpos As Integer
    Get
public:
property int^ inpos {
    int^ get ();
}

See Also

Controller..::..Axis Class


inpos_t Property

Axis..::..inpos_t Property

Required in position time, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int inpos_t { get; set; }
Public Property inpos_t As Integer
    Get
    Set
public:
property int^ inpos_t {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


inpos_w Property

Axis..::..inpos_w Property

In position window, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double inpos_w { get; set; }
Public Property inpos_w As Double
    Get
    Set
public:
property double^ inpos_w {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


inposw Property

Axis..::..inposw Property

In position window, user units. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double inposw { get; set; }
Public Property inposw As Double
    Get
    Set
public:
property double^ inposw {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


inputPolarity Property

Axis..::..inputPolarity Property

Exclusive OR of dins to set active low or high inputs, default is 0 where 1 = closed. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int inputPolarity { get; set; }
Public Property inputPolarity As Integer
    Get
    Set
public:
property int^ inputPolarity {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


invel_t Property

Axis..::..invel_t Property

In velocity time, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int invel_t { get; set; }
Public Property invel_t As Integer
    Get
    Set
public:
property int^ invel_t {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


invel_w Property

Axis..::..invel_w Property

In velocity window, drive dependent. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double invel_w { get; set; }
Public Property invel_w As Double
    Get
    Set
public:
property double^ invel_w {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


invertfeed Property

Axis..::..invertfeed Property

Invert feedback encoder, nonzero. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int invertfeed { get; set; }
Public Property invertfeed As Integer
    Get
    Set
public:
property int^ invertfeed {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


invertmaster Property

Axis..::..invertmaster Property

Invert master encoder, user units. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int invertmaster { get; set; }
Public Property invertmaster As Integer
    Get
    Set
public:
property int^ invertmaster {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


ipos Property

Axis..::..ipos Property

Initial position. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double ipos { get; }
Public ReadOnly Property ipos As Double
    Get
public:
property double^ ipos {
    double^ get ();
}

See Also

Controller..::..Axis Class


jerk_a Property

Axis..::..jerk_a Property

Jerk - acceleration used, S-curve. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float jerk_a { get; }
Public ReadOnly Property jerk_a As Single
    Get
public:
property float^ jerk_a {
    float^ get ();
}

See Also

Controller..::..Axis Class


jerk_a_req Property

Axis..::..jerk_a_req Property

Jerk - acceleration request. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float jerk_a_req { get; set; }
Public Property jerk_a_req As Single
    Get
    Set
public:
property float^ jerk_a_req {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


jerk_d Property

Axis..::..jerk_d Property

Jerk - deceleration used, S-curve. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float jerk_d { get; }
Public ReadOnly Property jerk_d As Single
    Get
public:
property float^ jerk_d {
    float^ get ();
}

See Also

Controller..::..Axis Class


jerk_d_req Property

Axis..::..jerk_d_req Property

Jerk - deceleration request. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float jerk_d_req { get; set; }
Public Property jerk_d_req As Single
    Get
    Set
public:
property float^ jerk_d_req {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


jogging Property

Axis..::..jogging Property

Jogging, not currently implemented. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int jogging { get; }
Public ReadOnly Property jogging As Integer
    Get
public:
property int^ jogging {
    int^ get ();
}

See Also

Controller..::..Axis Class


last_ALStatusCode Property

Axis..::..last_ALStatusCode Property

Last EtherCAT AL register status code. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int last_ALStatusCode { get; set; }
Public Property last_ALStatusCode As Integer
    Get
    Set
public:
property int^ last_ALStatusCode {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


last_errorCode Property

Axis..::..last_errorCode Property

Last EtherCAT error code, typcially object 0x603f. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int last_errorCode { get; set; }
Public Property last_errorCode As Integer
    Get
    Set
public:
property int^ last_errorCode {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


last_errorRegister Property

Axis..::..last_errorRegister Property

Last EtherCAT register value, object 0x1001. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int last_errorRegister { get; set; }
Public Property last_errorRegister As Integer
    Get
    Set
public:
property int^ last_errorRegister {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


last_errorType Property

Axis..::..last_errorType Property

Last EtherCAT error type. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int last_errorType { get; set; }
Public Property last_errorType As Integer
    Get
    Set
public:
property int^ last_errorType {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


loopperiod Property

Axis..::..loopperiod Property

Axis loop period. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float loopperiod { get; }
Public ReadOnly Property loopperiod As Single
    Get
public:
property float^ loopperiod {
    float^ get ();
}

See Also

Controller..::..Axis Class


looprate Property

Axis..::..looprate Property

Axis loop rate. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float looprate { get; }
Public ReadOnly Property looprate As Single
    Get
public:
property float^ looprate {
    float^ get ();
}

See Also

Controller..::..Axis Class


magnitude Property

Axis..::..magnitude Property

Linear interpolation vector size. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double magnitude { get; set; }
Public Property magnitude As Double
    Get
    Set
public:
property double^ magnitude {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


master_feedback Property

Axis..::..master_feedback Property

Set master feedback or target, master drive axis for EtherCAT 1 to N. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int master_feedback { get; set; }
Public Property master_feedback As Integer
    Get
    Set
public:
property int^ master_feedback {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mcinv Property

Axis..::..mcinv Property

Mposc 1 to 5 inversion bit mask, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mcinv { get; set; }
Public Property mcinv As Integer
    Get
    Set
public:
property int^ mcinv {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mdelta1 Property

Axis..::..mdelta1 Property

Last master position counter 1, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mdelta1 { get; }
Public ReadOnly Property mdelta1 As Integer
    Get
public:
property int^ mdelta1 {
    int^ get ();
}

See Also

Controller..::..Axis Class


mdelta2 Property

Axis..::..mdelta2 Property

Last master position counter 2, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mdelta2 { get; }
Public ReadOnly Property mdelta2 As Integer
    Get
public:
property int^ mdelta2 {
    int^ get ();
}

See Also

Controller..::..Axis Class


mdelta3 Property

Axis..::..mdelta3 Property

Last master position counter 3, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mdelta3 { get; }
Public ReadOnly Property mdelta3 As Integer
    Get
public:
property int^ mdelta3 {
    int^ get ();
}

See Also

Controller..::..Axis Class


mdelta4 Property

Axis..::..mdelta4 Property

Last master position counter 4, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mdelta4 { get; }
Public ReadOnly Property mdelta4 As Integer
    Get
public:
property int^ mdelta4 {
    int^ get ();
}

See Also

Controller..::..Axis Class


mdelta5 Property

Axis..::..mdelta5 Property

Last master position counter 5, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mdelta5 { get; }
Public ReadOnly Property mdelta5 As Integer
    Get
public:
property int^ mdelta5 {
    int^ get ();
}

See Also

Controller..::..Axis Class


mmc Property

Axis..::..mmc Property

mposc 1 to 5 modulus. Read/write only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mmc { get; set; }
Public Property mmc As Integer
    Get
    Set
public:
property int^ mmc {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


move_master_counts Property

Axis..::..move_master_counts Property

Move master command rate target. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int move_master_counts { get; }
Public ReadOnly Property move_master_counts As Integer
    Get
public:
property int^ move_master_counts {
    int^ get ();
}

See Also

Controller..::..Axis Class


move_master_ramp Property

Axis..::..move_master_ramp Property

Move master ramp setting. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int move_master_ramp { get; }
Public ReadOnly Property move_master_ramp As Integer
    Get
public:
property int^ move_master_ramp {
    int^ get ();
}

See Also

Controller..::..Axis Class


move_master_rate Property

Axis..::..move_master_rate Property

Current move master rate. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int move_master_rate { get; }
Public ReadOnly Property move_master_rate As Integer
    Get
public:
property int^ move_master_rate {
    int^ get ();
}

See Also

Controller..::..Axis Class


move_master_rate_target Property

Axis..::..move_master_rate_target Property

Move master command ramp. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int move_master_rate_target { get; }
Public ReadOnly Property move_master_rate_target As Integer
    Get
public:
property int^ move_master_rate_target {
    int^ get ();
}

See Also

Controller..::..Axis Class


mpgai Property

Axis..::..mpgai Property

master position delta in last gear at in. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mpgai { get; }
Public ReadOnly Property mpgai As Integer
    Get
public:
property int^ mpgai {
    int^ get ();
}

See Also

Controller..::..Axis Class


mpgfi Property

Axis..::..mpgfi Property

master position delta in last gear for in. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mpgfi { get; }
Public ReadOnly Property mpgfi As Integer
    Get
public:
property int^ mpgfi {
    int^ get ();
}

See Also

Controller..::..Axis Class


mpos Property

Axis..::..mpos Property

Master position, user units. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double mpos { get; }
Public ReadOnly Property mpos As Double
    Get
public:
property double^ mpos {
    double^ get ();
}

See Also

Controller..::..Axis Class


mposc Property

Axis..::..mposc Property

Master position in counts. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long mposc { get; }
Public ReadOnly Property mposc As Long
    Get
public:
property long long^ mposc {
    long long^ get ();
}

See Also

Controller..::..Axis Class


mposc1 Property

Axis..::..mposc1 Property

master position counter 1, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mposc1 { get; set; }
Public Property mposc1 As Integer
    Get
    Set
public:
property int^ mposc1 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mposc2 Property

Axis..::..mposc2 Property

master position counter 2, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mposc2 { get; set; }
Public Property mposc2 As Integer
    Get
    Set
public:
property int^ mposc2 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mposc3 Property

Axis..::..mposc3 Property

master position counter 3, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mposc3 { get; set; }
Public Property mposc3 As Integer
    Get
    Set
public:
property int^ mposc3 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mposc4 Property

Axis..::..mposc4 Property

master position counter 4, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mposc4 { get; set; }
Public Property mposc4 As Integer
    Get
    Set
public:
property int^ mposc4 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mposc5 Property

Axis..::..mposc5 Property

master position counter 5, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mposc5 { get; set; }
Public Property mposc5 As Integer
    Get
    Set
public:
property int^ mposc5 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


mppr Property

Axis..::..mppr Property

Master pulses per revolution. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int mppr { get; set; }
Public Property mppr As Integer
    Get
    Set
public:
property int^ mppr {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


msource Property

Axis..::..msource Property

Master source. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int msource { get; }
Public ReadOnly Property msource As Integer
    Get
public:
property int^ msource {
    int^ get ();
}

See Also

Controller..::..Axis Class


neglim Property

Axis..::..neglim Property

Negative overtravel limits, user units. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double neglim { get; set; }
Public Property neglim As Double
    Get
    Set
public:
property double^ neglim {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


newvel Property

Axis..::..newvel Property

New velocity request for 'newposition' move command. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float newvel { get; set; }
Public Property newvel As Single
    Get
    Set
public:
property float^ newvel {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


overneg Property

Axis..::..overneg Property

Negative overtravel, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int overneg { get; }
Public ReadOnly Property overneg As Integer
    Get
public:
property int^ overneg {
    int^ get ();
}

See Also

Controller..::..Axis Class


overnegin Property

Axis..::..overnegin Property

Overtravel negative input #. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int overnegin { get; set; }
Public Property overnegin As Integer
    Get
    Set
public:
property int^ overnegin {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


overpos Property

Axis..::..overpos Property

Positive overtravel, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int overpos { get; }
Public ReadOnly Property overpos As Integer
    Get
public:
property int^ overpos {
    int^ get ();
}

See Also

Controller..::..Axis Class


overposin Property

Axis..::..overposin Property

Overtravel positive input #. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int overposin { get; set; }
Public Property overposin As Integer
    Get
    Set
public:
property int^ overposin {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


overtrq Property

Axis..::..overtrq Property

In torque limit, nonzero. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int overtrq { get; }
Public ReadOnly Property overtrq As Integer
    Get
public:
property int^ overtrq {
    int^ get ();
}

See Also

Controller..::..Axis Class


perr Property

Axis..::..perr Property

Position error, in user units. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double perr { get; }
Public ReadOnly Property perr As Double
    Get
public:
property double^ perr {
    double^ get ();
}

See Also

Controller..::..Axis Class


perrlimit Property

Axis..::..perrlimit Property

Following error limit (0 = disabled). Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double perrlimit { get; set; }
Public Property perrlimit As Double
    Get
    Set
public:
property double^ perrlimit {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


poslim Property

Axis..::..poslim Property

Positive overtravel limits, user units. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double poslim { get; set; }
Public Property poslim As Double
    Get
    Set
public:
property double^ poslim {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


ppr Property

Axis..::..ppr Property

Pulses per revolution. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int ppr { get; set; }
Public Property ppr As Integer
    Get
    Set
public:
property int^ ppr {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


pstate Property

Axis..::..pstate Property

Axis state. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..Axis..::..PSTATES pstate { get; }
Public ReadOnly Property pstate As Controller..::..Axis..::..PSTATES
    Get
public:
property Controller..::..Axis..::..PSTATES^ pstate {
    Controller..::..Axis..::..PSTATES^ get ();
}

See Also

Controller..::..Axis Class


QS2_Status Property

Axis..::..QS2_Status Property

QS2 status interface. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int QS2_Status { get; }
Public ReadOnly Property QS2_Status As Integer
    Get
public:
property int^ QS2_Status {
    int^ get ();
}

See Also

Controller..::..Axis Class


radius Property

Axis..::..radius Property

Circular interpolation radius. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double radius { get; set; }
Public Property radius As Double
    Get
    Set
public:
property double^ radius {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


RFID_address Property

Axis..::..RFID_address Property

RFID channel address to access. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_address { get; set; }
Public Property RFID_address As Integer
    Get
    Set
public:
property int^ RFID_address {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_bytesTotal Property

Axis..::..RFID_bytesTotal Property

Total number of bytes to transfer to/from RFID tag. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_bytesTotal { get; set; }
Public Property RFID_bytesTotal As Integer
    Get
    Set
public:
property int^ RFID_bytesTotal {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_bytesTransferred Property

Axis..::..RFID_bytesTransferred Property

Current number of bytes actually transfered from RFID tag. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_bytesTransferred { get; set; }
Public Property RFID_bytesTransferred As Integer
    Get
    Set
public:
property int^ RFID_bytesTransferred {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_channel Property

Axis..::..RFID_channel Property

RFID ones based index to reference RFID channel to operate on. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_channel { get; set; }
Public Property RFID_channel As Integer
    Get
    Set
public:
property int^ RFID_channel {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_control Property

Axis..::..RFID_control Property

RFID channel control register. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_control { get; set; }
Public Property RFID_control As Integer
    Get
    Set
public:
property int^ RFID_control {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_controlActive Property

Axis..::..RFID_controlActive Property

RFID channel control register currently written to RFID reader. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_controlActive { get; }
Public ReadOnly Property RFID_controlActive As Integer
    Get
public:
property int^ RFID_controlActive {
    int^ get ();
}

See Also

Controller..::..Axis Class


RFID_count Property

Axis..::..RFID_count Property

Number of bytes in an RFID block read - 1. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_count { get; }
Public ReadOnly Property RFID_count As Integer
    Get
public:
property int^ RFID_count {
    int^ get ();
}

See Also

Controller..::..Axis Class


RFID_data_readh Property

Axis..::..RFID_data_readh Property

Second 4 bytes of RFID read array. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_data_readh { get; set; }
Public Property RFID_data_readh As Integer
    Get
    Set
public:
property int^ RFID_data_readh {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_data_readl Property

Axis..::..RFID_data_readl Property

First 4 bytes of RFID read array. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_data_readl { get; set; }
Public Property RFID_data_readl As Integer
    Get
    Set
public:
property int^ RFID_data_readl {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_data_writeh Property

Axis..::..RFID_data_writeh Property

Second 4 bytes of RFID write array. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_data_writeh { get; set; }
Public Property RFID_data_writeh As Integer
    Get
    Set
public:
property int^ RFID_data_writeh {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_data_writel Property

Axis..::..RFID_data_writel Property

First 4 bytes of RFID write array. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_data_writel { get; set; }
Public Property RFID_data_writel As Integer
    Get
    Set
public:
property int^ RFID_data_writel {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_error Property

Axis..::..RFID_error Property

RFID error catagory and description. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_error { get; }
Public ReadOnly Property RFID_error As Integer
    Get
public:
property int^ RFID_error {
    int^ get ();
}

See Also

Controller..::..Axis Class


RFID_index Property

Axis..::..RFID_index Property

Index to RFID read and write array, 1 to 32. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_index { get; set; }
Public Property RFID_index As Integer
    Get
    Set
public:
property int^ RFID_index {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_lasttagIDh Property

Axis..::..RFID_lasttagIDh Property

Last RFID unique tag ID high. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_lasttagIDh { get; set; }
Public Property RFID_lasttagIDh As Integer
    Get
    Set
public:
property int^ RFID_lasttagIDh {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_lasttagIDl Property

Axis..::..RFID_lasttagIDl Property

Last RFID unique tag ID low. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_lasttagIDl { get; set; }
Public Property RFID_lasttagIDl As Integer
    Get
    Set
public:
property int^ RFID_lasttagIDl {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_state Property

Axis..::..RFID_state Property

Current state of RFID read/write logic. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_state { get; set; }
Public Property RFID_state As Integer
    Get
    Set
public:
property int^ RFID_state {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_status Property

Axis..::..RFID_status Property

RFID channel status register. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_status { get; }
Public ReadOnly Property RFID_status As Integer
    Get
public:
property int^ RFID_status {
    int^ get ();
}

See Also

Controller..::..Axis Class


RFID_tagIDh Property

Axis..::..RFID_tagIDh Property

Current RFID unique tag ID high 4 bytes. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_tagIDh { get; set; }
Public Property RFID_tagIDh As Integer
    Get
    Set
public:
property int^ RFID_tagIDh {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_tagIDl Property

Axis..::..RFID_tagIDl Property

Current RFID unique tag ID low 4 bytes. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_tagIDl { get; set; }
Public Property RFID_tagIDl As Integer
    Get
    Set
public:
property int^ RFID_tagIDl {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


RFID_totalChannels Property

Axis..::..RFID_totalChannels Property

Total channels of RFID readers available. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RFID_totalChannels { get; }
Public ReadOnly Property RFID_totalChannels As Integer
    Get
public:
property int^ RFID_totalChannels {
    int^ get ();
}

See Also

Controller..::..Axis Class


rmstrq Property

Axis..::..rmstrq Property

RMS torque, typically actual torque or current, also drive specific features. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float rmstrq { get; }
Public ReadOnly Property rmstrq As Single
    Get
public:
property float^ rmstrq {
    float^ get ();
}

See Also

Controller..::..Axis Class


running Property

Axis..::..running Property

Turns on output # if MSB running on axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int running { get; set; }
Public Property running As Integer
    Get
    Set
public:
property int^ running {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


runv Property

Axis..::..runv Property

runv - Present velocity. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float runv { get; set; }
Public Property runv As Single
    Get
    Set
public:
property float^ runv {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


sdc Property

Axis..::..sdc Property

Slave decrement counter. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int sdc { get; set; }
Public Property sdc As Integer
    Get
    Set
public:
property int^ sdc {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


settling Property

Axis..::..settling Property

Settling time in seconds for new position command change of direction, default 0. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double settling { get; set; }
Public Property settling As Double
    Get
    Set
public:
property double^ settling {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


sfmod Property

Axis..::..sfmod Property

Secondary feedback modulus, counts. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long sfmod { get; set; }
Public Property sfmod As Long
    Get
    Set
public:
property long long^ sfmod {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


sfpos Property

Axis..::..sfpos Property

Secondary position, sfposc/ppr, user units. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double sfpos { get; }
Public ReadOnly Property sfpos As Double
    Get
public:
property double^ sfpos {
    double^ get ();
}

See Also

Controller..::..Axis Class


sfposc Property

Axis..::..sfposc Property

Secondary feedback position counts. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long sfposc { get; set; }
Public Property sfposc As Long
    Get
    Set
public:
property long long^ sfposc {
    long long^ get ();
    void set (long long^ value);
}

See Also

Controller..::..Axis Class


sign Property

Axis..::..sign Property

sign - Direction of move, plus or minus. Read Only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int sign { get; }
Public ReadOnly Property sign As Integer
    Get
public:
property int^ sign {
    int^ get ();
}

See Also

Controller..::..Axis Class


smark Property

Axis..::..smark Property

Slave marker position, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int smark { get; }
Public ReadOnly Property smark As Integer
    Get
public:
property int^ smark {
    int^ get ();
}

See Also

Controller..::..Axis Class


smarkfall Property

Axis..::..smarkfall Property

Input bit mask fall, determines when smark is calculated, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int smarkfall { get; set; }
Public Property smarkfall As Integer
    Get
    Set
public:
property int^ smarkfall {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


smarkrise Property

Axis..::..smarkrise Property

Input bit mask rise, determines when smark is calculated, not currently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int smarkrise { get; set; }
Public Property smarkrise As Integer
    Get
    Set
public:
property int^ smarkrise {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


smod Property

Axis..::..smod Property

Smodc modulus. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int smod { get; set; }
Public Property smod As Integer
    Get
    Set
public:
property int^ smod {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


smodc Property

Axis..::..smodc Property

Slave position counter. Read/write only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int smodc { get; set; }
Public Property smodc As Integer
    Get
    Set
public:
property int^ smodc {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


spgai Property

Axis..::..spgai Property

Slave position delta in last gear at in. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int spgai { get; }
Public ReadOnly Property spgai As Integer
    Get
public:
property int^ spgai {
    int^ get ();
}

See Also

Controller..::..Axis Class


spgfi Property

Axis..::..spgfi Property

Slave position delta in last gear for in. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int spgfi { get; }
Public ReadOnly Property spgfi As Integer
    Get
public:
property int^ spgfi {
    int^ get ();
}

See Also

Controller..::..Axis Class


sphase Property

Axis..::..sphase Property

Slave marker phase position, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int sphase { get; }
Public ReadOnly Property sphase As Integer
    Get
public:
property int^ sphase {
    int^ get ();
}

See Also

Controller..::..Axis Class


sppr Property

Axis..::..sppr Property

Stepper pulses/rev, not currently used Read/write only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int sppr { get; set; }
Public Property sppr As Integer
    Get
    Set
public:
property int^ sppr {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


stepsout Property

Axis..::..stepsout Property

Stepper pulses output, not currently used. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long stepsout { get; }
Public ReadOnly Property stepsout As Long
    Get
public:
property long long^ stepsout {
    long long^ get ();
}

See Also

Controller..::..Axis Class


stoprate Property

Axis..::..stoprate Property

Stop rate. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float stoprate { get; set; }
Public Property stoprate As Single
    Get
    Set
public:
property float^ stoprate {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


theta Property

Axis..::..theta Property

Motor angle. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int theta { get; }
Public ReadOnly Property theta As Integer
    Get
public:
property int^ theta {
    int^ get ();
}

See Also

Controller..::..Axis Class


time Property

Axis..::..time Property

Time, incremented by loop period each interrupt. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double time { get; set; }
Public Property time As Double
    Get
    Set
public:
property double^ time {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


tlim Property

Axis..::..tlim Property

Torque limit. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float tlim { get; set; }
Public Property tlim As Single
    Get
    Set
public:
property float^ tlim {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


tmax Property

Axis..::..tmax Property

Max torque or current, % actual depending on drive support. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float tmax { get; set; }
Public Property tmax As Single
    Get
    Set
public:
property float^ tmax {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


tmc1 Property

Axis..::..tmc1 Property

Temporary master counter 1. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tmc1 { get; set; }
Public Property tmc1 As Integer
    Get
    Set
public:
property int^ tmc1 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tmc2 Property

Axis..::..tmc2 Property

Temporary master counter 2. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tmc2 { get; set; }
Public Property tmc2 As Integer
    Get
    Set
public:
property int^ tmc2 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tmodc Property

Axis..::..tmodc Property

Master position counter mod mmc. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tmodc { get; set; }
Public Property tmodc As Integer
    Get
    Set
public:
property int^ tmodc {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


touchProbeStatus Property

Axis..::..touchProbeStatus Property

Drive position registration latch status. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int touchProbeStatus { get; }
Public ReadOnly Property touchProbeStatus As Integer
    Get
public:
property int^ touchProbeStatus {
    int^ get ();
}

See Also

Controller..::..Axis Class


tpos Property

Axis..::..tpos Property

Target position = tposc/ppr. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double tpos { get; }
Public ReadOnly Property tpos As Double
    Get
public:
property double^ tpos {
    double^ get ();
}

See Also

Controller..::..Axis Class


tposc Property

Axis..::..tposc Property

Target position counts. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long tposc { get; }
Public ReadOnly Property tposc As Long
    Get
public:
property long long^ tposc {
    long long^ get ();
}

See Also

Controller..::..Axis Class


tracking_pstate Property

Axis..::..tracking_pstate Property

Slave axis state of move command during tracking. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tracking_pstate { get; }
Public ReadOnly Property tracking_pstate As Integer
    Get
public:
property int^ tracking_pstate {
    int^ get ();
}

See Also

Controller..::..Axis Class


tracking_sign Property

Axis..::..tracking_sign Property

Direction to move, 1 for positive, -1 for negative. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tracking_sign { get; }
Public ReadOnly Property tracking_sign As Integer
    Get
public:
property int^ tracking_sign {
    int^ get ();
}

See Also

Controller..::..Axis Class


tracking_status Property

Axis..::..tracking_status Property

QS2 status for tracking, state of motion slope for move. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tracking_status { get; }
Public ReadOnly Property tracking_status As Integer
    Get
public:
property int^ tracking_status {
    int^ get ();
}

See Also

Controller..::..Axis Class


tracking_tpos Property

Axis..::..tracking_tpos Property

Relative position of move command during tracking, 0 base. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double tracking_tpos { get; }
Public ReadOnly Property tracking_tpos As Double
    Get
public:
property double^ tracking_tpos {
    double^ get ();
}

See Also

Controller..::..Axis Class


tracking_tposc Property

Axis..::..tracking_tposc Property

Relative counts of move command during tracking, 0 base. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public long tracking_tposc { get; }
Public ReadOnly Property tracking_tposc As Long
    Get
public:
property long long^ tracking_tposc {
    long long^ get ();
}

See Also

Controller..::..Axis Class


trqc Property

Axis..::..trqc Property

Torque command, not presently used. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float trqc { get; set; }
Public Property trqc As Single
    Get
    Set
public:
property float^ trqc {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


tsc1 Property

Axis..::..tsc1 Property

Temporary slave counter 1. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc1 { get; set; }
Public Property tsc1 As Integer
    Get
    Set
public:
property int^ tsc1 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tsc1fall Property

Axis..::..tsc1fall Property

Input bit mask (fall) determines when tsc1 is cleared. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc1fall { get; set; }
Public Property tsc1fall As Integer
    Get
    Set
public:
property int^ tsc1fall {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tsc1rise Property

Axis..::..tsc1rise Property

Input bit mask (rise) determines when tsc1 is cleared. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc1rise { get; set; }
Public Property tsc1rise As Integer
    Get
    Set
public:
property int^ tsc1rise {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tsc2 Property

Axis..::..tsc2 Property

Temporary slave counter 2. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc2 { get; set; }
Public Property tsc2 As Integer
    Get
    Set
public:
property int^ tsc2 {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tsc2fall Property

Axis..::..tsc2fall Property

Input bit mask (fall) determines when tsc2 is cleared. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc2fall { get; set; }
Public Property tsc2fall As Integer
    Get
    Set
public:
property int^ tsc2fall {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


tsc2rise Property

Axis..::..tsc2rise Property

Input bit mask (rise) determines when tsc2 is cleared. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int tsc2rise { get; set; }
Public Property tsc2rise As Integer
    Get
    Set
public:
property int^ tsc2rise {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


uud Property

Axis..::..uud Property

User units denominator. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int uud { get; set; }
Public Property uud As Integer
    Get
    Set
public:
property int^ uud {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


uun Property

Axis..::..uun Property

User units numerator. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int uun { get; set; }
Public Property uun As Integer
    Get
    Set
public:
property int^ uun {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


Variable_timeout_ms Property

Axis..::..Variable_timeout_ms Property

Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int Variable_timeout_ms { get; set; }
Public Property Variable_timeout_ms As Integer
    Get
    Set
public:
property int^ Variable_timeout_ms {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..Axis Class


vcmd Property

Axis..::..vcmd Property

Velocity command, drive specific use. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float vcmd { get; set; }
Public Property vcmd As Single
    Get
    Set
public:
property float^ vcmd {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


vectorY Property

Axis..::..vectorY Property

Y axis move distance for linear interpolation. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double vectorY { get; set; }
Public Property vectorY As Double
    Get
    Set
public:
property double^ vectorY {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


vectorZ Property

Axis..::..vectorZ Property

Z axis move distance for linear interpolation. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double vectorZ { get; set; }
Public Property vectorZ As Double
    Get
    Set
public:
property double^ vectorZ {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


vel Property

Axis..::..vel Property

Velocity, in user units. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float vel { get; }
Public ReadOnly Property vel As Single
    Get
public:
property float^ vel {
    float^ get ();
}

See Also

Controller..::..Axis Class


velVector Property

Axis..::..velVector Property

Velocity vector, if circular then in radians/sec. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double velVector { get; }
Public ReadOnly Property velVector As Double
    Get
public:
property double^ velVector {
    double^ get ();
}

See Also

Controller..::..Axis Class


velX Property

Axis..::..velX Property

Velocity along X axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double velX { get; set; }
Public Property velX As Double
    Get
    Set
public:
property double^ velX {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


velY Property

Axis..::..velY Property

Velocity along Y axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double velY { get; set; }
Public Property velY As Double
    Get
    Set
public:
property double^ velY {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


velZ Property

Axis..::..velZ Property

Velocity along Z axis. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double velZ { get; set; }
Public Property velZ As Double
    Get
    Set
public:
property double^ velZ {
    double^ get ();
    void set (double^ value);
}

See Also

Controller..::..Axis Class


verr Property

Axis..::..verr Property

Velocity error, not used with EtherCAT. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float verr { get; }
Public ReadOnly Property verr As Single
    Get
public:
property float^ verr {
    float^ get ();
}

See Also

Controller..::..Axis Class


vmax Property

Axis..::..vmax Property

Max velocity. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float vmax { get; set; }
Public Property vmax As Single
    Get
    Set
public:
property float^ vmax {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


vmdelta Property

Axis..::..vmdelta Property

Virtual master delta counts. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int vmdelta { get; }
Public ReadOnly Property vmdelta As Integer
    Get
public:
property int^ vmdelta {
    int^ get ();
}

See Also

Controller..::..Axis Class


wControlWord Property

Axis..::..wControlWord Property

Current EtherCAT control word written. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int wControlWord { get; }
Public ReadOnly Property wControlWord As Integer
    Get
public:
property int^ wControlWord {
    int^ get ();
}

See Also

Controller..::..Axis Class


wStatus Property

Axis..::..wStatus Property

Current EtherCAT PDO status read. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int wStatus { get; }
Public ReadOnly Property wStatus As Integer
    Get
public:
property int^ wStatus {
    int^ get ();
}

See Also

Controller..::..Axis Class


zone_limit_neg Property

Axis..::..zone_limit_neg Property

IAI linear actuator zone negative limit. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float zone_limit_neg { get; set; }
Public Property zone_limit_neg As Single
    Get
    Set
public:
property float^ zone_limit_neg {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


zone_limit_pos Property

Axis..::..zone_limit_pos Property

IAI linear actuator zone positive limit. Read/write.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public float zone_limit_pos { get; set; }
Public Property zone_limit_pos As Single
    Get
    Set
public:
property float^ zone_limit_pos {
    float^ get ();
    void set (float^ value);
}

See Also

Controller..::..Axis Class


zpulse Property

Axis..::..zpulse Property

Zpulse seen, drive specific. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int zpulse { get; }
Public ReadOnly Property zpulse As Integer
    Get
public:
property int^ zpulse {
    int^ get ();
}

See Also

Controller..::..Axis Class


ZPULSE_NEG Property

Axis..::..ZPULSE_NEG Property

Z pulse negative direction, drive specific. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double ZPULSE_NEG { get; }
Public ReadOnly Property ZPULSE_NEG As Double
    Get
public:
property double^ ZPULSE_NEG {
    double^ get ();
}

See Also

Controller..::..Axis Class


ZPULSE_POS Property

Axis..::..ZPULSE_POS Property

Z pulse positive direction, drive specific. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public double ZPULSE_POS { get; }
Public ReadOnly Property ZPULSE_POS As Double
    Get
public:
property double^ ZPULSE_POS {
    double^ get ();
}

See Also

Controller..::..Axis Class


ztheta Property

Axis..::..ztheta Property

Motor angle of Z. Read only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int ztheta { get; }
Public ReadOnly Property ztheta As Integer
    Get
public:
property int^ ztheta {
    int^ get ();
}

See Also

Controller..::..Axis Class


Axis.CAP_REFERENCE Enumeration

Axis..::..CAP_REFERENCE Enumeration

Enum CAP_REFERENCE, Capture window references.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum CAP_REFERENCE
Public Enumeration CAP_REFERENCE
public enum class CAP_REFERENCE

Members

Member name | Description
FPOSC | fposc property, feedback position counter.
MPOSC1 | mposc1 property, master position, counts by 'mmc'.
MPOSC2 | mposc2 property, master position, counts by 'mmc'.
MPOSC3 | mposc3 property, master position, counts by 'mmc'.
MPOSC4 | mposc4 property, master position, counts by 'mmc'.
MPOSC5 | mposc5 property, master position, counts by 'mmc'.
MPOSC | mposc property, master position, counts.
SMODC | smodc property, slave position counter.
SMARK | smark property, slave modulo marker position, counts.
TMC1 | tmc1 property, temporary master position 1, counts.
TMC2 | tmc2 property, temporary master position 2, counts.
TSC1 | tsc1 property, temporary slave position 1, counts.
TSC2 | tsc2 property, temporary slave position 2, counts.
SDC | sdc property, slave decrement counter.
FPOSC1 | fposc property of axis 1, feedback position counter.
FPOSC2 | fposc property of axis 2, feedback position counter.
TMODC | tmodc property, temporary master position counter mod mmc.
SFPOSC | sfposc property, slave feedback position counter.
TPOSC | tposc property, target position counter.
CTRS0 | ctr0 property, axis counter.
CTRS1 | ctr1 property, axis counter.
CTRS2 | ctr2 property, axis counter.
CTRS3 | ctr3 property, axis counter.
CTRS4 | ctr4 property, axis counter.
MASTER_FPOSC0 | fposc property of master encoder 0, not currently used.
MASTER_FPOSC1 | fposc property of master encoder 1, not currently used.
MASTER_FPOSC2 | fposc property of master encoder 2, not currently used.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.CAPTURE_TRANSISTIONS Enumeration

Axis..::..CAPTURE_TRANSISTIONS Enumeration

Enum TRANSISTIONS, Edge transistions for capture.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum CAPTURE_TRANSISTIONS
Public Enumeration CAPTURE_TRANSISTIONS
public enum class CAPTURE_TRANSISTIONS

Members

Member name | Description
FALL | Falling edge.
RISE | Rising edge.
EDGE | Any edge.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.cbit Class

Axis..::..cbit Class

Common bit index class

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class cbit
Public Class cbit
public ref class cbit

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..Axis..::..cbit

See Also

Controller..::..Axis..::..cbit Members


Axis.cbit Members

Axis..::..cbit Members

The Controller..::..Axis..::..cbit type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..cbit Class


Axis.cbit Methods

Axis..::..cbit Methods

The Controller..::..Axis..::..cbit type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..Axis..::..cbit Class


Axis.cbit Properties

Axis..::..cbit Properties

The Controller..::..Axis..::..cbit type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..cbit Class


Item Property

cbit..::..Item Property

Gets or sets the Int32 with the specified index.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int this[
    int idx
] { get; set; }
Public Default Property Item ( _
    idx As Integer _
) As Integer
    Get
    Set
public:
property int^ default[int^ idx] {
    int^ get (int^ idx);
    void set (int^ idx, int^ value);
}

Parameters

idx
Type: Int32
The index.

Return Value

System.Int32.

Exceptions

Exception | Condition
ArgumentOutOfRangeException | Index limited 0 to 255

See Also

Controller..::..Axis..::..cbit Class


Axis.COMMAND_EXT_RESULTS Structure

Axis..::..COMMAND_EXT_RESULTS Structure

Struct COMMAND_EXT_RESULTS, Extended command to capture drive information more efficiently.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct COMMAND_EXT_RESULTS
<StructLayoutAttribute> _
Public Structure COMMAND_EXT_RESULTS
[StructLayoutAttribute]
public value class COMMAND_EXT_RESULTS

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Members


Axis.COMMAND_EXT_RESULTS Members

Axis..::..COMMAND_EXT_RESULTS Members

The Controller..::..Axis..::..COMMAND_EXT_RESULTS type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | acc | Requested acceleration if move command.
Public field | cmd_results | 0 if command processed, other if ignored, 1 msb stack error, 2 = invalid pstate, 3 = foreground, 4 = outstanding newposition, 5 = pstate not COMPLETE, 6 = PAUSE or PAUSE Delay (reversing directions).
Public field | dec | Requested deceleration if move command.
Public field | fpos | Feedback position.
Public field | fposc | Feedback position counts.
Public field | max_velocity | Requested max_velocity if move command.
Public field | mpos | Master position.
Public field | mposc | Master position counts.
Public field | perr | Position error.
Public field | position | Requested position if move command.
Public field | pstate | Motion PSTATES at time real-time API received request.
Public field | result | Command result with regards to API passing of request.
Public field | rmstrq | Current torque, drive specific for units.
Public field | runv | Theoretical velocity as calculated by profile.
Public field | timeStamp | System kernel ticks in 100uS intervals of when message removed from real-time API queue, 0 is at powerup.
Public field | tpos | Target position.
Public field | tposc | Target position counts.
Public field | vel | Current velocity as reported by drive.

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


Axis.COMMAND_EXT_RESULTS Fields

Axis..::..COMMAND_EXT_RESULTS Fields

The Controller..::..Axis..::..COMMAND_EXT_RESULTS type exposes the following members.

Fields

 | Name | Description
Public field | acc | Requested acceleration if move command.
Public field | cmd_results | 0 if command processed, other if ignored, 1 msb stack error, 2 = invalid pstate, 3 = foreground, 4 = outstanding newposition, 5 = pstate not COMPLETE, 6 = PAUSE or PAUSE Delay (reversing directions).
Public field | dec | Requested deceleration if move command.
Public field | fpos | Feedback position.
Public field | fposc | Feedback position counts.
Public field | max_velocity | Requested max_velocity if move command.
Public field | mpos | Master position.
Public field | mposc | Master position counts.
Public field | perr | Position error.
Public field | position | Requested position if move command.
Public field | pstate | Motion PSTATES at time real-time API received request.
Public field | result | Command result with regards to API passing of request.
Public field | rmstrq | Current torque, drive specific for units.
Public field | runv | Theoretical velocity as calculated by profile.
Public field | timeStamp | System kernel ticks in 100uS intervals of when message removed from real-time API queue, 0 is at powerup.
Public field | tpos | Target position.
Public field | tposc | Target position counts.
Public field | vel | Current velocity as reported by drive.

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


acc Field

COMMAND_EXT_RESULTS..::..acc Field

Requested acceleration if move command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double acc
<FieldOffsetAttribute> _
Public acc As Double
[FieldOffsetAttribute]
public:
double^ acc

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


cmd_results Field

COMMAND_EXT_RESULTS..::..cmd_results Field

0 if command processed, other if ignored, 1 msb stack error, 2 = invalid pstate, 3 = foreground, 4 = outstanding newposition, 5 = pstate not COMPLETE, 6 = PAUSE or PAUSE Delay (reversing directions).

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int cmd_results
<FieldOffsetAttribute> _
Public cmd_results As Integer
[FieldOffsetAttribute]
public:
int^ cmd_results

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


dec Field

COMMAND_EXT_RESULTS..::..dec Field

Requested deceleration if move command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double dec
<FieldOffsetAttribute> _
Public dec As Double
[FieldOffsetAttribute]
public:
double^ dec

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


fpos Field

COMMAND_EXT_RESULTS..::..fpos Field

Feedback position.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double fpos
<FieldOffsetAttribute> _
Public fpos As Double
[FieldOffsetAttribute]
public:
double^ fpos

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


fposc Field

COMMAND_EXT_RESULTS..::..fposc Field

Feedback position counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long fposc
<FieldOffsetAttribute> _
Public fposc As Long
[FieldOffsetAttribute]
public:
long long^ fposc

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


max_velocity Field

COMMAND_EXT_RESULTS..::..max_velocity Field

Requested max_velocity if move command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double max_velocity
<FieldOffsetAttribute> _
Public max_velocity As Double
[FieldOffsetAttribute]
public:
double^ max_velocity

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


mpos Field

COMMAND_EXT_RESULTS..::..mpos Field

Master position.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double mpos
<FieldOffsetAttribute> _
Public mpos As Double
[FieldOffsetAttribute]
public:
double^ mpos

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


mposc Field

COMMAND_EXT_RESULTS..::..mposc Field

Master position counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long mposc
<FieldOffsetAttribute> _
Public mposc As Long
[FieldOffsetAttribute]
public:
long long^ mposc

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


perr Field

COMMAND_EXT_RESULTS..::..perr Field

Position error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double perr
<FieldOffsetAttribute> _
Public perr As Double
[FieldOffsetAttribute]
public:
double^ perr

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


position Field

COMMAND_EXT_RESULTS..::..position Field

Requested position if move command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double position
<FieldOffsetAttribute> _
Public position As Double
[FieldOffsetAttribute]
public:
double^ position

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


pstate Field

COMMAND_EXT_RESULTS..::..pstate Field

Motion PSTATES at time real-time API received request.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Controller..::..Axis..::..PSTATES pstate
<FieldOffsetAttribute> _
Public pstate As Controller..::..Axis..::..PSTATES
[FieldOffsetAttribute]
public:
Controller..::..Axis..::..PSTATES^ pstate

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


result Field

COMMAND_EXT_RESULTS..::..result Field

Command result with regards to API passing of request.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Controller..::..Axis..::..MOTION_FAULTS result
<FieldOffsetAttribute> _
Public result As Controller..::..Axis..::..MOTION_FAULTS
[FieldOffsetAttribute]
public:
Controller..::..Axis..::..MOTION_FAULTS^ result

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


rmstrq Field

COMMAND_EXT_RESULTS..::..rmstrq Field

Current torque, drive specific for units.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float rmstrq
<FieldOffsetAttribute> _
Public rmstrq As Single
[FieldOffsetAttribute]
public:
float^ rmstrq

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


runv Field

COMMAND_EXT_RESULTS..::..runv Field

Theoretical velocity as calculated by profile.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float runv
<FieldOffsetAttribute> _
Public runv As Single
[FieldOffsetAttribute]
public:
float^ runv

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


timeStamp Field

COMMAND_EXT_RESULTS..::..timeStamp Field

System kernel ticks in 100uS intervals of when message removed from real-time API queue, 0 is at powerup.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public ulong timeStamp
<FieldOffsetAttribute> _
Public timeStamp As ULong
[FieldOffsetAttribute]
public:
unsigned long long^ timeStamp

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


tpos Field

COMMAND_EXT_RESULTS..::..tpos Field

Target position.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double tpos
<FieldOffsetAttribute> _
Public tpos As Double
[FieldOffsetAttribute]
public:
double^ tpos

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


tposc Field

COMMAND_EXT_RESULTS..::..tposc Field

Target position counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long tposc
<FieldOffsetAttribute> _
Public tposc As Long
[FieldOffsetAttribute]
public:
long long^ tposc

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


vel Field

COMMAND_EXT_RESULTS..::..vel Field

Current velocity as reported by drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float vel
<FieldOffsetAttribute> _
Public vel As Single
[FieldOffsetAttribute]
public:
float^ vel

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


Axis.COMMAND_EXT_RESULTS Methods

Axis..::..COMMAND_EXT_RESULTS Methods

The Controller..::..Axis..::..COMMAND_EXT_RESULTS type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Controller..::..Axis..::..COMMAND_EXT_RESULTS Structure


Axis.ctr Class

Axis..::..ctr Class

Counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class ctr
Public Class ctr
public ref class ctr

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..Axis..::..ctr

See Also

Controller..::..Axis..::..ctr Members


Axis.ctr Members

Axis..::..ctr Members

The Controller..::..Axis..::..ctr type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..ctr Class


Axis.ctr Methods

Axis..::..ctr Methods

The Controller..::..Axis..::..ctr type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..Axis..::..ctr Class


Axis.ctr Properties

Axis..::..ctr Properties

The Controller..::..Axis..::..ctr type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..ctr Class


Item Property

ctr..::..Item Property

Gets or sets the Int32 with the specified index.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int this[
    int idx
] { get; set; }
Public Default Property Item ( _
    idx As Integer _
) As Integer
    Get
    Set
public:
property int^ default[int^ idx] {
    int^ get (int^ idx);
    void set (int^ idx, int^ value);
}

Parameters

idx
Type: Int32
The index.

Return Value

System.Int32.

Exceptions

Exception | Condition
ArgumentOutOfRangeException | Index limited 0 to 7 or Index limited 0 to 7

See Also

Controller..::..Axis..::..ctr Class


Axis.cvar Class

Axis..::..cvar Class

Common variable index class

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class cvar
Public Class cvar
public ref class cvar

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..Axis..::..cvar

See Also

Controller..::..Axis..::..cvar Members


Axis.cvar Members

Axis..::..cvar Members

The Controller..::..Axis..::..cvar type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..cvar Class


Axis.cvar Methods

Axis..::..cvar Methods

The Controller..::..Axis..::..cvar type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..Axis..::..cvar Class


Axis.cvar Properties

Axis..::..cvar Properties

The Controller..::..Axis..::..cvar type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets the Int32 with the specified index.

See Also

Controller..::..Axis..::..cvar Class


Item Property

cvar..::..Item Property

Gets or sets the Int32 with the specified index.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int this[
    int idx
] { get; set; }
Public Default Property Item ( _
    idx As Integer _
) As Integer
    Get
    Set
public:
property int^ default[int^ idx] {
    int^ get (int^ idx);
    void set (int^ idx, int^ value);
}

Parameters

idx
Type: Int32
The index.

Return Value

System.Int32.

Exceptions

Exception | Condition
ArgumentOutOfRangeException | Index limited 0 to 255 or Index limited 0 to 255

See Also

Controller..::..Axis..::..cvar Class


Axis.DRIVE_TYPES Enumeration

Axis..::..DRIVE_TYPES Enumeration

Enum DRIVE_TYPES, specific drive types supported.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum DRIVE_TYPES
Public Enumeration DRIVE_TYPES
public enum class DRIVE_TYPES

Members

Member name | Description
DRIVE_UNDEFINED | None defined.
DRIVE_ANALOG | Analog drive.
DRIVE_COPLEY | Copley drive.
DRIVE_YASKAWA | Yaskawa drive.
DRIVE_ELMO | Elmo drive, not presently supported.
DRIVE_KOLLMORGEN | Kollmorgen drive.
DRIVE_SANYO_DENKI | Sanyo Denki drive.
DRIVE_EMERSON | Emerson drive.
DRIVE_AMC | Advanced Motion Controls drive.
DRIVE_VIRTUAL | Virtual axis, simulated drive.
DRIVE_IAI_ACON_MODE0 | IAI actuator MODE0 drive.
DRIVE_IAI_ACON_MODE3 | IAI actuator MODE3 drive.
DRIVE_ABB_MICROFLEX | ABB Miroflex drive.
DRIVE_MITSUBISHI | Mitsubishi drive.
DRIVE_PANASONIC | Panasonic drive, not presently supported.
DRIVE_LINMOT | LinMOT linear actuator drive.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.ECAT_OBJECT_SIZE Enumeration

Axis..::..ECAT_OBJECT_SIZE Enumeration

ECAT_OBJECT_SIZE, Size of EtherCAT object data in bytes as defined by EtherCAT object.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum ECAT_OBJECT_SIZE
Public Enumeration ECAT_OBJECT_SIZE
public enum class ECAT_OBJECT_SIZE

Members

Member name | Description
SINT | Signed 8 bit byte
USINT | Unsigned 8 bit byte
INT | Signed 16 bit integer
UINT | Unsigned 16 bit integer
DINT | Signed 32 bit integer
UDINT | Unsigned 32 bit integer

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.ETHERCAT_MODES Enumeration

Axis..::..ETHERCAT_MODES Enumeration

Enum ETHERCAT_MODES, EtherCAT support motion modes

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum ETHERCAT_MODES
Public Enumeration ETHERCAT_MODES
public enum class ETHERCAT_MODES

Members

Member name | Description
CYCLIC_SYNC_POSITION_MODE | Cyclic sync position mode, most common move used.
PROFILE_VELOCITY_MODE | Profile velocity mode.
INTERPOLATED_POSITION_MODE | Interpolated position mode.
PROFILE_POSITION_MODE | Profile Position mode.
PROFILE_TORQUE_MODE | Profile torque mode, not supported.
HOMING_MODE | Homing mode, drive specific

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.IncentiveAxisException Class

Axis..::..IncentiveAxisException Class

Class IncentiveAxisException, error handler. Throws enum MOTION_FAULTS.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class IncentiveAxisException : ApplicationException
Public Class IncentiveAxisException _
    Inherits ApplicationException
public ref class IncentiveAxisException : public ApplicationException

Inheritance Hierarchy

Object
Exception
ApplicationException
CTC_Incentive..::..Controller..::..Axis..::..IncentiveAxisException

See Also

Controller..::..Axis..::..IncentiveAxisException Members
CTC_Incentive Namespace
ApplicationException


Axis.IncentiveAxisException Members

Axis..::..IncentiveAxisException Members

The Controller..::..Axis..::..IncentiveAxisException type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..Axis..::..IncentiveAxisException()()()() | Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.
Public method | Controller..::..Axis..::..IncentiveAxisException(Controller..::..Axis..::..MOTION_FAULTS) | Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a MOTION_FAULTS error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..Axis..::..IncentiveAxisException Class


IncentiveAxisException Constructor

Overload List

 | Name | Description
Public method | Controller..::..Axis..::..IncentiveAxisException()()()() | Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.
Public method | Controller..::..Axis..::..IncentiveAxisException(Controller..::..Axis..::..MOTION_FAULTS) | Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.

See Also

Controller..::..Axis..::..IncentiveAxisException Class
Controller..::..Axis..::..IncentiveAxisException Members


IncentiveAxisException Constructor

Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentiveAxisException()
Public Sub New
public:
IncentiveAxisException()

See Also

Controller..::..Axis..::..IncentiveAxisException Class
Controller..::..Axis..::..IncentiveAxisException Overload


IncentiveAxisException Constructor (MOTION_FAULTS)

Initializes a new instance of the Controller..::..Axis..::..IncentiveAxisException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentiveAxisException(
    Controller..::..Axis..::..MOTION_FAULTS error
)
Public Sub New ( _
    error As Controller..::..Axis..::..MOTION_FAULTS _
)
public:
IncentiveAxisException(
    Controller..::..Axis..::..MOTION_FAULTS^ error
)

Parameters

error
Type: CTC_Incentive..::..Controller..::..Axis..::..MOTION_FAULTS
MOTION_FAULTS error code.

See Also

Controller..::..Axis..::..IncentiveAxisException Class
Controller..::..Axis..::..IncentiveAxisException Overload


Axis.IncentiveAxisException Methods

Axis..::..IncentiveAxisException Methods

The Controller..::..Axis..::..IncentiveAxisException type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

Controller..::..Axis..::..IncentiveAxisException Class


Axis.IncentiveAxisException Properties

Axis..::..IncentiveAxisException Properties

The Controller..::..Axis..::..IncentiveAxisException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a MOTION_FAULTS error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Controller..::..Axis..::..IncentiveAxisException Class


ErrCode Property

IncentiveAxisException..::..ErrCode Property

Gets a MOTION_FAULTS error code that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..Axis..::..MOTION_FAULTS ErrCode { get; }
Public ReadOnly Property ErrCode As Controller..::..Axis..::..MOTION_FAULTS
    Get
public:
property Controller..::..Axis..::..MOTION_FAULTS^ ErrCode {
    Controller..::..Axis..::..MOTION_FAULTS^ get ();
}

See Also

Controller..::..Axis..::..IncentiveAxisException Class


ErrMessage Property

IncentiveAxisException..::..ErrMessage Property

Gets a message that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string ErrMessage { get; }
Public ReadOnly Property ErrMessage As String
    Get
public:
property String^ ErrMessage {
    String^ get ();
}

See Also

Controller..::..Axis..::..IncentiveAxisException Class


Axis.IncentiveAxisException Events

Axis..::..IncentiveAxisException Events

The Controller..::..Axis..::..IncentiveAxisException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..Axis..::..IncentiveAxisException Class


Axis.MASTER_MODES Enumeration

Axis..::..MASTER_MODES Enumeration

Enum MASTER_MODES, master feedback position modes, referencing master_feedback variable for axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum MASTER_MODES
Public Enumeration MASTER_MODES
public enum class MASTER_MODES

Members

Member name | Description
FEEDBACK | fpos feedback.
FEEDBACKZ | fposz feedback, currently not supported due to drive limitations.
TARGET | tpos feedback.
VIRTUAL | Virtual master, currently not used since virtual axis can run its own simulated encoder.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.MOTION_FAULTS Enumeration

Axis..::..MOTION_FAULTS Enumeration

Enum MOTION_FAULTS, Errors returned by axis functions.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum MOTION_FAULTS
Public Enumeration MOTION_FAULTS
public enum class MOTION_FAULTS

Members

Member name | Description
MF_NO_ERROR | No Error.
MF_GENERICFAULT | Generic Fault.
MF_INVALIDTIME | Time request on move command is not possible or is negative.
MF_INVALIDVEL | Invalid velocity.
MF_INVALIDACC | Invalid acceleration.
MF_INVALIDDEC | Invalid deceleration.
MF_INVALIDRATE | Invalid rate.
MF_ONLYINBG | This command can only run in background mode and foreground was attempted.
MF_MOTIONACTIVE | Attempted a move while already active moving.
MF_UNIMPLEMENTED | Attempted to execute unimplemented command.
MF_WRONGMODE | Attempting to set mode but pstate is not in proper state.
MF_FGMSBLIMIT | Attempted too many foreground MSBs.
MF_NOTINSLEW | Not in slew mode and it is required for this operation.
MF_FOLLOWERR | Error > perrlimit.
MF_BADINPUTNO | Invalid input number.
MF_NOTENABLED | Drive not enabled.
MF_BADARGUMENT1 | Bad argument 1.
MF_INVALID_TBL_OP | Invalid table operation, for example table # or points exceeds limits.
MF_NOTINTRACK | Not in tracking mode and it is required for this command.
MF_CANTCONSUME | When gearing, mtm != MTM_GEAR_AT.
MF_SESGMOVE_ERROR | Segmove error, current velocity is not zero.
MF_SESGMOVE_SIZE | Not enough room to add segment.
MF_NOCAMFILE | Attempted to load CAM file but failed.
MF_REMOTE_READ | Host read error.
MF_REMOTE_WRITE | Host write error.
MF_NOMSBFILE | Attempted to load MSB file but failed.
MF_BADARGUMENT2 | Bad argument 2.
MF_BADARGUMENT3 | Bad argument 3.
MF_BADARGUMENT4 | Bad argument 4.
MF_SDO_READ | SDO Read error.
MF_SDO_WRITE | SDO Write error.
MF_DRIVE_ERR_MSG | General drive logging fault, check logs.
MF_ECAT_OFFLINE | Attempted command but EtherCAT is offline.
MF_DCSYNC | EtherCAT DC Sync command failed.
MF_INVALID_ECAT_MODE | Attempting to process a move command request but the EtherCAT drive is in the wrong mode (cmode).
MF_STACK_ERROR | MSB stack error
MF_READONLY | Attempted to write to read only
MF_INVALID_TBL_OP_Y | Out of room in table, Y axis.
MF_INVALID_TBL_OP_Z | Out of room in table, Z axis.
MF_INVALID_TRACKING | Attempting to begin slew but in TRACKING mode.
MF_TIMEOUT | Command timeout, typically Wait For In Position optional timeout or other command supporting it.
MF_ERROR_NO_SERVO | No Servo existed?
MF_ABORT_REQUESTED | Abort was requested, probably from download of a new QB program while API was running.
MF_MESSAGE_RESULT | Command returned with a bad result message length, should be 4 byte int?
MF_NTX_TYPE_RT_PROCESS | Attempted to attached to a process other than real time?
MF_ECATQueAPI | The PLC mailbox is missing? Possibly not running.
MF_ECATQue_RESPONSE | The PLC response mailbox is missing? Possibly invalid name or duplicate?
MF_ECATQue_REQUEST | The PLC request mailbox is missing? Possibly invalid name or duplicate?
MF_NAME_TO_LONG | The PLC request mailbox name is too long? Limited to 8 characters maximum.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.MOVE_CMD Enumeration

Axis..::..MOVE_CMD Enumeration

Enum MOVE_CMD

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum MOVE_CMD
Public Enumeration MOVE_CMD
public enum class MOVE_CMD

Members

Member name | Description
ABSTRI | The abstri
INCTRI | The inctri
ABSTRAP | The abstrap
INCTRAP | The inctrap
ABSTRAP3 | The abstra p3
INCTRAP3 | The inctra p3
ABSTIMETRAP | The abstimetrap
INCTIMETRAP | The inctimetrap
SLEWATIN | The slewatin
SLEWFOR | The slewfor
NEWENDPOSITION | The newendposition
NEWENDPOSITION_RELATIVE | The newendpositio n_ relative
RESET | The reset
SET_TPOS | The se t_ tpos
SET_FPOS | The se t_ fpos
OFFSET_POS | The offse t_ position
DEFINE_PLS | The defin e_ PLS
PLS_ON | The pl s_ on
PLS_OFF | The pl s_ off
ABSTIMETRAP_N | The abstimetra p_ n
INCTIMETRAP_N | The inctimetra p_ n
SET_SIMFBK | The se t_ simfbk
MOVE_MASTER | The mov e_ master
SEEK_TPOS | The see k_ tpos
MOVE_MASTER_FOREVER | The mov e_ maste r_ forever
MOVE_MASTER_RAMP | The mov e_ maste r_ ramp
MOVE_MASTER_FOREVER_RAMP | The mov e_ maste r_ foreve r_ ramp
SET_LOOPPERIOD | The se t_ loopperiod
PLS_SETOUTPUT | The pl s_ setoutput
PWM_GEN | The pw m_ gen
PLS_SETMOD | The pl s_ setmod
PLS_SETINPUT_FALLING | The pl s_ setinpu t_ falling
PLS_SETINPUT_RISING | The pl s_ setinpu t_ rising
TABLE_CLEAR | The tabl e_ clear
TABLE_ADDPAIR | The tabl e_ addpair
TABLE_ADDSERIES | The tabl e_ addseries
TABLE_COMPUTE | The tabl e_ compute
TABLE_START | The tabl e_ start
TABLE_START_CAM | The tabl e_ star t_ cam
TABLE_STOP | The tabl e_ stop
TABLE_LOADSERIES | The tabl e_ loadseries
TABLE_LOADOFFSET | The tabl e_ loadoffset
TABLE_COPY | The tabl e_ copy
TABLE_CONTINUE_CAM | The tabl e_ continu e_ cam
GEAR_AT | The gea r_ at
GEAR_AT_IN | The gea r_ a t_ in
GEAR_FOR_IN | The gea r_ fo r_ in
GEAR_AT_IN_AFTER | The gea r_ a t_ i n_ after
MOVESLAVE | The moveslave
CON_MASTER | The co n_ master
CON_SLAVE | The co n_ slave
DEFINE_PLS_EXTENDED | The defin e_ pl s_ extended
SM_CLEAR | The s m_ clear
SM_AD_USING | The s m_ a d_ using
SM_AD_FOR | The s m_ a d_ for
SM_SLEW_UNTIL_POS | The s m_ sle w_ unti l_ position
START_REL | The star t_ relative
GEAR_FOR_IN_AFTER | The gea r_ fo r_ i n_ after
SM_STOP_AT_USING | The s m_ sto p_ a t_ using
MSB_DREN | The ms b_ dren
MSB_DRDIS | The ms b_ drdis
MSB_STOP | The ms b_ stop
MSB_SETM | The ms b_ setm
MSB_SETMS | The ms b_ setms
MSB_ONRISE | The ms b_ onrise
MSB_ONFALL | The ms b_ onfall
MSB_PULSEOUT_EXT | The ms b_ pulseou t_ ext
MSB_SETOUT | The ms b_ setout
MSB_CLROUT | The ms b_ clrout
MSB_REMOTE_SDO_READ | The ms b_ remot e_ sd o_ read
MSB_REMOTE_SDO_WRITE | The ms b_ remot e_ sd o_ write
MSB_REM_DCSYNC | The ms b_ re m_ dcsync
MSB_WAITIP | The ms b_ waitip
MSB_ZERO | The ms b_ zero
MSB_RELAX | The ms b_ relax
MSB_DELAY | The ms b_ delay
MSB_SETCAPWIN | The ms b_ setcapwin
MSB_SETCAP | The ms b_ setcap
MSB_WAITCAP | The ms b_ waitcap
MSB_SETCBIT | The ms b_ setcbit
MSB_SETCVAR | The ms b_ setcvar
MSB_WAITCBIT | The ms b_ waitcbit
MSB_WAITCVAR_INRANGE | The ms b_ waitcva r_ inrange
MSB_WAITCVAR_NOT_INRANGE | The ms b_ waitcva r_ no t_ inrange
MSB_CBIT | The ms b_ cbit
MSB_CVAR | The ms b_ cvar
MSB_CLRTRACKVARS | The ms b_ clrtrackvars
READ_VAR | The rea d_ variable
WRITE_VAR | The writ e_ variable
RESTART_NETWORK | Invoke this command to reset the EtherCAT Network.
ABSTRAP_EXT | The abstrap returning with drive information
INCTRAP_EXT | The inctrap returning with drive information
READ_DRIVE_PROPERTIES | Read drive properties as a block instead of individually

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.MOVE_PARAM Structure

Axis..::..MOVE_PARAM Structure

Struct MOVE_PARAM, typically used internally to request and pass parameters for certain motion commands.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct MOVE_PARAM
<StructLayoutAttribute> _
Public Structure MOVE_PARAM
[StructLayoutAttribute]
public value class MOVE_PARAM

See Also

Controller..::..Axis..::..MOVE_PARAM Members


Axis.MOVE_PARAM Members

Axis..::..MOVE_PARAM Members

The Controller..::..Axis..::..MOVE_PARAM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | arg_cnt | Number of arguments passing where 0 is the command only
Public field | axisnum | Axis number, starting with 1, to access.
Public field | cmd | _MOVE_CMD command that is to be executed.
Public field | d_args1 | first double argument
Public field | d_args2 | second double argument
Public field | d_args3 | third double argument
Public field | d_args4 | fourth double argument
Public field | d_args5 | fifth double argument
Public field | f_args1 | first float argument
Public field | f_args2 | second float argument
Public field | i_args1 | first integer argument
Public field | i_args2 | second integer argument
Public field | i_args3 | third integer argument
Public field | i_args4 | fourth integer argument
Public field | i_args5 | fifth integer argument
Public field | ll_args1 | first long, int64 argument
Public field | ll_args2 | second long, int64 argument
Public field | msb_index | Assigned MSB index on the selected axis to access.
Public field | segment | Table segment to access if relavent.
Public field | timeout | Optional timeout in milliseconds for this command available on some requests.
Public field | var_index | Used when reading or writing axis variables, this is the variable index assign defining which want to access, see avartable.h
Public field | var_type | Type of variable, VARIANT_INTEGER, VARIANT_DOUBLE, etc...

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


Axis.MOVE_PARAM Fields

Axis..::..MOVE_PARAM Fields

The Controller..::..Axis..::..MOVE_PARAM type exposes the following members.

Fields

 | Name | Description
Public field | arg_cnt | Number of arguments passing where 0 is the command only
Public field | axisnum | Axis number, starting with 1, to access.
Public field | cmd | _MOVE_CMD command that is to be executed.
Public field | d_args1 | first double argument
Public field | d_args2 | second double argument
Public field | d_args3 | third double argument
Public field | d_args4 | fourth double argument
Public field | d_args5 | fifth double argument
Public field | f_args1 | first float argument
Public field | f_args2 | second float argument
Public field | i_args1 | first integer argument
Public field | i_args2 | second integer argument
Public field | i_args3 | third integer argument
Public field | i_args4 | fourth integer argument
Public field | i_args5 | fifth integer argument
Public field | ll_args1 | first long, int64 argument
Public field | ll_args2 | second long, int64 argument
Public field | msb_index | Assigned MSB index on the selected axis to access.
Public field | segment | Table segment to access if relavent.
Public field | timeout | Optional timeout in milliseconds for this command available on some requests.
Public field | var_index | Used when reading or writing axis variables, this is the variable index assign defining which want to access, see avartable.h
Public field | var_type | Type of variable, VARIANT_INTEGER, VARIANT_DOUBLE, etc...

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


arg_cnt Field

MOVE_PARAM..::..arg_cnt Field

Number of arguments passing where 0 is the command only

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int arg_cnt
<FieldOffsetAttribute> _
Public arg_cnt As Integer
[FieldOffsetAttribute]
public:
int^ arg_cnt

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


axisnum Field

MOVE_PARAM..::..axisnum Field

Axis number, starting with 1, to access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int axisnum
<FieldOffsetAttribute> _
Public axisnum As Integer
[FieldOffsetAttribute]
public:
int^ axisnum

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


cmd Field

MOVE_PARAM..::..cmd Field

_MOVE_CMD command that is to be executed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Controller..::..Axis..::..MOVE_CMD cmd
<FieldOffsetAttribute> _
Public cmd As Controller..::..Axis..::..MOVE_CMD
[FieldOffsetAttribute]
public:
Controller..::..Axis..::..MOVE_CMD^ cmd

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


d_args1 Field

MOVE_PARAM..::..d_args1 Field

first double argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double d_args1
<FieldOffsetAttribute> _
Public d_args1 As Double
[FieldOffsetAttribute]
public:
double^ d_args1

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


d_args2 Field

MOVE_PARAM..::..d_args2 Field

second double argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double d_args2
<FieldOffsetAttribute> _
Public d_args2 As Double
[FieldOffsetAttribute]
public:
double^ d_args2

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


d_args3 Field

MOVE_PARAM..::..d_args3 Field

third double argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double d_args3
<FieldOffsetAttribute> _
Public d_args3 As Double
[FieldOffsetAttribute]
public:
double^ d_args3

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


d_args4 Field

MOVE_PARAM..::..d_args4 Field

fourth double argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double d_args4
<FieldOffsetAttribute> _
Public d_args4 As Double
[FieldOffsetAttribute]
public:
double^ d_args4

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


d_args5 Field

MOVE_PARAM..::..d_args5 Field

fifth double argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double d_args5
<FieldOffsetAttribute> _
Public d_args5 As Double
[FieldOffsetAttribute]
public:
double^ d_args5

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


f_args1 Field

MOVE_PARAM..::..f_args1 Field

first float argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float f_args1
<FieldOffsetAttribute> _
Public f_args1 As Single
[FieldOffsetAttribute]
public:
float^ f_args1

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


f_args2 Field

MOVE_PARAM..::..f_args2 Field

second float argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float f_args2
<FieldOffsetAttribute> _
Public f_args2 As Single
[FieldOffsetAttribute]
public:
float^ f_args2

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


i_args1 Field

MOVE_PARAM..::..i_args1 Field

first integer argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int i_args1
<FieldOffsetAttribute> _
Public i_args1 As Integer
[FieldOffsetAttribute]
public:
int^ i_args1

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


i_args2 Field

MOVE_PARAM..::..i_args2 Field

second integer argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int i_args2
<FieldOffsetAttribute> _
Public i_args2 As Integer
[FieldOffsetAttribute]
public:
int^ i_args2

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


i_args3 Field

MOVE_PARAM..::..i_args3 Field

third integer argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int i_args3
<FieldOffsetAttribute> _
Public i_args3 As Integer
[FieldOffsetAttribute]
public:
int^ i_args3

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


i_args4 Field

MOVE_PARAM..::..i_args4 Field

fourth integer argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int i_args4
<FieldOffsetAttribute> _
Public i_args4 As Integer
[FieldOffsetAttribute]
public:
int^ i_args4

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


i_args5 Field

MOVE_PARAM..::..i_args5 Field

fifth integer argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int i_args5
<FieldOffsetAttribute> _
Public i_args5 As Integer
[FieldOffsetAttribute]
public:
int^ i_args5

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


ll_args1 Field

MOVE_PARAM..::..ll_args1 Field

first long, int64 argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long ll_args1
<FieldOffsetAttribute> _
Public ll_args1 As Long
[FieldOffsetAttribute]
public:
long long^ ll_args1

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


ll_args2 Field

MOVE_PARAM..::..ll_args2 Field

second long, int64 argument

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long ll_args2
<FieldOffsetAttribute> _
Public ll_args2 As Long
[FieldOffsetAttribute]
public:
long long^ ll_args2

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


msb_index Field

MOVE_PARAM..::..msb_index Field

Assigned MSB index on the selected axis to access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int msb_index
<FieldOffsetAttribute> _
Public msb_index As Integer
[FieldOffsetAttribute]
public:
int^ msb_index

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


segment Field

MOVE_PARAM..::..segment Field

Table segment to access if relavent.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int segment
<FieldOffsetAttribute> _
Public segment As Integer
[FieldOffsetAttribute]
public:
int^ segment

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


timeout Field

MOVE_PARAM..::..timeout Field

Optional timeout in milliseconds for this command available on some requests.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int timeout
<FieldOffsetAttribute> _
Public timeout As Integer
[FieldOffsetAttribute]
public:
int^ timeout

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


var_index Field

MOVE_PARAM..::..var_index Field

Used when reading or writing axis variables, this is the variable index assign defining which want to access, see avartable.h

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int var_index
<FieldOffsetAttribute> _
Public var_index As Integer
[FieldOffsetAttribute]
public:
int^ var_index

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


var_type Field

MOVE_PARAM..::..var_type Field

Type of variable, VARIANT_INTEGER, VARIANT_DOUBLE, etc...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int var_type
<FieldOffsetAttribute> _
Public var_type As Integer
[FieldOffsetAttribute]
public:
int^ var_type

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


Axis.MOVE_PARAM Methods

Axis..::..MOVE_PARAM Methods

The Controller..::..Axis..::..MOVE_PARAM type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Controller..::..Axis..::..MOVE_PARAM Structure


Axis.PSTATES Enumeration

Axis..::..PSTATES Enumeration

Enum PSTATES, present motion state of axis

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum PSTATES
Public Enumeration PSTATES
public enum class PSTATES

Members

Member name | Description
IDLE | Axis is idle.
RUNNING | Axis is running.
COMPLETE | Completed move, ready for command.
STOP | STOP.
SLEWSTOP | Slewed Stop
SLEWING | Slewing
PRESPLINE | pre 'SPLINE' move
PRECAM | pre 'CAM' move
PRECAM_REVERSE | run cam table in reverse
CONT_CAM | continue cam from where stopped (assumes did jog)
INSPLINE | in 'SPLINE' move
INCAM | in 'CAM' move
TABLESTOP | stop table
TRACKING | geared and tracking
PRETRACKING | initialization for TRACKING (geared) mode
EXIT_TRACKING | exiting TRACKING mode
ECAT_COMPLETE_PENDING | EtherCAT Complete pending mode
ECAT_PROFILE_POS_INIT | Profile Position mode INIT state
ECAT_PROFILE_POS_STARTING1 | Profile Position mode STARTING1 state
ECAT_PROFILE_POS_STARTING1A | Profile Position mode STARTING1A state
ECAT_PROFILE_POS_STARTING2 | Profile Position mode STARTING2 state
ECAT_PROFILE_POS_RUNNING | Profile Position mode RUNNING state
ECAT_PROFILE_POS_WAIT_INPOS | Profile Position mode WAIT_INPOS state
ECAT_PROFILE_VEL_INIT | Profile Velocity mode INIT state
ECAT_PROFILE_VEL_WAIT_DELAY1 | Profile Velocity mode DELAY1 state
ECAT_PROFILE_VEL_WAIT_DELAY2 | Profile Velocity mode DELAY2 state
ECAT_PROFILE_VEL_WAIT_DELAY3 | Profile Velocity mode DELAY3 state
ECAT_PROFILE_VEL_WAIT | Profile Velocity mode WAIT state
ECAT_PROFILE_TORQUE_INIT | Profile Torque mode INIT state
ECAT_PROFILE_INIT_CSP | Cyclic Sync Position mode INIT state
ECAT_PROFILE_INIT_INTERPOLATED | Interpolated Position mode INIT state
ECAT_PROFILE_WAIT_CSP1 | Cyclic Sync Position mode WAIT_CSP1 state
ECAT_PROFILE_WAIT_CSP2 | Cyclic Sync Position mode WAIT_CSP2 state
ECAT_MODE_WAIT_CSP | Cyclic Sync Position mode WAIT_CSP state
ECAT_MODE_WAIT_INTERPOLATED | Interpolated Position mode WAIT_INTERPOLATED state
ECAT_MODE_WAIT_PROFILE | Profile mode WAIT state
ECAT_PROFILE_INIT_QSTOP | Quick Stop mode INIT_QSTOP state
ECAT_PROFILE_WAIT_QSTOP1 | Quick Stop mode WAIT_QSTOP1 state
ECAT_PROFILE_WAIT_QSTOP2 | Quick Stop mode WAIT_QSTOP2 state
ECAT_PROFILE_WAIT_QSTOP | Quick Stop mode WAIT_QSTOP state
ECAT_PROFILE_AT_VEL | EtherCAT Profile At Velocity state
ECAT_PROFILE_AT_TORQUE | EtherCAT Profile At Torque state
ECAT_HOMING_INIT | HOMING mode INIT state
ECAT_HOMING_STARTING1 | HOMING mode STARTING1 state
ECAT_HOMING_STARTING1A | HOMING mode STARTING1A state
ECAT_HOMING_STARTING2 | HOMING mode STARTING2 state
ECAT_HOMING_RUNNING | HOMING mode RUNNING state
ECAT_HOMING_WAIT_INPOS_KOLLMORGEN | HOMING mode WAIT_INPOS_KOLLMORGEN state
ECAT_HOMING_WAIT_INPOS | HOMING mode WAIT_INPOS state
ECAT_HOMING_WAIT_INPOS_IAI | HOMING mode WAIT_INPOS_IAI state
ECAT_PROFILE_POS_WAIT_ABORTING | HOMING mode WAIT_ABORTING state
ECAT_OFFLINE | EtherCAT Offline mode

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Axis.SDO_READ_RESULTS Structure

Axis..::..SDO_READ_RESULTS Structure

Struct SDO_READ_RESULTS, Extended command results from reading a drive property over EtherCAT.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct SDO_READ_RESULTS
<StructLayoutAttribute> _
Public Structure SDO_READ_RESULTS
[StructLayoutAttribute]
public value class SDO_READ_RESULTS

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Members


Axis.SDO_READ_RESULTS Members

Axis..::..SDO_READ_RESULTS Members

The Controller..::..Axis..::..SDO_READ_RESULTS type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ivalue | integer value.
Public field | result | Command result.
Public field | uvalue | unsigned integer value.

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


Axis.SDO_READ_RESULTS Fields

Axis..::..SDO_READ_RESULTS Fields

The Controller..::..Axis..::..SDO_READ_RESULTS type exposes the following members.

Fields

 | Name | Description
Public field | ivalue | integer value.
Public field | result | Command result.
Public field | uvalue | unsigned integer value.

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


ivalue Field

SDO_READ_RESULTS..::..ivalue Field

integer value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int ivalue
<FieldOffsetAttribute> _
Public ivalue As Integer
[FieldOffsetAttribute]
public:
int^ ivalue

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


result Field

SDO_READ_RESULTS..::..result Field

Command result.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Controller..::..Axis..::..MOTION_FAULTS result
<FieldOffsetAttribute> _
Public result As Controller..::..Axis..::..MOTION_FAULTS
[FieldOffsetAttribute]
public:
Controller..::..Axis..::..MOTION_FAULTS^ result

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


uvalue Field

SDO_READ_RESULTS..::..uvalue Field

unsigned integer value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public uint uvalue
<FieldOffsetAttribute> _
Public uvalue As UInteger
[FieldOffsetAttribute]
public:
unsigned int^ uvalue

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


Axis.SDO_READ_RESULTS Methods

Axis..::..SDO_READ_RESULTS Methods

The Controller..::..Axis..::..SDO_READ_RESULTS type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Controller..::..Axis..::..SDO_READ_RESULTS Structure


Axis.TABLE_MOVES Enumeration

Axis..::..TABLE_MOVES Enumeration

Enum TABLE_MOVES, table computational modes.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum TABLE_MOVES
Public Enumeration TABLE_MOVES
public enum class TABLE_MOVES

Members

Member name | Description
LINEAR | Linear computational move.
QUADRATIC | Quadratic computational move.
CUBIC | CUBIC computational move.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Controller.AxisSupervisor Class

Controller..::..AxisSupervisor Class

Class AxisSupervisor used to interact with the EtherCAT Master when the PLC logic process is not running or wish to control a single network directly.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class AxisSupervisor
Public Class AxisSupervisor
public ref class AxisSupervisor

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..AxisSupervisor

See Also

Controller..::..AxisSupervisor Members


Controller.AxisSupervisor Members

Controller..::..AxisSupervisor Members

The Controller..::..AxisSupervisor type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..AxisSupervisor | Class creation for an Axis.

Methods

 | Name | Description
Public method | closeConnection | This method closes a connection to the EtherCAT Master runtime.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getResources | Gets the resources of only this EtherCAT network. Use the PLCLogic for entire system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | openConnection | This method opens a connection to the EtherCAT Master runtime for motion control.
Public method | restartEtherCAT | Restart the EtherCAT network. MSB connections will be cleared so best to close axis connections prior to this call.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | connected | Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.
Public field | errorCode | Last function call operation result code in case fails
Public field | errString | Last function call operation error string information if available.
Public field | name | Name of process accessing, typically CTECAT_1 or CTECAT_2.
Public field | resources | Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

Properties

 | Name | Description
Public property | scanning | scanning - Reflects the state of the EtherCAT Master scan engine, SCAN_STATES.OFFLINE not running, SCAN_STATES.INITIALIZING initializing, SCAN_STATES.RUNNING scanning. Read Only.

See Also

Controller..::..AxisSupervisor Class


AxisSupervisor Constructor

Class creation for an Axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public AxisSupervisor()
Public Sub New
public:
AxisSupervisor()

See Also

Controller..::..AxisSupervisor Class


Controller.AxisSupervisor Fields

Controller..::..AxisSupervisor Fields

The Controller..::..AxisSupervisor type exposes the following members.

Fields

 | Name | Description
Public field | connected | Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.
Public field | errorCode | Last function call operation result code in case fails
Public field | errString | Last function call operation error string information if available.
Public field | name | Name of process accessing, typically CTECAT_1 or CTECAT_2.
Public field | resources | Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

See Also

Controller..::..AxisSupervisor Class


connected Field

AxisSupervisor..::..connected Field

Set if connected to EtherCAT Axis mailbox and ready to issue commands and read/write properties.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool connected
Public connected As Boolean
public:
bool^ connected

See Also

Controller..::..AxisSupervisor Class


errorCode Field

AxisSupervisor..::..errorCode Field

Last function call operation result code in case fails

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int errorCode
Public errorCode As Integer
public:
int^ errorCode

See Also

Controller..::..AxisSupervisor Class


errString Field

AxisSupervisor..::..errString Field

Last function call operation error string information if available.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string errString
Public errString As String
public:
String^ errString

See Also

Controller..::..AxisSupervisor Class


name Field

AxisSupervisor..::..name Field

Name of process accessing, typically CTECAT_1 or CTECAT_2.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string name
Public name As String
public:
String^ name

See Also

Controller..::..AxisSupervisor Class


resources Field

AxisSupervisor..::..resources Field

Once connection is open this structure contains the resources available on this machine from EtherCAT Master perspective.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Variant..::..VARIANT_PLC_RESOURCES resources
Public resources As Variant..::..VARIANT_PLC_RESOURCES
public:
Variant..::..VARIANT_PLC_RESOURCES^ resources

See Also

Controller..::..AxisSupervisor Class


userObject1 Field

AxisSupervisor..::..userObject1 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject1
Public userObject1 As Object
public:
Object^ userObject1

See Also

Controller..::..AxisSupervisor Class


userObject2 Field

AxisSupervisor..::..userObject2 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject2
Public userObject2 As Object
public:
Object^ userObject2

See Also

Controller..::..AxisSupervisor Class


Controller.AxisSupervisor Methods

Controller..::..AxisSupervisor Methods

The Controller..::..AxisSupervisor type exposes the following members.

Methods

 | Name | Description
Public method | closeConnection | This method closes a connection to the EtherCAT Master runtime.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getResources | Gets the resources of only this EtherCAT network. Use the PLCLogic for entire system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | openConnection | This method opens a connection to the EtherCAT Master runtime for motion control.
Public method | restartEtherCAT | Restart the EtherCAT network. MSB connections will be cleared so best to close axis connections prior to this call.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..AxisSupervisor Class


closeConnection Method

AxisSupervisor..::..closeConnection Method

This method closes a connection to the EtherCAT Master runtime.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool closeConnection()
Public Function closeConnection As Boolean
public:
bool^ closeConnection()

Return Value

true if successful, false if failed.

See Also

Controller..::..AxisSupervisor Class


getResources Method

AxisSupervisor..::..getResources Method

Gets the resources of only this EtherCAT network. Use the PLCLogic for entire system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getResources(
    ref Variant..::..VARIANT_PLC_RESOURCES blk
)
Public Function getResources ( _
    ByRef blk As Variant..::..VARIANT_PLC_RESOURCES _
) As Boolean
public:
bool^ getResources(
    Variant..::..VARIANT_PLC_RESOURCES^% blk
)

Parameters

blk
Type: CTC_Incentive..::..Variant..::..VARIANT_PLC_RESOURCES %
VARIANT_PLC_RESOURCES for reading resource information from the controller.

Return Value

true if successful, false otherwise.

See Also

Controller..::..AxisSupervisor Class


openConnection Method

AxisSupervisor..::..openConnection Method

This method opens a connection to the EtherCAT Master runtime for motion control.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool openConnection(
    string node,
    string our_mailbox_name
)
Public Function openConnection ( _
    node As String, _
    our_mailbox_name As String _
) As Boolean
public:
bool^ openConnection(
    String^ node,
    String^ our_mailbox_name
)

Parameters

node
Type: String
EtherCAT runtime name, typically CTECAT_1.
our_mailbox_name
Type: String
Base name of our queue, limited to 8 characters.

Return Value

true if successful, false if failed.

Exceptions

Exception | Condition
[INtimeException] |

See Also

Controller..::..AxisSupervisor Class


restartEtherCAT Method

AxisSupervisor..::..restartEtherCAT Method

Restart the EtherCAT network. MSB connections will be cleared so best to close axis connections prior to this call.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool restartEtherCAT(
    int timeout_ms
)
Public Function restartEtherCAT ( _
    timeout_ms As Integer _
) As Boolean
public:
bool^ restartEtherCAT(
    int^ timeout_ms
)

Parameters

timeout_ms
Type: Int32
Optional timeout in milliseconds, 0 or -1 defaults to 10,000, 1000 is min value.

Return Value

true if successful, false otherwise.

See Also

Controller..::..AxisSupervisor Class


Controller.AxisSupervisor Properties

Controller..::..AxisSupervisor Properties

The Controller..::..AxisSupervisor type exposes the following members.

Properties

 | Name | Description
Public property | scanning | scanning - Reflects the state of the EtherCAT Master scan engine, SCAN_STATES.OFFLINE not running, SCAN_STATES.INITIALIZING initializing, SCAN_STATES.RUNNING scanning. Read Only.

See Also

Controller..::..AxisSupervisor Class


scanning Property

AxisSupervisor..::..scanning Property

scanning - Reflects the state of the EtherCAT Master scan engine, SCAN_STATES.OFFLINE not running, SCAN_STATES.INITIALIZING initializing, SCAN_STATES.RUNNING scanning. Read Only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..AxisSupervisor..::..SCAN_STATES scanning { get; }
Public ReadOnly Property scanning As Controller..::..AxisSupervisor..::..SCAN_STATES
    Get
public:
property Controller..::..AxisSupervisor..::..SCAN_STATES^ scanning {
    Controller..::..AxisSupervisor..::..SCAN_STATES^ get ();
}

See Also

Controller..::..AxisSupervisor Class


AxisSupervisor.IncentiveAxisSupervisorException Class

AxisSupervisor..::..IncentiveAxisSupervisorException Class

Class IncentiveAxisSupervisorException, error handler. Throws enum Axis.MOTION_FAULTS.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class IncentiveAxisSupervisorException : ApplicationException
Public Class IncentiveAxisSupervisorException _
    Inherits ApplicationException
public ref class IncentiveAxisSupervisorException : public ApplicationException

Inheritance Hierarchy

Object
Exception
ApplicationException
CTC_Incentive..::..Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Members
CTC_Incentive Namespace
ApplicationException


AxisSupervisor.IncentiveAxisSupervisorException Members

AxisSupervisor..::..IncentiveAxisSupervisorException Members

The Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException()()()() | Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.
Public method | Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException(MOTION_FAULTS) | Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a MOTION_FAULTS error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


IncentiveAxisSupervisorException Constructor

Overload List

 | Name | Description
Public method | Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException()()()() | Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.
Public method | Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException(MOTION_FAULTS) | Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class
Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Members


IncentiveAxisSupervisorException Constructor

Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentiveAxisSupervisorException()
Public Sub New
public:
IncentiveAxisSupervisorException()

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class
Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Overload


IncentiveAxisSupervisorException Constructor (MOTION_FAULTS)

Initializes a new instance of the Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentiveAxisSupervisorException(
    MOTION_FAULTS error
)
Public Sub New ( _
    error As MOTION_FAULTS _
)
public:
IncentiveAxisSupervisorException(
    MOTION_FAULTS^ error
)

Parameters

error
Type: MOTION_FAULTS
MOTION_FAULTS error code.

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class
Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Overload


AxisSupervisor.IncentiveAxisSupervisorException Methods

AxisSupervisor..::..IncentiveAxisSupervisorException Methods

The Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


AxisSupervisor.IncentiveAxisSupervisorException Properties

AxisSupervisor..::..IncentiveAxisSupervisorException Properties

The Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a MOTION_FAULTS error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


ErrCode Property

IncentiveAxisSupervisorException..::..ErrCode Property

Gets a MOTION_FAULTS error code that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public MOTION_FAULTS ErrCode { get; }
Public ReadOnly Property ErrCode As MOTION_FAULTS
    Get
public:
property MOTION_FAULTS^ ErrCode {
    MOTION_FAULTS^ get ();
}

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


ErrMessage Property

IncentiveAxisSupervisorException..::..ErrMessage Property

Gets a message that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string ErrMessage { get; }
Public ReadOnly Property ErrMessage As String
    Get
public:
property String^ ErrMessage {
    String^ get ();
}

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


AxisSupervisor.IncentiveAxisSupervisorException Events

AxisSupervisor..::..IncentiveAxisSupervisorException Events

The Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..AxisSupervisor..::..IncentiveAxisSupervisorException Class


AxisSupervisor.SCAN_STATES Enumeration

AxisSupervisor..::..SCAN_STATES Enumeration

Enum SCAN_STATES, EtherCAT scanner states

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum SCAN_STATES
Public Enumeration SCAN_STATES
public enum class SCAN_STATES

Members

Member name | Description
OFFLINE | EtherCAT scan engine is offline, thread not running.
INITIALIZING | EtherCAT scan engine is initializing the system.
RUNNING | EtherCAT scan engine is fully operational, running.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


Controller.PLCLogic Class

Controller..::..PLCLogic Class

Class PLCLogic for access to QuickBuilder registers

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class PLCLogic
Public Class PLCLogic
public ref class PLCLogic

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..PLCLogic

See Also

Controller..::..PLCLogic Members


Controller.PLCLogic Members

Controller..::..PLCLogic Members

The Controller..::..PLCLogic type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..PLCLogic | Initializes a new instance of the Controller..::..PLCLogic class.

Methods

 | Name | Description
Public method | closeConnection | This method closes and open connection to the PLC runtime.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getRegister(Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Int32, Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Single%) | This method reads a float.
Public method | getRegister(Int32, Double%) | This method reads a double.
Public method | getRegister(Int32, Int32, Int32, Byte, Single%) | This method reads a float.
Public method | getRegister(Int32, Int32, Int32, Byte, Double%) | This method reads a double.
Public method | getRegister(Int32, String%) | This method reads a string.
Public method | getRegister(Int32, Int32, Int32, Byte, String%) | Gets the register.
Public method | getResources | Gets the resources.
Public method | getSymbol | Gets the symbol information from the Quickbuilder controller program.
Public method | getSymbolTableCount | Gets the QuickBuilder controller symbol table count.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getvector | Gets the requested vector or table block from the controller.
Public method | input | Read the IO input requested.
Public method | input16 | Read the 16 bit IO input block requested.
Public method | input32 | Read the 16 bit IO input block requested.
Public method | loadSymbols | Loads all the symbols from the currently active QuickBuilder program in the controller.
Public method | maxLimitforBlockType | Get maximum Variant Block Storage size available for transfer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | openConnection | This method opens a connection to the PLC runtime for register access.
Public method | output(Int32, Boolean) | Write the IO output requested.
Public method | output(Int32, Int16) | Write the IO output requested.
Public method | output(Int32, Int32) | Write the IO output requested.
Public method | putRegister(Int32, Int32) | This method writes an int.
Public method | putRegister(Int32, Single) | This method writes an float.
Public method | putRegister(Int32, Double) | This method writes an double.
Public method | putRegister(Int32, String) | This method writes an string.
Public method | restartController | Restart the Controller and EtherCAT program. This command will restart the QuickBuilder program, download new MSB's and restart the EtherCAT network. It will not effect our connections.
Public method | restartEtherCAT | Restart the EtherCAT network only. Useful for .Net only programs since QuickBuilder will not be reset, only MSB's if exist. It is not recommended to do this command with a QuickBuilder program running unless .Net program coordinates with it else the MSB's are reset without the main program knowing it.
Public method | shutdown_QuickBuilder | This method shuts down a QuickBuilder program and removes it from memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | connected | Flag to determine a connection was established to the PLC mailbox via the openConnection method, true, else false.
Public field | errorCode | Last error code returned.
Public field | errString | Last error string returned.
Public field | resources | Once connection is open this structure contains the resources available on this machine.
Public field | symbols | Controller symbols from any loaded QuickBuilder program available upon connection with the PLC.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

Properties

 | Name | Description
Public property | Controller_Timeout_ms | Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.

See Also

Controller..::..PLCLogic Class


PLCLogic Constructor

Initializes a new instance of the Controller..::..PLCLogic class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public PLCLogic()
Public Sub New
public:
PLCLogic()

See Also

Controller..::..PLCLogic Class


Controller.PLCLogic Fields

Controller..::..PLCLogic Fields

The Controller..::..PLCLogic type exposes the following members.

Fields

 | Name | Description
Public field | connected | Flag to determine a connection was established to the PLC mailbox via the openConnection method, true, else false.
Public field | errorCode | Last error code returned.
Public field | errString | Last error string returned.
Public field | resources | Once connection is open this structure contains the resources available on this machine.
Public field | symbols | Controller symbols from any loaded QuickBuilder program available upon connection with the PLC.
Public field | userObject1 | This is a user setable, typically used for threadID
Public field | userObject2 | This is a user setable, typically used for threadID

See Also

Controller..::..PLCLogic Class


connected Field

PLCLogic..::..connected Field

Flag to determine a connection was established to the PLC mailbox via the openConnection method, true, else false.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool connected
Public connected As Boolean
public:
bool^ connected

See Also

Controller..::..PLCLogic Class


errorCode Field

PLCLogic..::..errorCode Field

Last error code returned.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int errorCode
Public errorCode As Integer
public:
int^ errorCode

See Also

Controller..::..PLCLogic Class


errString Field

PLCLogic..::..errString Field

Last error string returned.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string errString
Public errString As String
public:
String^ errString

See Also

Controller..::..PLCLogic Class


resources Field

PLCLogic..::..resources Field

Once connection is open this structure contains the resources available on this machine.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Variant..::..VARIANT_PLC_RESOURCES resources
Public resources As Variant..::..VARIANT_PLC_RESOURCES
public:
Variant..::..VARIANT_PLC_RESOURCES^ resources

See Also

Controller..::..PLCLogic Class


symbols Field

PLCLogic..::..symbols Field

Controller symbols from any loaded QuickBuilder program available upon connection with the PLC.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public ArrayList symbols
Public symbols As ArrayList
public:
ArrayList^ symbols

See Also

Controller..::..PLCLogic Class


userObject1 Field

PLCLogic..::..userObject1 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject1
Public userObject1 As Object
public:
Object^ userObject1

See Also

Controller..::..PLCLogic Class


userObject2 Field

PLCLogic..::..userObject2 Field

This is a user setable, typically used for threadID

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object userObject2
Public userObject2 As Object
public:
Object^ userObject2

See Also

Controller..::..PLCLogic Class


Controller.PLCLogic Methods

Controller..::..PLCLogic Methods

The Controller..::..PLCLogic type exposes the following members.

Methods

 | Name | Description
Public method | closeConnection | This method closes and open connection to the PLC runtime.
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getRegister(Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Int32, Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Single%) | This method reads a float.
Public method | getRegister(Int32, Double%) | This method reads a double.
Public method | getRegister(Int32, Int32, Int32, Byte, Single%) | This method reads a float.
Public method | getRegister(Int32, Int32, Int32, Byte, Double%) | This method reads a double.
Public method | getRegister(Int32, String%) | This method reads a string.
Public method | getRegister(Int32, Int32, Int32, Byte, String%) | Gets the register.
Public method | getResources | Gets the resources.
Public method | getSymbol | Gets the symbol information from the Quickbuilder controller program.
Public method | getSymbolTableCount | Gets the QuickBuilder controller symbol table count.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | getvector | Gets the requested vector or table block from the controller.
Public method | input | Read the IO input requested.
Public method | input16 | Read the 16 bit IO input block requested.
Public method | input32 | Read the 16 bit IO input block requested.
Public method | loadSymbols | Loads all the symbols from the currently active QuickBuilder program in the controller.
Public method | maxLimitforBlockType | Get maximum Variant Block Storage size available for transfer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | openConnection | This method opens a connection to the PLC runtime for register access.
Public method | output(Int32, Boolean) | Write the IO output requested.
Public method | output(Int32, Int16) | Write the IO output requested.
Public method | output(Int32, Int32) | Write the IO output requested.
Public method | putRegister(Int32, Int32) | This method writes an int.
Public method | putRegister(Int32, Single) | This method writes an float.
Public method | putRegister(Int32, Double) | This method writes an double.
Public method | putRegister(Int32, String) | This method writes an string.
Public method | restartController | Restart the Controller and EtherCAT program. This command will restart the QuickBuilder program, download new MSB's and restart the EtherCAT network. It will not effect our connections.
Public method | restartEtherCAT | Restart the EtherCAT network only. Useful for .Net only programs since QuickBuilder will not be reset, only MSB's if exist. It is not recommended to do this command with a QuickBuilder program running unless .Net program coordinates with it else the MSB's are reset without the main program knowing it.
Public method | shutdown_QuickBuilder | This method shuts down a QuickBuilder program and removes it from memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..PLCLogic Class


closeConnection Method

PLCLogic..::..closeConnection Method

This method closes and open connection to the PLC runtime.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool closeConnection()
Public Function closeConnection As Boolean
public:
bool^ closeConnection()

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class


getRegister Method

PLCLogic..::..getRegister Method

Overload List

 | Name | Description
Public method | getRegister(Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Int32, Int32, Int32%) | This method reads an int.
Public method | getRegister(Int32, Single%) | This method reads a float.
Public method | getRegister(Int32, Double%) | This method reads a double.
Public method | getRegister(Int32, Int32, Int32, Byte, Single%) | This method reads a float.
Public method | getRegister(Int32, Int32, Int32, Byte, Double%) | This method reads a double.
Public method | getRegister(Int32, String%) | This method reads a string.
Public method | getRegister(Int32, Int32, Int32, Byte, String%) | Gets the register.

See Also

Controller..::..PLCLogic Class
Controller..::..PLCLogic Members


getRegister Method (Int32, Int32)

PLCLogic..::..getRegister Method (Int32, Int32%)

This method reads an int.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    ref int ivalue
)
Public Function getRegister ( _
    regnum As Integer, _
    ByRef ivalue As Integer _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    int^% ivalue
)

Parameters

regnum
Type: Int32
Register number to access.
ivalue
Type: Int32 %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Int32, Int32, Int32)

PLCLogic..::..getRegister Method (Int32, Int32, Int32, Int32%)

This method reads an int.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    int row,
    int col,
    ref int value
)
Public Function getRegister ( _
    regnum As Integer, _
    row As Integer, _
    col As Integer, _
    ByRef value As Integer _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    int^ row,
    int^ col,
    int^% value
)

Parameters

regnum
Type: Int32
Register number to access.
row
Type: Int32
Row, X value if array.
col
Type: Int32
Column, Y value if array.
value
Type: Int32 %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Single)

PLCLogic..::..getRegister Method (Int32, Single%)

This method reads a float.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    ref float value
)
Public Function getRegister ( _
    regnum As Integer, _
    ByRef value As Single _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    float^% value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: Single %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Double)

PLCLogic..::..getRegister Method (Int32, Double%)

This method reads a double.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    ref double value
)
Public Function getRegister ( _
    regnum As Integer, _
    ByRef value As Double _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    double^% value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: Double %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Int32, Int32, Byte, Single)

PLCLogic..::..getRegister Method (Int32, Int32, Int32, Byte, Single%)

This method reads a float.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    int row,
    int col,
    byte precision,
    ref float value
)
Public Function getRegister ( _
    regnum As Integer, _
    row As Integer, _
    col As Integer, _
    precision As Byte, _
    ByRef value As Single _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    int^ row,
    int^ col,
    unsigned char^ precision,
    float^% value
)

Parameters

regnum
Type: Int32
Register number to access.
row
Type: Int32
Row, X value if array.
col
Type: Int32
Column, Y value if array.
precision
Type: Byte
Number of decimal precision.
value
Type: Single %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Int32, Int32, Byte, Double)

PLCLogic..::..getRegister Method (Int32, Int32, Int32, Byte, Double%)

This method reads a double.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    int row,
    int col,
    byte precision,
    ref double value
)
Public Function getRegister ( _
    regnum As Integer, _
    row As Integer, _
    col As Integer, _
    precision As Byte, _
    ByRef value As Double _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    int^ row,
    int^ col,
    unsigned char^ precision,
    double^% value
)

Parameters

regnum
Type: Int32
Register number to access.
row
Type: Int32
Row, X value if array.
col
Type: Int32
Column, Y value if array.
precision
Type: Byte
Number of decimal precision.
value
Type: Double %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, String)

PLCLogic..::..getRegister Method (Int32, String%)

This method reads a string.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    ref string value
)
Public Function getRegister ( _
    regnum As Integer, _
    ByRef value As String _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    String^% value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: String %
Reference to where to store what read.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getRegister Method (Int32, Int32, Int32, Byte, String)

PLCLogic..::..getRegister Method (Int32, Int32, Int32, Byte, String%)

Gets the register.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getRegister(
    int regnum,
    int row,
    int col,
    byte precision,
    ref string value
)
Public Function getRegister ( _
    regnum As Integer, _
    row As Integer, _
    col As Integer, _
    precision As Byte, _
    ByRef value As String _
) As Boolean
public:
bool^ getRegister(
    int^ regnum,
    int^ row,
    int^ col,
    unsigned char^ precision,
    String^% value
)

Parameters

regnum
Type: Int32
The regnum.
row
Type: Int32
The row.
col
Type: Int32
The col.
precision
Type: Byte
The precision.
value
Type: String %
The value.

Return Value

true if XXXX, false otherwise.

See Also

Controller..::..PLCLogic Class
getRegister Overload


getResources Method

PLCLogic..::..getResources Method

Gets the resources.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool getResources(
    ref Variant..::..VARIANT_PLC_RESOURCES blk
)
Public Function getResources ( _
    ByRef blk As Variant..::..VARIANT_PLC_RESOURCES _
) As Boolean
public:
bool^ getResources(
    Variant..::..VARIANT_PLC_RESOURCES^% blk
)

Parameters

blk
Type: CTC_Incentive..::..Variant..::..VARIANT_PLC_RESOURCES %
VARIANT_PLC_RESOURCES for reading resource information from the controller.

Return Value

true if successful, false otherwise.

See Also

Controller..::..PLCLogic Class


getSymbol Method

PLCLogic..::..getSymbol Method

Gets the symbol information from the Quickbuilder controller program.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..Symbol getSymbol(
    int n
)
Public Function getSymbol ( _
    n As Integer _
) As Controller..::..Symbol
public:
Controller..::..Symbol^ getSymbol(
    int^ n
)

Parameters

n
Type: Int32
Index of symbol desired as stored in the controller.

Return Value

Symbol.

See Also

Controller..::..PLCLogic Class


getSymbolTableCount Method

PLCLogic..::..getSymbolTableCount Method

Gets the QuickBuilder controller symbol table count.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int getSymbolTableCount()
Public Function getSymbolTableCount As Integer
public:
int^ getSymbolTableCount()

Return Value

System.Int32, -1 means no table loaded.

See Also

Controller..::..PLCLogic Class


getvector Method

PLCLogic..::..getvector Method

Gets the requested vector or table block from the controller.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Object[] getvector(
    int _reg,
    int type,
    int x,
    int y,
    int xinc,
    int yinc,
    int n
)
Public Function getvector ( _
    _reg As Integer, _
    type As Integer, _
    x As Integer, _
    y As Integer, _
    xinc As Integer, _
    yinc As Integer, _
    n As Integer _
) As Object()
public:
array<Object^>^ getvector(
    int^ _reg,
    int^ type,
    int^ x,
    int^ y,
    int^ xinc,
    int^ yinc,
    int^ n
)

Parameters

_reg
Type: Int32
The Variant register desired.
type
Type: Int32
The type of data desired, variant.
x
Type: Int32
Row of Variant table.
y
Type: Int32
Column of Variant table.
xinc
Type: Int32
How much to increment the row each time if multiple transfer.
yinc
Type: Int32
How much to increment the column each time if multiple transfer.
n
Type: Int32
The number of items to transfer.

Return Value

System.Object[].

See Also

Controller..::..PLCLogic Class


input Method

PLCLogic..::..input Method

Read the IO input requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool input(
    int number
)
Public Function input ( _
    number As Integer _
) As Boolean
public:
bool^ input(
    int^ number
)

Parameters

number
Type: Int32
Input number desired, 1 to N.

Return Value

True if set, false if not.

See Also

Controller..::..PLCLogic Class


input16 Method

PLCLogic..::..input16 Method

Read the 16 bit IO input block requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int input16(
    int number
)
Public Function input16 ( _
    number As Integer _
) As Integer
public:
int^ input16(
    int^ number
)

Parameters

number
Type: Int32
16 bit input number block desired, 1 to N.

Return Value

True if set, false if not.

See Also

Controller..::..PLCLogic Class


input32 Method

PLCLogic..::..input32 Method

Read the 16 bit IO input block requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int input32(
    int number
)
Public Function input32 ( _
    number As Integer _
) As Integer
public:
int^ input32(
    int^ number
)

Parameters

number
Type: Int32
16 bit input number block desired, 1 to N.

Return Value

True if set, false if not.

See Also

Controller..::..PLCLogic Class


loadSymbols Method

PLCLogic..::..loadSymbols Method

Loads all the symbols from the currently active QuickBuilder program in the controller.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int loadSymbols()
Public Function loadSymbols As Integer
public:
int^ loadSymbols()

Return Value

System.Int32, less than 0 if error, else number of symbols found.

See Also

Controller..::..PLCLogic Class


maxLimitforBlockType Method

PLCLogic..::..maxLimitforBlockType Method

Get maximum Variant Block Storage size available for transfer.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int maxLimitforBlockType(
    int type
)
Public Function maxLimitforBlockType ( _
    type As Integer _
) As Integer
public:
int^ maxLimitforBlockType(
    int^ type
)

Parameters

type
Type: Int32
Type of Variant.

Return Value

int, storage size.

See Also

Controller..::..PLCLogic Class


openConnection Method

PLCLogic..::..openConnection Method

This method opens a connection to the PLC runtime for register access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool openConnection(
    string node,
    string our_mailbox_name,
    bool get_resources,
    bool get_symbols
)
Public Function openConnection ( _
    node As String, _
    our_mailbox_name As String, _
    get_resources As Boolean, _
    get_symbols As Boolean _
) As Boolean
public:
bool^ openConnection(
    String^ node,
    String^ our_mailbox_name,
    bool^ get_resources,
    bool^ get_symbols
)

Parameters

node
Type: String
PLC runtime name, typically CTPLC_1.
our_mailbox_name
Type: String
Base name of our queue, limited to 8 characters.
get_resources
Type: Boolean
True if want controller resources loaded immediately after connection.
get_symbols
Type: Boolean
True to request controller symbols be loaded immediately after connection.

Return Value

True if successful, false if failed.

Exceptions

Exception | Condition
[INtimeException] |

See Also

Controller..::..PLCLogic Class


output Method

PLCLogic..::..output Method

Overload List

 | Name | Description
Public method | output(Int32, Boolean) | Write the IO output requested.
Public method | output(Int32, Int16) | Write the IO output requested.
Public method | output(Int32, Int32) | Write the IO output requested.

See Also

Controller..::..PLCLogic Class
Controller..::..PLCLogic Members


output Method (Int32, Boolean)

PLCLogic..::..output Method (Int32, Boolean)

Write the IO output requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool output(
    int number,
    bool state
)
Public Function output ( _
    number As Integer, _
    state As Boolean _
) As Boolean
public:
bool^ output(
    int^ number,
    bool^ state
)

Parameters

number
Type: Int32
Output number desired, 1 to N.
state
Type: Boolean
True to set, false to clear.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
output Overload


output Method (Int32, Int16)

PLCLogic..::..output Method (Int32, Int16)

Write the IO output requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool output(
    int number,
    short value
)
Public Function output ( _
    number As Integer, _
    value As Short _
) As Boolean
public:
bool^ output(
    int^ number,
    short^ value
)

Parameters

number
Type: Int32
16 bit output block number desired, 1 to N.
value
Type: Int16
16 bit value to set on output block number.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
output Overload


output Method (Int32, Int32)

PLCLogic..::..output Method (Int32, Int32)

Write the IO output requested.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool output(
    int number,
    int value
)
Public Function output ( _
    number As Integer, _
    value As Integer _
) As Boolean
public:
bool^ output(
    int^ number,
    int^ value
)

Parameters

number
Type: Int32
32 bit output block number desired, 1 to N.
value
Type: Int32
32 bit value to set on output block number.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
output Overload


putRegister Method

PLCLogic..::..putRegister Method

Overload List

 | Name | Description
Public method | putRegister(Int32, Int32) | This method writes an int.
Public method | putRegister(Int32, Single) | This method writes an float.
Public method | putRegister(Int32, Double) | This method writes an double.
Public method | putRegister(Int32, String) | This method writes an string.

See Also

Controller..::..PLCLogic Class
Controller..::..PLCLogic Members


putRegister Method (Int32, Int32)

PLCLogic..::..putRegister Method (Int32, Int32)

This method writes an int.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool putRegister(
    int regnum,
    int value
)
Public Function putRegister ( _
    regnum As Integer, _
    value As Integer _
) As Boolean
public:
bool^ putRegister(
    int^ regnum,
    int^ value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: Int32
Value to write.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
putRegister Overload


putRegister Method (Int32, Single)

PLCLogic..::..putRegister Method (Int32, Single)

This method writes an float.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool putRegister(
    int regnum,
    float value
)
Public Function putRegister ( _
    regnum As Integer, _
    value As Single _
) As Boolean
public:
bool^ putRegister(
    int^ regnum,
    float^ value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: Single
Value to write.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
putRegister Overload


putRegister Method (Int32, Double)

PLCLogic..::..putRegister Method (Int32, Double)

This method writes an double.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool putRegister(
    int regnum,
    double value
)
Public Function putRegister ( _
    regnum As Integer, _
    value As Double _
) As Boolean
public:
bool^ putRegister(
    int^ regnum,
    double^ value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: Double
Value to write.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
putRegister Overload


putRegister Method (Int32, String)

PLCLogic..::..putRegister Method (Int32, String)

This method writes an string.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool putRegister(
    int regnum,
    string value
)
Public Function putRegister ( _
    regnum As Integer, _
    value As String _
) As Boolean
public:
bool^ putRegister(
    int^ regnum,
    String^ value
)

Parameters

regnum
Type: Int32
Register number to access.
value
Type: String
Value to write.

Return Value

True if successful, false if failed.

See Also

Controller..::..PLCLogic Class
putRegister Overload


restartController Method

PLCLogic..::..restartController Method

Restart the Controller and EtherCAT program. This command will restart the QuickBuilder program, download new MSB's and restart the EtherCAT network. It will not effect our connections.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool restartController(
    int timeout_ms
)
Public Function restartController ( _
    timeout_ms As Integer _
) As Boolean
public:
bool^ restartController(
    int^ timeout_ms
)

Parameters

timeout_ms
Type: Int32
Optional timeout in milliseconds, 0 or -1 defaults to 10,000, 1000 is min value.

Return Value

true if succesful, false otherwise.

See Also

Controller..::..PLCLogic Class


restartEtherCAT Method

PLCLogic..::..restartEtherCAT Method

Restart the EtherCAT network only. Useful for .Net only programs since QuickBuilder will not be reset, only MSB's if exist. It is not recommended to do this command with a QuickBuilder program running unless .Net program coordinates with it else the MSB's are reset without the main program knowing it.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool restartEtherCAT(
    int timeout_ms
)
Public Function restartEtherCAT ( _
    timeout_ms As Integer _
) As Boolean
public:
bool^ restartEtherCAT(
    int^ timeout_ms
)

Parameters

timeout_ms
Type: Int32
Optional timeout in milliseconds, 0 or -1 defaults to 10,000, 1000 is min value.

Return Value

true if successful, false otherwise.

See Also

Controller..::..PLCLogic Class


shutdown_QuickBuilder Method

PLCLogic..::..shutdown_QuickBuilder Method

This method shuts down a QuickBuilder program and removes it from memory.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool shutdown_QuickBuilder(
    int max_timeout,
    bool doEvents
)
Public Function shutdown_QuickBuilder ( _
    max_timeout As Integer, _
    doEvents As Boolean _
) As Boolean
public:
bool^ shutdown_QuickBuilder(
    int^ max_timeout,
    bool^ doEvents
)

Parameters

max_timeout
Type: Int32
The maximum timeout, typically 10000 milliseconds.
doEvents
Type: Boolean
if set to true [doEvents for UI].

Return Value

True if successful, false if times out (10 seconds).

See Also

Controller..::..PLCLogic Class


Controller.PLCLogic Properties

Controller..::..PLCLogic Properties

The Controller..::..PLCLogic type exposes the following members.

Properties

 | Name | Description
Public property | Controller_Timeout_ms | Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.

See Also

Controller..::..PLCLogic Class


Controller_Timeout_ms Property

PLCLogic..::..Controller_Timeout_ms Property

Gets or sets the motion variable property timeout, in milliseconds, for waiting for responses from the EtherCAT process, default is 1 second.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int Controller_Timeout_ms { get; set; }
Public Property Controller_Timeout_ms As Integer
    Get
    Set
public:
property int^ Controller_Timeout_ms {
    int^ get ();
    void set (int^ value);
}

See Also

Controller..::..PLCLogic Class


PLCLogic.IncentivePLCException Class

PLCLogic..::..IncentivePLCException Class

Class IncentivePLCException. Throws enum PLC_FAULTS.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class IncentivePLCException : ApplicationException
Public Class IncentivePLCException _
    Inherits ApplicationException
public ref class IncentivePLCException : public ApplicationException

Inheritance Hierarchy

Object
Exception
ApplicationException
CTC_Incentive..::..Controller..::..PLCLogic..::..IncentivePLCException

See Also

Controller..::..PLCLogic..::..IncentivePLCException Members
CTC_Incentive Namespace
ApplicationException


PLCLogic.IncentivePLCException Members

PLCLogic..::..IncentivePLCException Members

The Controller..::..PLCLogic..::..IncentivePLCException type exposes the following members.

Constructors

 | Name | Description
Public method | Controller..::..PLCLogic..::..IncentivePLCException()()()() | Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.
Public method | Controller..::..PLCLogic..::..IncentivePLCException(Controller..::..PLCLogic..::..PLC_RETVAL) | Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a PLC_RETVAL error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


IncentivePLCException Constructor

Overload List

 | Name | Description
Public method | Controller..::..PLCLogic..::..IncentivePLCException()()()() | Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.
Public method | Controller..::..PLCLogic..::..IncentivePLCException(Controller..::..PLCLogic..::..PLC_RETVAL) | Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class
Controller..::..PLCLogic..::..IncentivePLCException Members


IncentivePLCException Constructor

Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentivePLCException()
Public Sub New
public:
IncentivePLCException()

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class
Controller..::..PLCLogic..::..IncentivePLCException Overload


IncentivePLCException Constructor (PLC_RETVAL)

Initializes a new instance of the Controller..::..PLCLogic..::..IncentivePLCException class.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public IncentivePLCException(
    Controller..::..PLCLogic..::..PLC_RETVAL error
)
Public Sub New ( _
    error As Controller..::..PLCLogic..::..PLC_RETVAL _
)
public:
IncentivePLCException(
    Controller..::..PLCLogic..::..PLC_RETVAL^ error
)

Parameters

error
Type: CTC_Incentive..::..Controller..::..PLCLogic..::..PLC_RETVAL
PLC_FAULTS error code.

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class
Controller..::..PLCLogic..::..IncentivePLCException Overload


PLCLogic.IncentivePLCException Methods

PLCLogic..::..IncentivePLCException Methods

The Controller..::..PLCLogic..::..IncentivePLCException type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


PLCLogic.IncentivePLCException Properties

PLCLogic..::..IncentivePLCException Properties

The Controller..::..PLCLogic..::..IncentivePLCException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrCode | Gets a PLC_RETVAL error code that describes the current exception.
Public property | ErrMessage | Gets a message that describes the current exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


ErrCode Property

IncentivePLCException..::..ErrCode Property

Gets a PLC_RETVAL error code that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public Controller..::..PLCLogic..::..PLC_RETVAL ErrCode { get; }
Public ReadOnly Property ErrCode As Controller..::..PLCLogic..::..PLC_RETVAL
    Get
public:
property Controller..::..PLCLogic..::..PLC_RETVAL^ ErrCode {
    Controller..::..PLCLogic..::..PLC_RETVAL^ get ();
}

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


ErrMessage Property

IncentivePLCException..::..ErrMessage Property

Gets a message that describes the current exception.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string ErrMessage { get; }
Public ReadOnly Property ErrMessage As String
    Get
public:
property String^ ErrMessage {
    String^ get ();
}

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


PLCLogic.IncentivePLCException Events

PLCLogic..::..IncentivePLCException Events

The Controller..::..PLCLogic..::..IncentivePLCException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Controller..::..PLCLogic..::..IncentivePLCException Class


PLCLogic.PLC_CONNECT_MODES Enumeration

PLCLogic..::..PLC_CONNECT_MODES Enumeration

enum PLC_CONNECT_MODES, Defines what to do after successful connection to PLC Logic. Optionally stop QuickBuilder program and restart EtherCAT Network.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum PLC_CONNECT_MODES
Public Enumeration PLC_CONNECT_MODES
public enum class PLC_CONNECT_MODES

Members

Member name | Description
CONNECT_ONLY | Connect only.
CONNECT_STOPQB | Connect and ensure QuickBuilder is stopped.
CONNECT_STOPQB_RESTARTECAT | Connect, stop QuickBuilder and then restart the EtherCAT network.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


PLCLogic.PLC_RETVAL Enumeration

PLCLogic..::..PLC_RETVAL Enumeration

Enum MOTION_FAULTS, Errors returned by axis functions.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum PLC_RETVAL
Public Enumeration PLC_RETVAL
public enum class PLC_RETVAL

Members

Member name | Description
SUCCESS | No Error, success.
ERROR_ILLEGAL_INST | Illegal instruction opcode.
ERROR_CORRUPT | Corrupt program data.
ERROR_NO_STEP | Destination step doesnt exist.
ERROR_BAD_THUMB | Not used.
ERROR_NO_STEP_1 | Step#1 doesnt exist.
ERROR_MAX_TASKS | Too many tasks.
ERROR_NO_STEPPER | No such stepping motor #.
ERROR_STEPPER_NOT_READY | Stepping motor not ready.
ERROR_NOT_PROF | Stepping motor not profiled.
ERROR_NO_SERVO | No such servo #.
ERROR_SERVO_NOT_READY | Servo not ready.
ERROR_SERVO | Servo error.
ERROR_NO_REG | No such register exists.
ERROR_NO_COL | No such data table col.
ERROR_NO_ROW | No such data table row.
ERROR_NO_PROTO | Not used.
ERROR_SAMPLE_T | Illegal sample time.
ERROR_NO_AIN | No such analog input # .
ERROR_NO_AOUT | No such analog output #.
ERROR_NO_DISP | No such display #.
ERROR_DIG_INP | No such digital input #.
ERROR_DIG_OUT | No such digital output #.
ERROR_NO_THUMB | Not used.
ERROR_ILLEGAL_VAL | Illegal (data table) value.
ERROR_XMIT | Transmitter busy.
ERROR_DIV_ZERO | Divide-by-zero error.
ERROR_OO_RANGE | Generic data-out-of range.
ERROR_HARDWARE | Hardware fault.
ERROR_NET_ACCESS | Network access problem.
ERROR_NET_TIMEOUT | Network access timeout.
ERROR_NET_BUSY | Network access busy.
ERROR_NET_RQST_LOST | Network request lost.
ERROR_NET_BAD_RESPONSE | Network bad response.
ERROR_NET_BAD_MSG | Network bad return message.
ERROR_NO_COMM_PORT | No such communications port.
ERROR_COMM_PROTOCOL | Error in request/reply handshake.
ERROR_NO_FLAG | Bad flag number selected.
ERROR_NO_DELAYTIMER | Bad delaytimer selected.
ERROR_OUT_OF_SOFTCNTRS | Out-of-softcounters.
ERROR_AIN_SCALING | Error in fetching or calculating analog scaling.
ERROR_NOT_CALIBRATED | Device not calibrated, analog?
ERROR_ATMEL_ISP | 5300 only, not used.
ERROR_FILE_OPEN | Error trying to open file requested, not exist?.
ERROR_FILE_FGETS | fgets returned null pointer, not found .
ERROR_MALLOC | Memory malloc failed.
ERROR_ANALOG_NOT_READY | Analog module not responding.
ERROR_AOUT_SCALING | Error in fetching or calculating analog scaling.
ERROR_INVALID_PCA | 5300 only, not used.
ERROR_VIRTUALIO_CONNECTION | Lost connection with Virtual Controller.
ERROR_TASK | Task error.
ERROR_TASK_STATUS | Task status error.
ERROR_DELAY_REJECTED | Time delay not accepted not necessarily an error .
ERROR_IOACCESS | IError Accessing Hardware I/O.
ERROR_IODRIVER | Generic Error in IODRIVER.
INVALID_PARAMETER | Invalid parameter was passed.
ERROR_EXT_DATA_DESC | Invalid extended data descriptor.
ERROR_SPI_OVERRUN | SPI data overrun.
ERROR_SPI_TIMEOUT | SPI device timed out.
ALTERNATE_ERROR_ILLEGAL_INST | Use this instead of 1 since success can be 1 or 0 depending where used.
ERROR_FTP_DISCONNECT | Attempted to connect on something already connected.
ERROR_FTP_CONNECT | Attempted FTP Client operation but not connected.
ERROR_FTP_COMMAND | General FTP command failed.
ERROR_LOST_EXPANSION | Lost Expansion during operation.
ERROR_NOT_SET | Used for dual port to set error to not defined yet.
ERROR_IO_DUALPORT_UNDEFINED | Dualport device on IO bus ID seen but cpu not running...
ERROR_NOT_DEFINED | Virtual table function call not defined.
END_OF_STEP | "End of Step" was found, not an error..
END_ALL_TASKS | Last task has successfully completed..
ERROR_NO_COUNTER | No counters available?
ERROR_NO_PWM | No PWM available?
ERROR_DUALPORT_TIMEOUT | Dualport memory timeout.
ERROR_CORRUPT_QUICKSTEP | Quickstep memory corrupted.
ERROR_MESSAGE_RESULT | Message result length != 4? Possible bytes left in mailbox from old message...
ERROR_NTX_TYPE_RT_PROCESS | Attempted to attached to a process other than real time?
ERROR_PLCQueAPI | The PLC mailbox is missing? Possibly not running.
ERROR_PLCQue_RESPONSE | The PLC response mailbox is missing? Possibly invalid name or duplicate?
ERROR_PLCQue_REQUEST | The PLC request mailbox is missing? Possibly invalid name or duplicate?
ERROR_NAME_TO_LONG | The PLC request mailbox name is too long? Limit is 8 characters.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


PLCLogic.PLC_STATES Enumeration

PLCLogic..::..PLC_STATES Enumeration

enum PLC_STATES, PLC controller states, register 13054.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum PLC_STATES
Public Enumeration PLC_STATES
public enum class PLC_STATES

Members

Member name | Description
RESET | Reset the controller and begin running the Quickstep or QuickBuilder again from start.
AT_RESET | Controller is at Reset.
RESTART | Reset the controller and begin running the Quickstep or QuickBuilder again from start. Clears a fault.
STOPPED | Stop the controller but do not reset, used to clear a FAULT before restarting. State will change to FAULT_STOPPED.
PROGRAMMING | Read: Program is loading...
RUNNING | Write: Ignore the fault and continue running. Read: Program is running.
FAULT | Write: Continue to fault as usual. Read: Faulting.
FAULT_STOPPED | Read: System stopped after fault encountered.
SHUTDOWN | Reset the controller and shutdown, requires a power cycle to exit and continue.
WARM_RESTART | Warm restart, restart only, do not reload the program.
RESET_STOP | Reset the controller and stop the program... Will enter STOPPED state when done...

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


PLCLogic.REGISTERS Enumeration

PLCLogic..::..REGISTERS Enumeration

enum REGISTERS, some popular registers, reference the 5300 Quick Reference guide to additional details.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public enum REGISTERS
Public Enumeration REGISTERS
public enum class REGISTERS

Members

Member name | Description
VOLATILE_START | Volatile integer memory start.
VOLATILE_END | Volatile integer memory end.
NON_VOLATILE_START | Non-Volatile extended integer memory start.
NON_VOLATILE_END | Non-Volatile integer memory end.
NON_VOLATILE_EXT_START | Non-Volatile extended integer memory start.
NON_VOLATILE_EXT_END | Non-Volatile extended integer memory end.
VOLATILE_VARIANT_START | Volatile memory varient start.
VOLATILE_VARIANT_END | Volatile memory varient end.
NON_VOLATILE_VARIENT_START | Non-Volatile memory varient start.
NON_VOLATILE_VARIENT_END | Non-Volatile memory varient end.
PROGRAM_EXECUTION_STATE | PLC logic Quickbuilder program execution state.
MASTER_BOARD_SELECT | EtherCAT board/process select, 1 for first, 2 for second.
MILLISECOND_COUNTER | PLC logic millisecond tick.
MASTER_BOARD_ONLINE_STATUS | Online status of EtherCAT board selected
DIGITAL_IN_BITS_START | Digital input bits start.
DIGITAL_IN_BYTES_START | Digital input 8 bit start.
DIGITAL_IN_SHORT_START | Digital input 16 bit start.
DIGITAL_IN_INT_START | Digital input 32 bit integer start.
DIGITAL_OUT_BITS_START | Digital output bits start.
DIGITAL_OUT_BYTES_START | Digital output 8 bit start.
DIGITAL_OUT_SHORT_START | Digital output 16 bit short start.
DIGITAL_OUT_INT_START | Digital output 32 bit integer start.
FLAG_INT | General Flag 32 bit integer.
FLAG_BYTE_EXT_START | Extended flag byte start.
FLAG_BYTE_EXT_END | Extended flag byte end.
FLAG_BIT_EXT_START | Extended flag bit start.
FLAG_BIT_EXT_END | Extended flag bit end.
ANALOG_OUT_START | Analog output start.
ANALOG_OUT_END | Analog output end.
ANALOG_IN_START | Analog input start.
ANALOG_IN_END | Analog input end.

See Also

CTC_Incentive Namespace
(C) 2016 Control Technolgy Corporation All Rights Reserved
Help File generated with GhostDoc


PLCLogic.SimpleStringComparer Class

PLCLogic..::..SimpleStringComparer Class

Class SimpleStringComparer, used as Binary Search comparison for controller symbols.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class SimpleStringComparer : IComparer
Public Class SimpleStringComparer _
    Implements IComparer
public ref class SimpleStringComparer : IComparer

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..PLCLogic..::..SimpleStringComparer

See Also

Controller..::..PLCLogic..::..SimpleStringComparer Members
CTC_Incentive Namespace
IComparer


PLCLogic.SimpleStringComparer Members

PLCLogic..::..SimpleStringComparer Members

The Controller..::..PLCLogic..::..SimpleStringComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..PLCLogic..::..SimpleStringComparer Class


PLCLogic.SimpleStringComparer Methods

PLCLogic..::..SimpleStringComparer Methods

The Controller..::..PLCLogic..::..SimpleStringComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Controller..::..PLCLogic..::..SimpleStringComparer Class


Controller.Symbol Class

Controller..::..Symbol Class

QuickBuilder Symbol structure stored within a running program.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class Symbol
Public Class Symbol
public ref class Symbol

Inheritance Hierarchy

Object
CTC_Incentive..::..Controller..::..Symbol

See Also

Controller..::..Symbol Members


Controller.Symbol Members

Controller..::..Symbol Members

The Controller..::..Symbol type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns string name.

Fields

 | Name | Description
Public field | Name | Name of symbol as used in QuickBuilder. If MSB symbol then has axisname.symbolname as string name.
Public field | PropertyNumber | Property or register number to access this by.
Public field | RegisterOrObjectNumber | If axis then this is the axis #, else register #.
Public field | SymbolType | Type of symbol this is, Variant type as well as axis BIT13 or plc BIT14.

Properties

 | Name | Description
Public property | IsAxisRegister | Returns true if symbol type is a Axis user variable.
Public property | IsRegister | Returns true if symbol type is a PLC register.
Public property | IsString | Returns true if symbol type is a string.
Public property | VariantType | Returns Variant Type of the symbol, masking off the Axis/PLC information.

See Also

Controller..::..Symbol Class


Controller.Symbol Fields

Controller..::..Symbol Fields

The Controller..::..Symbol type exposes the following members.

Fields

 | Name | Description
Public field | Name | Name of symbol as used in QuickBuilder. If MSB symbol then has axisname.symbolname as string name.
Public field | PropertyNumber | Property or register number to access this by.
Public field | RegisterOrObjectNumber | If axis then this is the axis #, else register #.
Public field | SymbolType | Type of symbol this is, Variant type as well as axis BIT13 or plc BIT14.

See Also

Controller..::..Symbol Class


Name Field

Symbol..::..Name Field

Name of symbol as used in QuickBuilder. If MSB symbol then has axisname.symbolname as string name.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

Controller..::..Symbol Class


PropertyNumber Field

Symbol..::..PropertyNumber Field

Property or register number to access this by.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int PropertyNumber
Public PropertyNumber As Integer
public:
int^ PropertyNumber

See Also

Controller..::..Symbol Class


RegisterOrObjectNumber Field

Symbol..::..RegisterOrObjectNumber Field

If axis then this is the axis #, else register #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int RegisterOrObjectNumber
Public RegisterOrObjectNumber As Integer
public:
int^ RegisterOrObjectNumber

See Also

Controller..::..Symbol Class


SymbolType Field

Symbol..::..SymbolType Field

Type of symbol this is, Variant type as well as axis BIT13 or plc BIT14.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int SymbolType
Public SymbolType As Integer
public:
int^ SymbolType

See Also

Controller..::..Symbol Class


Controller.Symbol Methods

Controller..::..Symbol Methods

The Controller..::..Symbol type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns string name.

See Also

Controller..::..Symbol Class


ToString Method

Symbol..::..ToString Method

Returns string name.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

See Also

Controller..::..Symbol Class


Controller.Symbol Properties

Controller..::..Symbol Properties

The Controller..::..Symbol type exposes the following members.

Properties

 | Name | Description
Public property | IsAxisRegister | Returns true if symbol type is a Axis user variable.
Public property | IsRegister | Returns true if symbol type is a PLC register.
Public property | IsString | Returns true if symbol type is a string.
Public property | VariantType | Returns Variant Type of the symbol, masking off the Axis/PLC information.

See Also

Controller..::..Symbol Class


IsAxisRegister Property

Symbol..::..IsAxisRegister Property

Returns true if symbol type is a Axis user variable.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool IsAxisRegister { get; }
Public ReadOnly Property IsAxisRegister As Boolean
    Get
public:
property bool^ IsAxisRegister {
    bool^ get ();
}

See Also

Controller..::..Symbol Class


IsRegister Property

Symbol..::..IsRegister Property

Returns true if symbol type is a PLC register.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool IsRegister { get; }
Public ReadOnly Property IsRegister As Boolean
    Get
public:
property bool^ IsRegister {
    bool^ get ();
}

See Also

Controller..::..Symbol Class


IsString Property

Symbol..::..IsString Property

Returns true if symbol type is a string.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public bool IsString { get; }
Public ReadOnly Property IsString As Boolean
    Get
public:
property bool^ IsString {
    bool^ get ();
}

See Also

Controller..::..Symbol Class


VariantType Property

Symbol..::..VariantType Property

Returns Variant Type of the symbol, masking off the Axis/PLC information.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public int VariantType { get; }
Public ReadOnly Property VariantType As Integer
    Get
public:
property int^ VariantType {
    int^ get ();
}

See Also

Controller..::..Symbol Class


Variant Class

Class Variant, define the different data types and limitations.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public class Variant
Public Class Variant
public ref class Variant

Inheritance Hierarchy

Object
CTC_Incentive..::..Variant

See Also

Variant Members


Variant Members

The Variant type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ISAXISREG | Symbol flag for axis register
ISREGISTER | Symbol flag for plc register
MAX_VARIANT_BLOCK_32BITS | Maximum number of integers that can be transfered in VARIANT_STORAGE_BLOCK structure.
MAX_VARIANT_BLOCK_64BITS | Maximum number of doubles and int64's that can be transfered in VARIANT_STORAGE_BLOCK structure.
MAX_VARIANT_BLOCK_8BITS | Maximum number of bytes that can be transfered in VARIANT_STORAGE_BLOCK structure.
QS4_OBJECT_GET_SYMBOL | Row index used when referencing SPECIAL_QS4_OBJECT_REGISTER to retrieve symbol information at the specified offset in controller table.
QS4_OBJECT_NSYMBOLS | Row index used when refererencing SPECIAL_QS4_OBJECT_REGISTER to get the number of symbols available in QB program
SPECIAL_QS4_OBJECT_REGISTER | Register for special QB object information access
VARIANT_ANY | Request type based upon what last written.
VARIANT_BYTE | Request byte type within VARIANT_STORAGE
VARIANT_DOUBLE | Request double type within VARIANT_STORAGE
VARIANT_FLOAT | Request 32 bit float type within VARIANT_STORAGE
VARIANT_INTEGER | Request integer type within VARIANT_STORAGE
VARIANT_LLONGINTEGER | Request 64 bit long type within VARIANT_STORAGE
VARIANT_MAX_STRING | Maximum string length allowed in a variant, typically 223 bytes.
VARIANT_STRING | Request string type within VARIANT_STORAGE
VARIANT_UINTEGER | Request unsigned integer type within VARIANT_STORAGE

See Also

Variant Class


Variant Fields

The Variant type exposes the following members.

Fields

Name | Description
ISAXISREG | Symbol flag for axis register
ISREGISTER | Symbol flag for plc register
MAX_VARIANT_BLOCK_32BITS | Maximum number of integers that can be transfered in VARIANT_STORAGE_BLOCK structure.
MAX_VARIANT_BLOCK_64BITS | Maximum number of doubles and int64's that can be transfered in VARIANT_STORAGE_BLOCK structure.
MAX_VARIANT_BLOCK_8BITS | Maximum number of bytes that can be transfered in VARIANT_STORAGE_BLOCK structure.
QS4_OBJECT_GET_SYMBOL | Row index used when referencing SPECIAL_QS4_OBJECT_REGISTER to retrieve symbol information at the specified offset in controller table.
QS4_OBJECT_NSYMBOLS | Row index used when refererencing SPECIAL_QS4_OBJECT_REGISTER to get the number of symbols available in QB program
SPECIAL_QS4_OBJECT_REGISTER | Register for special QB object information access
VARIANT_ANY | Request type based upon what last written.
VARIANT_BYTE | Request byte type within VARIANT_STORAGE
VARIANT_DOUBLE | Request double type within VARIANT_STORAGE
VARIANT_FLOAT | Request 32 bit float type within VARIANT_STORAGE
VARIANT_INTEGER | Request integer type within VARIANT_STORAGE
VARIANT_LLONGINTEGER | Request 64 bit long type within VARIANT_STORAGE
VARIANT_MAX_STRING | Maximum string length allowed in a variant, typically 223 bytes.
VARIANT_STRING | Request string type within VARIANT_STORAGE
VARIANT_UINTEGER | Request unsigned integer type within VARIANT_STORAGE

See Also

Variant Class


ISAXISREG Field

Variant..::..ISAXISREG Field

Symbol flag for axis register

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int ISAXISREG
Public Const ISAXISREG As Integer
public:
literal int^ ISAXISREG

See Also

Variant Class


ISREGISTER Field

Variant..::..ISREGISTER Field

Symbol flag for plc register

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int ISREGISTER
Public Const ISREGISTER As Integer
public:
literal int^ ISREGISTER

See Also

Variant Class


MAX_VARIANT_BLOCK_32BITS Field

Variant..::..MAX_VARIANT_BLOCK_32BITS Field

Maximum number of integers that can be transfered in VARIANT_STORAGE_BLOCK structure.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int MAX_VARIANT_BLOCK_32BITS
Public Const MAX_VARIANT_BLOCK_32BITS As Integer
public:
literal int^ MAX_VARIANT_BLOCK_32BITS

See Also

Variant Class


MAX_VARIANT_BLOCK_64BITS Field

Variant..::..MAX_VARIANT_BLOCK_64BITS Field

Maximum number of doubles and int64's that can be transfered in VARIANT_STORAGE_BLOCK structure.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int MAX_VARIANT_BLOCK_64BITS
Public Const MAX_VARIANT_BLOCK_64BITS As Integer
public:
literal int^ MAX_VARIANT_BLOCK_64BITS

See Also

Variant Class


MAX_VARIANT_BLOCK_8BITS Field

Variant..::..MAX_VARIANT_BLOCK_8BITS Field

Maximum number of bytes that can be transfered in VARIANT_STORAGE_BLOCK structure.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int MAX_VARIANT_BLOCK_8BITS
Public Const MAX_VARIANT_BLOCK_8BITS As Integer
public:
literal int^ MAX_VARIANT_BLOCK_8BITS

See Also

Variant Class


QS4_OBJECT_GET_SYMBOL Field

Variant..::..QS4_OBJECT_GET_SYMBOL Field

Row index used when referencing SPECIAL_QS4_OBJECT_REGISTER to retrieve symbol information at the specified offset in controller table.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int QS4_OBJECT_GET_SYMBOL
Public Const QS4_OBJECT_GET_SYMBOL As Integer
public:
literal int^ QS4_OBJECT_GET_SYMBOL

See Also

Variant Class


QS4_OBJECT_NSYMBOLS Field

Variant..::..QS4_OBJECT_NSYMBOLS Field

Row index used when refererencing SPECIAL_QS4_OBJECT_REGISTER to get the number of symbols available in QB program

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int QS4_OBJECT_NSYMBOLS
Public Const QS4_OBJECT_NSYMBOLS As Integer
public:
literal int^ QS4_OBJECT_NSYMBOLS

See Also

Variant Class


SPECIAL_QS4_OBJECT_REGISTER Field

Variant..::..SPECIAL_QS4_OBJECT_REGISTER Field

Register for special QB object information access

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int SPECIAL_QS4_OBJECT_REGISTER
Public Const SPECIAL_QS4_OBJECT_REGISTER As Integer
public:
literal int^ SPECIAL_QS4_OBJECT_REGISTER

See Also

Variant Class


VARIANT_ANY Field

Variant..::..VARIANT_ANY Field

Request type based upon what last written.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_ANY
Public Const VARIANT_ANY As Integer
public:
literal int^ VARIANT_ANY

See Also

Variant Class


VARIANT_BYTE Field

Variant..::..VARIANT_BYTE Field

Request byte type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_BYTE
Public Const VARIANT_BYTE As Integer
public:
literal int^ VARIANT_BYTE

See Also

Variant Class


VARIANT_DOUBLE Field

Variant..::..VARIANT_DOUBLE Field

Request double type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_DOUBLE
Public Const VARIANT_DOUBLE As Integer
public:
literal int^ VARIANT_DOUBLE

See Also

Variant Class


VARIANT_FLOAT Field

Variant..::..VARIANT_FLOAT Field

Request 32 bit float type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_FLOAT
Public Const VARIANT_FLOAT As Integer
public:
literal int^ VARIANT_FLOAT

See Also

Variant Class


VARIANT_INTEGER Field

Variant..::..VARIANT_INTEGER Field

Request integer type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_INTEGER
Public Const VARIANT_INTEGER As Integer
public:
literal int^ VARIANT_INTEGER

See Also

Variant Class


VARIANT_LLONGINTEGER Field

Variant..::..VARIANT_LLONGINTEGER Field

Request 64 bit long type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_LLONGINTEGER
Public Const VARIANT_LLONGINTEGER As Integer
public:
literal int^ VARIANT_LLONGINTEGER

See Also

Variant Class


VARIANT_MAX_STRING Field

Variant..::..VARIANT_MAX_STRING Field

Maximum string length allowed in a variant, typically 223 bytes.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_MAX_STRING
Public Const VARIANT_MAX_STRING As Integer
public:
literal int^ VARIANT_MAX_STRING

See Also

Variant Class


VARIANT_STRING Field

Variant..::..VARIANT_STRING Field

Request string type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_STRING
Public Const VARIANT_STRING As Integer
public:
literal int^ VARIANT_STRING

See Also

Variant Class


VARIANT_UINTEGER Field

Variant..::..VARIANT_UINTEGER Field

Request unsigned integer type within VARIANT_STORAGE

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const int VARIANT_UINTEGER
Public Const VARIANT_UINTEGER As Integer
public:
literal int^ VARIANT_UINTEGER

See Also

Variant Class


Variant Methods

The Variant type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Variant Class


Variant.VARIANT_PLC_RESOURCES Structure

Variant..::..VARIANT_PLC_RESOURCES Structure

Struct VARIANT_PLC_RESOURCES: Resources available for use within the PLC/EtherCAT runtimes.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct VARIANT_PLC_RESOURCES
<StructLayoutAttribute> _
Public Structure VARIANT_PLC_RESOURCES
[StructLayoutAttribute]
public value class VARIANT_PLC_RESOURCES

See Also

Variant..::..VARIANT_PLC_RESOURCES Members


Variant.VARIANT_PLC_RESOURCES Members

Variant..::..VARIANT_PLC_RESOURCES Members

The Variant..::..VARIANT_PLC_RESOURCES type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ains | Total number of analog inputs in the system.
Public field | aouts | Total number of analog outputs in the system.
Public field | axisnum1 | Number of motion axis on CTECAT_1.
Public field | axisnum2 | Number of motion axis on CTECAT_2.
Public field | axisnum3 | Number of motion axis on CTECAT_3, not used.
Public field | axisnum4 | Number of motion axis on CTECAT_4, not used.
Public field | dins | Total number of digital inputs in the system.
Public field | douts | Total number of digital outputs in the system.
Public field | ecat_cards | Number of EtherCAT processes available, typically 1 or 2, one for each network. CTECAT_1 and CTECAT_2.
Public field | misc1 | Not used.
Public field | misc2 | Not used.

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


Variant.VARIANT_PLC_RESOURCES Fields

Variant..::..VARIANT_PLC_RESOURCES Fields

The Variant..::..VARIANT_PLC_RESOURCES type exposes the following members.

Fields

 | Name | Description
Public field | ains | Total number of analog inputs in the system.
Public field | aouts | Total number of analog outputs in the system.
Public field | axisnum1 | Number of motion axis on CTECAT_1.
Public field | axisnum2 | Number of motion axis on CTECAT_2.
Public field | axisnum3 | Number of motion axis on CTECAT_3, not used.
Public field | axisnum4 | Number of motion axis on CTECAT_4, not used.
Public field | dins | Total number of digital inputs in the system.
Public field | douts | Total number of digital outputs in the system.
Public field | ecat_cards | Number of EtherCAT processes available, typically 1 or 2, one for each network. CTECAT_1 and CTECAT_2.
Public field | misc1 | Not used.
Public field | misc2 | Not used.

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


ains Field

VARIANT_PLC_RESOURCES..::..ains Field

Total number of analog inputs in the system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short ains
<FieldOffsetAttribute> _
Public ains As Short
[FieldOffsetAttribute]
public:
short^ ains

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


aouts Field

VARIANT_PLC_RESOURCES..::..aouts Field

Total number of analog outputs in the system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short aouts
<FieldOffsetAttribute> _
Public aouts As Short
[FieldOffsetAttribute]
public:
short^ aouts

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


axisnum1 Field

VARIANT_PLC_RESOURCES..::..axisnum1 Field

Number of motion axis on CTECAT_1.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short axisnum1
<FieldOffsetAttribute> _
Public axisnum1 As Short
[FieldOffsetAttribute]
public:
short^ axisnum1

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


axisnum2 Field

VARIANT_PLC_RESOURCES..::..axisnum2 Field

Number of motion axis on CTECAT_2.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short axisnum2
<FieldOffsetAttribute> _
Public axisnum2 As Short
[FieldOffsetAttribute]
public:
short^ axisnum2

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


axisnum3 Field

VARIANT_PLC_RESOURCES..::..axisnum3 Field

Number of motion axis on CTECAT_3, not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short axisnum3
<FieldOffsetAttribute> _
Public axisnum3 As Short
[FieldOffsetAttribute]
public:
short^ axisnum3

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


axisnum4 Field

VARIANT_PLC_RESOURCES..::..axisnum4 Field

Number of motion axis on CTECAT_4, not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short axisnum4
<FieldOffsetAttribute> _
Public axisnum4 As Short
[FieldOffsetAttribute]
public:
short^ axisnum4

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


dins Field

VARIANT_PLC_RESOURCES..::..dins Field

Total number of digital inputs in the system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short dins
<FieldOffsetAttribute> _
Public dins As Short
[FieldOffsetAttribute]
public:
short^ dins

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


douts Field

VARIANT_PLC_RESOURCES..::..douts Field

Total number of digital outputs in the system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short douts
<FieldOffsetAttribute> _
Public douts As Short
[FieldOffsetAttribute]
public:
short^ douts

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


ecat_cards Field

VARIANT_PLC_RESOURCES..::..ecat_cards Field

Number of EtherCAT processes available, typically 1 or 2, one for each network. CTECAT_1 and CTECAT_2.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short ecat_cards
<FieldOffsetAttribute> _
Public ecat_cards As Short
[FieldOffsetAttribute]
public:
short^ ecat_cards

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


misc1 Field

VARIANT_PLC_RESOURCES..::..misc1 Field

Not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short misc1
<FieldOffsetAttribute> _
Public misc1 As Short
[FieldOffsetAttribute]
public:
short^ misc1

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


misc2 Field

VARIANT_PLC_RESOURCES..::..misc2 Field

Not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short misc2
<FieldOffsetAttribute> _
Public misc2 As Short
[FieldOffsetAttribute]
public:
short^ misc2

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


Variant.VARIANT_PLC_RESOURCES Methods

Variant..::..VARIANT_PLC_RESOURCES Methods

The Variant..::..VARIANT_PLC_RESOURCES type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Variant..::..VARIANT_PLC_RESOURCES Structure


Variant.VARIANT_STORAGE Structure

Variant..::..VARIANT_STORAGE Structure

Struct VARIANT_STORAGE: Universal data type access structure.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct VARIANT_STORAGE
<StructLayoutAttribute> _
Public Structure VARIANT_STORAGE
[StructLayoutAttribute]
public value class VARIANT_STORAGE

See Also

Variant..::..VARIANT_STORAGE Members


Variant.VARIANT_STORAGE Members

Variant..::..VARIANT_STORAGE Members

The Variant..::..VARIANT_STORAGE type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | cmd | Not used at this level, set to 0.
Public field | col | Column index of Variant accessing.
Public field | dValue | If requested via type, 8 byte double value.
Public field | flags | Not used at this level, set to 0.
Public field | fValue | If requested via type, 32 bit float value.
Public field | iValue | If requested via type, integer value.
Public field | llValue | If requested via type, long, int64 value.
Public field | pad | Structure alignment use only, set to 0.
Public field | precision | Precision for type conversions, where 6 is usually the default.
Public field | row | Row index of Variant accessing.
Public field | slength | Is set to string length when raw data, non-ascii is present, else 0.
Public field | sValue | If requested via type, string value, null terminated if ASCII.
Public field | taskhandle | Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.
Public field | type | Variable type using, VARIANT_INTEGER, etc...
Public field | uiValue | If requested via type, unsigned integer value.

See Also

Variant..::..VARIANT_STORAGE Structure


Variant.VARIANT_STORAGE Fields

Variant..::..VARIANT_STORAGE Fields

The Variant..::..VARIANT_STORAGE type exposes the following members.

Fields

 | Name | Description
Public field | cmd | Not used at this level, set to 0.
Public field | col | Column index of Variant accessing.
Public field | dValue | If requested via type, 8 byte double value.
Public field | flags | Not used at this level, set to 0.
Public field | fValue | If requested via type, 32 bit float value.
Public field | iValue | If requested via type, integer value.
Public field | llValue | If requested via type, long, int64 value.
Public field | pad | Structure alignment use only, set to 0.
Public field | precision | Precision for type conversions, where 6 is usually the default.
Public field | row | Row index of Variant accessing.
Public field | slength | Is set to string length when raw data, non-ascii is present, else 0.
Public field | sValue | If requested via type, string value, null terminated if ASCII.
Public field | taskhandle | Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.
Public field | type | Variable type using, VARIANT_INTEGER, etc...
Public field | uiValue | If requested via type, unsigned integer value.

See Also

Variant..::..VARIANT_STORAGE Structure


cmd Field

VARIANT_STORAGE..::..cmd Field

Not used at this level, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte cmd
<FieldOffsetAttribute> _
Public cmd As Byte
[FieldOffsetAttribute]
public:
unsigned char^ cmd

See Also

Variant..::..VARIANT_STORAGE Structure


col Field

VARIANT_STORAGE..::..col Field

Column index of Variant accessing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int col
<FieldOffsetAttribute> _
Public col As Integer
[FieldOffsetAttribute]
public:
int^ col

See Also

Variant..::..VARIANT_STORAGE Structure


dValue Field

VARIANT_STORAGE..::..dValue Field

If requested via type, 8 byte double value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double dValue
<FieldOffsetAttribute> _
Public dValue As Double
[FieldOffsetAttribute]
public:
double^ dValue

See Also

Variant..::..VARIANT_STORAGE Structure


flags Field

VARIANT_STORAGE..::..flags Field

Not used at this level, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte flags
<FieldOffsetAttribute> _
Public flags As Byte
[FieldOffsetAttribute]
public:
unsigned char^ flags

See Also

Variant..::..VARIANT_STORAGE Structure


fValue Field

VARIANT_STORAGE..::..fValue Field

If requested via type, 32 bit float value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float fValue
<FieldOffsetAttribute> _
Public fValue As Single
[FieldOffsetAttribute]
public:
float^ fValue

See Also

Variant..::..VARIANT_STORAGE Structure


iValue Field

VARIANT_STORAGE..::..iValue Field

If requested via type, integer value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int iValue
<FieldOffsetAttribute> _
Public iValue As Integer
[FieldOffsetAttribute]
public:
int^ iValue

See Also

Variant..::..VARIANT_STORAGE Structure


llValue Field

VARIANT_STORAGE..::..llValue Field

If requested via type, long, int64 value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public long llValue
<FieldOffsetAttribute> _
Public llValue As Long
[FieldOffsetAttribute]
public:
long long^ llValue

See Also

Variant..::..VARIANT_STORAGE Structure


pad Field

VARIANT_STORAGE..::..pad Field

Structure alignment use only, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte pad
<FieldOffsetAttribute> _
Public pad As Byte
[FieldOffsetAttribute]
public:
unsigned char^ pad

See Also

Variant..::..VARIANT_STORAGE Structure


precision Field

VARIANT_STORAGE..::..precision Field

Precision for type conversions, where 6 is usually the default.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte precision
<FieldOffsetAttribute> _
Public precision As Byte
[FieldOffsetAttribute]
public:
unsigned char^ precision

See Also

Variant..::..VARIANT_STORAGE Structure


row Field

VARIANT_STORAGE..::..row Field

Row index of Variant accessing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int row
<FieldOffsetAttribute> _
Public row As Integer
[FieldOffsetAttribute]
public:
int^ row

See Also

Variant..::..VARIANT_STORAGE Structure


slength Field

VARIANT_STORAGE..::..slength Field

Is set to string length when raw data, non-ascii is present, else 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short slength
<FieldOffsetAttribute> _
Public slength As Short
[FieldOffsetAttribute]
public:
short^ slength

See Also

Variant..::..VARIANT_STORAGE Structure


sValue Field

VARIANT_STORAGE..::..sValue Field

If requested via type, string value, null terminated if ASCII.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte sValue
<FieldOffsetAttribute> _
Public sValue As Byte
[FieldOffsetAttribute]
public:
unsigned char^ sValue

See Also

Variant..::..VARIANT_STORAGE Structure


taskhandle Field

VARIANT_STORAGE..::..taskhandle Field

Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short taskhandle
<FieldOffsetAttribute> _
Public taskhandle As Short
[FieldOffsetAttribute]
public:
short^ taskhandle

See Also

Variant..::..VARIANT_STORAGE Structure


type Field

VARIANT_STORAGE..::..type Field

Variable type using, VARIANT_INTEGER, etc...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int type
<FieldOffsetAttribute> _
Public type As Integer
[FieldOffsetAttribute]
public:
int^ type

See Also

Variant..::..VARIANT_STORAGE Structure


uiValue Field

VARIANT_STORAGE..::..uiValue Field

If requested via type, unsigned integer value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public uint uiValue
<FieldOffsetAttribute> _
Public uiValue As UInteger
[FieldOffsetAttribute]
public:
unsigned int^ uiValue

See Also

Variant..::..VARIANT_STORAGE Structure


Variant.VARIANT_STORAGE Methods

Variant..::..VARIANT_STORAGE Methods

The Variant..::..VARIANT_STORAGE type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Variant..::..VARIANT_STORAGE Structure


Variant.VARIANT_STORAGE_BLOCK Structure

Variant..::..VARIANT_STORAGE_BLOCK Structure

Struct VARIANT_STORAGE_BLOCK: Universal data type access structure for block transfer of same type.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct VARIANT_STORAGE_BLOCK
<StructLayoutAttribute> _
Public Structure VARIANT_STORAGE_BLOCK
[StructLayoutAttribute]
public value class VARIANT_STORAGE_BLOCK

See Also

Variant..::..VARIANT_STORAGE_BLOCK Members


Variant.VARIANT_STORAGE_BLOCK Members

Variant..::..VARIANT_STORAGE_BLOCK Members

The Variant..::..VARIANT_STORAGE_BLOCK type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | arraysizeCols | Used on write operation, -1 do not expand existing columns, else columns desired. Rows will automatically grow as needed.
Public field | cmd | Not used at this level, set to 0.
Public field | col | Column index of Variant accessing.
Public field | colInc | Column increment, if 0 just increment by rows.
Public field | dbValue | Double block storage.
Public field | fbValue | Floating point block storage.
Public field | flags | Not used at this level, set to 0.
Public field | ibValue | Integer block storage.
Public field | numAccess | Is set to number of block entries.
Public field | pad | Structure alignment use only, set to 0.
Public field | precision | Precision for type conversions, where 6 is usually the default.
Public field | row | Row index of Variant accessing.
Public field | rowInc | Row increment, if 0 just read columns based upon colInc.
Public field | slength | Is set to number of block entries.
Public field | taskhandle | Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.
Public field | type | Variable type using, VARIANT_INTEGER, etc...
Public field | ucbValue | Unsigned byte block storage.
Public field | uibValue | Unsigned integer block storage.

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


Variant.VARIANT_STORAGE_BLOCK Fields

Variant..::..VARIANT_STORAGE_BLOCK Fields

The Variant..::..VARIANT_STORAGE_BLOCK type exposes the following members.

Fields

 | Name | Description
Public field | arraysizeCols | Used on write operation, -1 do not expand existing columns, else columns desired. Rows will automatically grow as needed.
Public field | cmd | Not used at this level, set to 0.
Public field | col | Column index of Variant accessing.
Public field | colInc | Column increment, if 0 just increment by rows.
Public field | dbValue | Double block storage.
Public field | fbValue | Floating point block storage.
Public field | flags | Not used at this level, set to 0.
Public field | ibValue | Integer block storage.
Public field | numAccess | Is set to number of block entries.
Public field | pad | Structure alignment use only, set to 0.
Public field | precision | Precision for type conversions, where 6 is usually the default.
Public field | row | Row index of Variant accessing.
Public field | rowInc | Row increment, if 0 just read columns based upon colInc.
Public field | slength | Is set to number of block entries.
Public field | taskhandle | Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.
Public field | type | Variable type using, VARIANT_INTEGER, etc...
Public field | ucbValue | Unsigned byte block storage.
Public field | uibValue | Unsigned integer block storage.

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


arraysizeCols Field

VARIANT_STORAGE_BLOCK..::..arraysizeCols Field

Used on write operation, -1 do not expand existing columns, else columns desired. Rows will automatically grow as needed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int arraysizeCols
<FieldOffsetAttribute> _
Public arraysizeCols As Integer
[FieldOffsetAttribute]
public:
int^ arraysizeCols

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


cmd Field

VARIANT_STORAGE_BLOCK..::..cmd Field

Not used at this level, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte cmd
<FieldOffsetAttribute> _
Public cmd As Byte
[FieldOffsetAttribute]
public:
unsigned char^ cmd

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


col Field

VARIANT_STORAGE_BLOCK..::..col Field

Column index of Variant accessing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int col
<FieldOffsetAttribute> _
Public col As Integer
[FieldOffsetAttribute]
public:
int^ col

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


colInc Field

VARIANT_STORAGE_BLOCK..::..colInc Field

Column increment, if 0 just increment by rows.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int colInc
<FieldOffsetAttribute> _
Public colInc As Integer
[FieldOffsetAttribute]
public:
int^ colInc

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


dbValue Field

VARIANT_STORAGE_BLOCK..::..dbValue Field

Double block storage.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public double dbValue
<FieldOffsetAttribute> _
Public dbValue As Double
[FieldOffsetAttribute]
public:
double^ dbValue

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


fbValue Field

VARIANT_STORAGE_BLOCK..::..fbValue Field

Floating point block storage.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public float fbValue
<FieldOffsetAttribute> _
Public fbValue As Single
[FieldOffsetAttribute]
public:
float^ fbValue

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


flags Field

VARIANT_STORAGE_BLOCK..::..flags Field

Not used at this level, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte flags
<FieldOffsetAttribute> _
Public flags As Byte
[FieldOffsetAttribute]
public:
unsigned char^ flags

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


ibValue Field

VARIANT_STORAGE_BLOCK..::..ibValue Field

Integer block storage.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int ibValue
<FieldOffsetAttribute> _
Public ibValue As Integer
[FieldOffsetAttribute]
public:
int^ ibValue

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


numAccess Field

VARIANT_STORAGE_BLOCK..::..numAccess Field

Is set to number of block entries.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int numAccess
<FieldOffsetAttribute> _
Public numAccess As Integer
[FieldOffsetAttribute]
public:
int^ numAccess

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


pad Field

VARIANT_STORAGE_BLOCK..::..pad Field

Structure alignment use only, set to 0.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte pad
<FieldOffsetAttribute> _
Public pad As Byte
[FieldOffsetAttribute]
public:
unsigned char^ pad

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


precision Field

VARIANT_STORAGE_BLOCK..::..precision Field

Precision for type conversions, where 6 is usually the default.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte precision
<FieldOffsetAttribute> _
Public precision As Byte
[FieldOffsetAttribute]
public:
unsigned char^ precision

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


row Field

VARIANT_STORAGE_BLOCK..::..row Field

Row index of Variant accessing.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int row
<FieldOffsetAttribute> _
Public row As Integer
[FieldOffsetAttribute]
public:
int^ row

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


rowInc Field

VARIANT_STORAGE_BLOCK..::..rowInc Field

Row increment, if 0 just read columns based upon colInc.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int rowInc
<FieldOffsetAttribute> _
Public rowInc As Integer
[FieldOffsetAttribute]
public:
int^ rowInc

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


slength Field

VARIANT_STORAGE_BLOCK..::..slength Field

Is set to number of block entries.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short slength
<FieldOffsetAttribute> _
Public slength As Short
[FieldOffsetAttribute]
public:
short^ slength

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


taskhandle Field

VARIANT_STORAGE_BLOCK..::..taskhandle Field

Not used at this level, set to 0. Useful at QuickBuilder level when using local variants.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public short taskhandle
<FieldOffsetAttribute> _
Public taskhandle As Short
[FieldOffsetAttribute]
public:
short^ taskhandle

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


type Field

VARIANT_STORAGE_BLOCK..::..type Field

Variable type using, VARIANT_INTEGER, etc...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public int type
<FieldOffsetAttribute> _
Public type As Integer
[FieldOffsetAttribute]
public:
int^ type

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


ucbValue Field

VARIANT_STORAGE_BLOCK..::..ucbValue Field

Unsigned byte block storage.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public byte ucbValue
<FieldOffsetAttribute> _
Public ucbValue As Byte
[FieldOffsetAttribute]
public:
unsigned char^ ucbValue

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


uibValue Field

VARIANT_STORAGE_BLOCK..::..uibValue Field

Unsigned integer block storage.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public uint uibValue
<FieldOffsetAttribute> _
Public uibValue As UInteger
[FieldOffsetAttribute]
public:
unsigned int^ uibValue

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


Variant.VARIANT_STORAGE_BLOCK Methods

Variant..::..VARIANT_STORAGE_BLOCK Methods

The Variant..::..VARIANT_STORAGE_BLOCK type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Variant..::..VARIANT_STORAGE_BLOCK Structure


Variant.VARIANT_STORAGE_BLOCK_TRANSFER Structure

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure

Struct VARIANT_STORAGE_TRANSFER

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct VARIANT_STORAGE_BLOCK_TRANSFER
<StructLayoutAttribute> _
Public Structure VARIANT_STORAGE_BLOCK_TRANSFER
[StructLayoutAttribute]
public value class VARIANT_STORAGE_BLOCK_TRANSFER

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Members


Variant.VARIANT_STORAGE_BLOCK_TRANSFER Members

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Members

The Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | register | Desired PLC register to access.
Public field | v | Variant storage information.

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure


Variant.VARIANT_STORAGE_BLOCK_TRANSFER Fields

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Fields

The Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER type exposes the following members.

Fields

 | Name | Description
Public field | register | Desired PLC register to access.
Public field | v | Variant storage information.

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure


register Field

VARIANT_STORAGE_BLOCK_TRANSFER..::..register Field

Desired PLC register to access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public uint register
<FieldOffsetAttribute> _
Public register As UInteger
[FieldOffsetAttribute]
public:
unsigned int^ register

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure


v Field

VARIANT_STORAGE_BLOCK_TRANSFER..::..v Field

Variant storage information.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Variant..::..VARIANT_STORAGE_BLOCK v
<FieldOffsetAttribute> _
Public v As Variant..::..VARIANT_STORAGE_BLOCK
[FieldOffsetAttribute]
public:
Variant..::..VARIANT_STORAGE_BLOCK^ v

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure


Variant.VARIANT_STORAGE_BLOCK_TRANSFER Methods

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Methods

The Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Variant..::..VARIANT_STORAGE_BLOCK_TRANSFER Structure


Variant.VARIANT_STORAGE_TRANSFER Structure

Variant..::..VARIANT_STORAGE_TRANSFER Structure

Struct VARIANT_STORAGE_TRANSFER

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct VARIANT_STORAGE_TRANSFER
<StructLayoutAttribute> _
Public Structure VARIANT_STORAGE_TRANSFER
[StructLayoutAttribute]
public value class VARIANT_STORAGE_TRANSFER

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Members


Variant.VARIANT_STORAGE_TRANSFER Members

Variant..::..VARIANT_STORAGE_TRANSFER Members

The Variant..::..VARIANT_STORAGE_TRANSFER type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | register | Desired PLC register to access.
Public field | v | Variant storage information.

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Structure


Variant.VARIANT_STORAGE_TRANSFER Fields

Variant..::..VARIANT_STORAGE_TRANSFER Fields

The Variant..::..VARIANT_STORAGE_TRANSFER type exposes the following members.

Fields

 | Name | Description
Public field | register | Desired PLC register to access.
Public field | v | Variant storage information.

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Structure


register Field

VARIANT_STORAGE_TRANSFER..::..register Field

Desired PLC register to access.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public uint register
<FieldOffsetAttribute> _
Public register As UInteger
[FieldOffsetAttribute]
public:
unsigned int^ register

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Structure


v Field

VARIANT_STORAGE_TRANSFER..::..v Field

Variant storage information.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
[FieldOffsetAttribute]
public Variant..::..VARIANT_STORAGE v
<FieldOffsetAttribute> _
Public v As Variant..::..VARIANT_STORAGE
[FieldOffsetAttribute]
public:
Variant..::..VARIANT_STORAGE^ v

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Structure


Variant.VARIANT_STORAGE_TRANSFER Methods

Variant..::..VARIANT_STORAGE_TRANSFER Methods

The Variant..::..VARIANT_STORAGE_TRANSFER type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Variant..::..VARIANT_STORAGE_TRANSFER Structure


CTRS0 Field

CAP_REFERENCE..::..CTRS0 Field

ctr0 property, axis counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE CTRS0
Public Const CTRS0 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE CTRS0

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


CTRS1 Field

CAP_REFERENCE..::..CTRS1 Field

ctr1 property, axis counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE CTRS1
Public Const CTRS1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE CTRS1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


CTRS2 Field

CAP_REFERENCE..::..CTRS2 Field

ctr2 property, axis counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE CTRS2
Public Const CTRS2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE CTRS2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


CTRS3 Field

CAP_REFERENCE..::..CTRS3 Field

ctr3 property, axis counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE CTRS3
Public Const CTRS3 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE CTRS3

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


CTRS4 Field

CAP_REFERENCE..::..CTRS4 Field

ctr4 property, axis counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE CTRS4
Public Const CTRS4 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE CTRS4

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


FPOSC Field

CAP_REFERENCE..::..FPOSC Field

fposc property, feedback position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE FPOSC
Public Const FPOSC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE FPOSC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


FPOSC1 Field

CAP_REFERENCE..::..FPOSC1 Field

fposc property of axis 1, feedback position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE FPOSC1
Public Const FPOSC1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE FPOSC1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


FPOSC2 Field

CAP_REFERENCE..::..FPOSC2 Field

fposc property of axis 2, feedback position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE FPOSC2
Public Const FPOSC2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE FPOSC2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MASTER_FPOSC0 Field

CAP_REFERENCE..::..MASTER_FPOSC0 Field

fposc property of master encoder 0, not currently used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC0
Public Const MASTER_FPOSC0 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC0

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MASTER_FPOSC1 Field

CAP_REFERENCE..::..MASTER_FPOSC1 Field

fposc property of master encoder 1, not currently used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC1
Public Const MASTER_FPOSC1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MASTER_FPOSC2 Field

CAP_REFERENCE..::..MASTER_FPOSC2 Field

fposc property of master encoder 2, not currently used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC2
Public Const MASTER_FPOSC2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MASTER_FPOSC2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC Field

CAP_REFERENCE..::..MPOSC Field

mposc property, master position, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC
Public Const MPOSC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC1 Field

CAP_REFERENCE..::..MPOSC1 Field

mposc1 property, master position, counts by 'mmc'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC1
Public Const MPOSC1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC2 Field

CAP_REFERENCE..::..MPOSC2 Field

mposc2 property, master position, counts by 'mmc'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC2
Public Const MPOSC2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC3 Field

CAP_REFERENCE..::..MPOSC3 Field

mposc3 property, master position, counts by 'mmc'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC3
Public Const MPOSC3 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC3

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC4 Field

CAP_REFERENCE..::..MPOSC4 Field

mposc4 property, master position, counts by 'mmc'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC4
Public Const MPOSC4 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC4

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


MPOSC5 Field

CAP_REFERENCE..::..MPOSC5 Field

mposc5 property, master position, counts by 'mmc'.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE MPOSC5
Public Const MPOSC5 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE MPOSC5

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


SDC Field

CAP_REFERENCE..::..SDC Field

sdc property, slave decrement counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE SDC
Public Const SDC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE SDC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


SFPOSC Field

CAP_REFERENCE..::..SFPOSC Field

sfposc property, slave feedback position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE SFPOSC
Public Const SFPOSC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE SFPOSC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


SMARK Field

CAP_REFERENCE..::..SMARK Field

smark property, slave modulo marker position, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE SMARK
Public Const SMARK As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE SMARK

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


SMODC Field

CAP_REFERENCE..::..SMODC Field

smodc property, slave position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE SMODC
Public Const SMODC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE SMODC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TMC1 Field

CAP_REFERENCE..::..TMC1 Field

tmc1 property, temporary master position 1, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TMC1
Public Const TMC1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TMC1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TMC2 Field

CAP_REFERENCE..::..TMC2 Field

tmc2 property, temporary master position 2, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TMC2
Public Const TMC2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TMC2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TMODC Field

CAP_REFERENCE..::..TMODC Field

tmodc property, temporary master position counter mod mmc.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TMODC
Public Const TMODC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TMODC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TPOSC Field

CAP_REFERENCE..::..TPOSC Field

tposc property, target position counter.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TPOSC
Public Const TPOSC As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TPOSC

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TSC1 Field

CAP_REFERENCE..::..TSC1 Field

tsc1 property, temporary slave position 1, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TSC1
Public Const TSC1 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TSC1

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


TSC2 Field

CAP_REFERENCE..::..TSC2 Field

tsc2 property, temporary slave position 2, counts.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAP_REFERENCE TSC2
Public Const TSC2 As Controller..::..Axis..::..CAP_REFERENCE
public:
literal Controller..::..Axis..::..CAP_REFERENCE TSC2

See Also

Controller..::..Axis..::..CAP_REFERENCE Enumeration


EDGE Field

CAPTURE_TRANSISTIONS..::..EDGE Field

Any edge.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAPTURE_TRANSISTIONS EDGE
Public Const EDGE As Controller..::..Axis..::..CAPTURE_TRANSISTIONS
public:
literal Controller..::..Axis..::..CAPTURE_TRANSISTIONS EDGE

See Also

Controller..::..Axis..::..CAPTURE_TRANSISTIONS Enumeration


FALL Field

CAPTURE_TRANSISTIONS..::..FALL Field

Falling edge.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAPTURE_TRANSISTIONS FALL
Public Const FALL As Controller..::..Axis..::..CAPTURE_TRANSISTIONS
public:
literal Controller..::..Axis..::..CAPTURE_TRANSISTIONS FALL

See Also

Controller..::..Axis..::..CAPTURE_TRANSISTIONS Enumeration


RISE Field

CAPTURE_TRANSISTIONS..::..RISE Field

Rising edge.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..CAPTURE_TRANSISTIONS RISE
Public Const RISE As Controller..::..Axis..::..CAPTURE_TRANSISTIONS
public:
literal Controller..::..Axis..::..CAPTURE_TRANSISTIONS RISE

See Also

Controller..::..Axis..::..CAPTURE_TRANSISTIONS Enumeration


DRIVE_ABB_MICROFLEX Field

DRIVE_TYPES..::..DRIVE_ABB_MICROFLEX Field

ABB Miroflex drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_ABB_MICROFLEX
Public Const DRIVE_ABB_MICROFLEX As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_ABB_MICROFLEX

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_AMC Field

DRIVE_TYPES..::..DRIVE_AMC Field

Advanced Motion Controls drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_AMC
Public Const DRIVE_AMC As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_AMC

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_ANALOG Field

DRIVE_TYPES..::..DRIVE_ANALOG Field

Analog drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_ANALOG
Public Const DRIVE_ANALOG As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_ANALOG

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_COPLEY Field

DRIVE_TYPES..::..DRIVE_COPLEY Field

Copley drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_COPLEY
Public Const DRIVE_COPLEY As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_COPLEY

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_ELMO Field

DRIVE_TYPES..::..DRIVE_ELMO Field

Elmo drive, not presently supported.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_ELMO
Public Const DRIVE_ELMO As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_ELMO

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_EMERSON Field

DRIVE_TYPES..::..DRIVE_EMERSON Field

Emerson drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_EMERSON
Public Const DRIVE_EMERSON As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_EMERSON

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_IAI_ACON_MODE0 Field

DRIVE_TYPES..::..DRIVE_IAI_ACON_MODE0 Field

IAI actuator MODE0 drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_IAI_ACON_MODE0
Public Const DRIVE_IAI_ACON_MODE0 As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_IAI_ACON_MODE0

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_IAI_ACON_MODE3 Field

DRIVE_TYPES..::..DRIVE_IAI_ACON_MODE3 Field

IAI actuator MODE3 drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_IAI_ACON_MODE3
Public Const DRIVE_IAI_ACON_MODE3 As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_IAI_ACON_MODE3

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_KOLLMORGEN Field

DRIVE_TYPES..::..DRIVE_KOLLMORGEN Field

Kollmorgen drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_KOLLMORGEN
Public Const DRIVE_KOLLMORGEN As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_KOLLMORGEN

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_LINMOT Field

DRIVE_TYPES..::..DRIVE_LINMOT Field

LinMOT linear actuator drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_LINMOT
Public Const DRIVE_LINMOT As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_LINMOT

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_MITSUBISHI Field

DRIVE_TYPES..::..DRIVE_MITSUBISHI Field

Mitsubishi drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_MITSUBISHI
Public Const DRIVE_MITSUBISHI As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_MITSUBISHI

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_PANASONIC Field

DRIVE_TYPES..::..DRIVE_PANASONIC Field

Panasonic drive, not presently supported.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_PANASONIC
Public Const DRIVE_PANASONIC As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_PANASONIC

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_SANYO_DENKI Field

DRIVE_TYPES..::..DRIVE_SANYO_DENKI Field

Sanyo Denki drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_SANYO_DENKI
Public Const DRIVE_SANYO_DENKI As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_SANYO_DENKI

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_UNDEFINED Field

DRIVE_TYPES..::..DRIVE_UNDEFINED Field

None defined.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_UNDEFINED
Public Const DRIVE_UNDEFINED As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_UNDEFINED

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_VIRTUAL Field

DRIVE_TYPES..::..DRIVE_VIRTUAL Field

Virtual axis, simulated drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_VIRTUAL
Public Const DRIVE_VIRTUAL As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_VIRTUAL

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DRIVE_YASKAWA Field

DRIVE_TYPES..::..DRIVE_YASKAWA Field

Yaskawa drive.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..DRIVE_TYPES DRIVE_YASKAWA
Public Const DRIVE_YASKAWA As Controller..::..Axis..::..DRIVE_TYPES
public:
literal Controller..::..Axis..::..DRIVE_TYPES DRIVE_YASKAWA

See Also

Controller..::..Axis..::..DRIVE_TYPES Enumeration


DINT Field

ECAT_OBJECT_SIZE..::..DINT Field

Signed 32 bit integer

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE DINT
Public Const DINT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE DINT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


INT Field

ECAT_OBJECT_SIZE..::..INT Field

Signed 16 bit integer

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE INT
Public Const INT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE INT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


SINT Field

ECAT_OBJECT_SIZE..::..SINT Field

Signed 8 bit byte

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE SINT
Public Const SINT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE SINT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


UDINT Field

ECAT_OBJECT_SIZE..::..UDINT Field

Unsigned 32 bit integer

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE UDINT
Public Const UDINT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE UDINT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


UINT Field

ECAT_OBJECT_SIZE..::..UINT Field

Unsigned 16 bit integer

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE UINT
Public Const UINT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE UINT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


USINT Field

ECAT_OBJECT_SIZE..::..USINT Field

Unsigned 8 bit byte

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ECAT_OBJECT_SIZE USINT
Public Const USINT As Controller..::..Axis..::..ECAT_OBJECT_SIZE
public:
literal Controller..::..Axis..::..ECAT_OBJECT_SIZE USINT

See Also

Controller..::..Axis..::..ECAT_OBJECT_SIZE Enumeration


CYCLIC_SYNC_POSITION_MODE Field

ETHERCAT_MODES..::..CYCLIC_SYNC_POSITION_MODE Field

Cyclic sync position mode, most common move used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES CYCLIC_SYNC_POSITION_MODE
Public Const CYCLIC_SYNC_POSITION_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES CYCLIC_SYNC_POSITION_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


HOMING_MODE Field

ETHERCAT_MODES..::..HOMING_MODE Field

Homing mode, drive specific

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES HOMING_MODE
Public Const HOMING_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES HOMING_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


INTERPOLATED_POSITION_MODE Field

ETHERCAT_MODES..::..INTERPOLATED_POSITION_MODE Field

Interpolated position mode.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES INTERPOLATED_POSITION_MODE
Public Const INTERPOLATED_POSITION_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES INTERPOLATED_POSITION_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


PROFILE_POSITION_MODE Field

ETHERCAT_MODES..::..PROFILE_POSITION_MODE Field

Profile Position mode.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES PROFILE_POSITION_MODE
Public Const PROFILE_POSITION_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES PROFILE_POSITION_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


PROFILE_TORQUE_MODE Field

ETHERCAT_MODES..::..PROFILE_TORQUE_MODE Field

Profile torque mode, not supported.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES PROFILE_TORQUE_MODE
Public Const PROFILE_TORQUE_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES PROFILE_TORQUE_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


PROFILE_VELOCITY_MODE Field

ETHERCAT_MODES..::..PROFILE_VELOCITY_MODE Field

Profile velocity mode.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..ETHERCAT_MODES PROFILE_VELOCITY_MODE
Public Const PROFILE_VELOCITY_MODE As Controller..::..Axis..::..ETHERCAT_MODES
public:
literal Controller..::..Axis..::..ETHERCAT_MODES PROFILE_VELOCITY_MODE

See Also

Controller..::..Axis..::..ETHERCAT_MODES Enumeration


FEEDBACK Field

MASTER_MODES..::..FEEDBACK Field

fpos feedback.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MASTER_MODES FEEDBACK
Public Const FEEDBACK As Controller..::..Axis..::..MASTER_MODES
public:
literal Controller..::..Axis..::..MASTER_MODES FEEDBACK

See Also

Controller..::..Axis..::..MASTER_MODES Enumeration


FEEDBACKZ Field

MASTER_MODES..::..FEEDBACKZ Field

fposz feedback, currently not supported due to drive limitations.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MASTER_MODES FEEDBACKZ
Public Const FEEDBACKZ As Controller..::..Axis..::..MASTER_MODES
public:
literal Controller..::..Axis..::..MASTER_MODES FEEDBACKZ

See Also

Controller..::..Axis..::..MASTER_MODES Enumeration


TARGET Field

MASTER_MODES..::..TARGET Field

tpos feedback.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MASTER_MODES TARGET
Public Const TARGET As Controller..::..Axis..::..MASTER_MODES
public:
literal Controller..::..Axis..::..MASTER_MODES TARGET

See Also

Controller..::..Axis..::..MASTER_MODES Enumeration


VIRTUAL Field

MASTER_MODES..::..VIRTUAL Field

Virtual master, currently not used since virtual axis can run its own simulated encoder.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MASTER_MODES VIRTUAL
Public Const VIRTUAL As Controller..::..Axis..::..MASTER_MODES
public:
literal Controller..::..Axis..::..MASTER_MODES VIRTUAL

See Also

Controller..::..Axis..::..MASTER_MODES Enumeration


MF_ABORT_REQUESTED Field

MOTION_FAULTS..::..MF_ABORT_REQUESTED Field

Abort was requested, probably from download of a new QB program while API was running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ABORT_REQUESTED
Public Const MF_ABORT_REQUESTED As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ABORT_REQUESTED

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_BADARGUMENT1 Field

MOTION_FAULTS..::..MF_BADARGUMENT1 Field

Bad argument 1.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT1
Public Const MF_BADARGUMENT1 As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT1

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_BADARGUMENT2 Field

MOTION_FAULTS..::..MF_BADARGUMENT2 Field

Bad argument 2.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT2
Public Const MF_BADARGUMENT2 As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT2

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_BADARGUMENT3 Field

MOTION_FAULTS..::..MF_BADARGUMENT3 Field

Bad argument 3.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT3
Public Const MF_BADARGUMENT3 As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT3

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_BADARGUMENT4 Field

MOTION_FAULTS..::..MF_BADARGUMENT4 Field

Bad argument 4.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT4
Public Const MF_BADARGUMENT4 As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_BADARGUMENT4

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_BADINPUTNO Field

MOTION_FAULTS..::..MF_BADINPUTNO Field

Invalid input number.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_BADINPUTNO
Public Const MF_BADINPUTNO As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_BADINPUTNO

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_CANTCONSUME Field

MOTION_FAULTS..::..MF_CANTCONSUME Field

When gearing, mtm != MTM_GEAR_AT.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_CANTCONSUME
Public Const MF_CANTCONSUME As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_CANTCONSUME

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_DCSYNC Field

MOTION_FAULTS..::..MF_DCSYNC Field

EtherCAT DC Sync command failed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_DCSYNC
Public Const MF_DCSYNC As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_DCSYNC

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_DRIVE_ERR_MSG Field

MOTION_FAULTS..::..MF_DRIVE_ERR_MSG Field

General drive logging fault, check logs.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_DRIVE_ERR_MSG
Public Const MF_DRIVE_ERR_MSG As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_DRIVE_ERR_MSG

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ECAT_OFFLINE Field

MOTION_FAULTS..::..MF_ECAT_OFFLINE Field

Attempted command but EtherCAT is offline.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ECAT_OFFLINE
Public Const MF_ECAT_OFFLINE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ECAT_OFFLINE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ECATQue_REQUEST Field

MOTION_FAULTS..::..MF_ECATQue_REQUEST Field

The PLC request mailbox is missing? Possibly invalid name or duplicate?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ECATQue_REQUEST
Public Const MF_ECATQue_REQUEST As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ECATQue_REQUEST

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ECATQue_RESPONSE Field

MOTION_FAULTS..::..MF_ECATQue_RESPONSE Field

The PLC response mailbox is missing? Possibly invalid name or duplicate?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ECATQue_RESPONSE
Public Const MF_ECATQue_RESPONSE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ECATQue_RESPONSE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ECATQueAPI Field

MOTION_FAULTS..::..MF_ECATQueAPI Field

The PLC mailbox is missing? Possibly not running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ECATQueAPI
Public Const MF_ECATQueAPI As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ECATQueAPI

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ERROR_NO_SERVO Field

MOTION_FAULTS..::..MF_ERROR_NO_SERVO Field

No Servo existed?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ERROR_NO_SERVO
Public Const MF_ERROR_NO_SERVO As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ERROR_NO_SERVO

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_FGMSBLIMIT Field

MOTION_FAULTS..::..MF_FGMSBLIMIT Field

Attempted too many foreground MSBs.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_FGMSBLIMIT
Public Const MF_FGMSBLIMIT As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_FGMSBLIMIT

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_FOLLOWERR Field

MOTION_FAULTS..::..MF_FOLLOWERR Field

Error > perrlimit.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_FOLLOWERR
Public Const MF_FOLLOWERR As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_FOLLOWERR

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_GENERICFAULT Field

MOTION_FAULTS..::..MF_GENERICFAULT Field

Generic Fault.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_GENERICFAULT
Public Const MF_GENERICFAULT As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_GENERICFAULT

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALID_ECAT_MODE Field

MOTION_FAULTS..::..MF_INVALID_ECAT_MODE Field

Attempting to process a move command request but the EtherCAT drive is in the wrong mode (cmode).

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_ECAT_MODE
Public Const MF_INVALID_ECAT_MODE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_ECAT_MODE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALID_TBL_OP Field

MOTION_FAULTS..::..MF_INVALID_TBL_OP Field

Invalid table operation, for example table # or points exceeds limits.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP
Public Const MF_INVALID_TBL_OP As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALID_TBL_OP_Y Field

MOTION_FAULTS..::..MF_INVALID_TBL_OP_Y Field

Out of room in table, Y axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP_Y
Public Const MF_INVALID_TBL_OP_Y As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP_Y

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALID_TBL_OP_Z Field

MOTION_FAULTS..::..MF_INVALID_TBL_OP_Z Field

Out of room in table, Z axis.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP_Z
Public Const MF_INVALID_TBL_OP_Z As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TBL_OP_Z

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALID_TRACKING Field

MOTION_FAULTS..::..MF_INVALID_TRACKING Field

Attempting to begin slew but in TRACKING mode.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TRACKING
Public Const MF_INVALID_TRACKING As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALID_TRACKING

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALIDACC Field

MOTION_FAULTS..::..MF_INVALIDACC Field

Invalid acceleration.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDACC
Public Const MF_INVALIDACC As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDACC

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALIDDEC Field

MOTION_FAULTS..::..MF_INVALIDDEC Field

Invalid deceleration.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDDEC
Public Const MF_INVALIDDEC As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDDEC

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALIDRATE Field

MOTION_FAULTS..::..MF_INVALIDRATE Field

Invalid rate.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDRATE
Public Const MF_INVALIDRATE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDRATE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALIDTIME Field

MOTION_FAULTS..::..MF_INVALIDTIME Field

Time request on move command is not possible or is negative.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDTIME
Public Const MF_INVALIDTIME As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDTIME

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_INVALIDVEL Field

MOTION_FAULTS..::..MF_INVALIDVEL Field

Invalid velocity.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDVEL
Public Const MF_INVALIDVEL As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_INVALIDVEL

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_MESSAGE_RESULT Field

MOTION_FAULTS..::..MF_MESSAGE_RESULT Field

Command returned with a bad result message length, should be 4 byte int?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_MESSAGE_RESULT
Public Const MF_MESSAGE_RESULT As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_MESSAGE_RESULT

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_MOTIONACTIVE Field

MOTION_FAULTS..::..MF_MOTIONACTIVE Field

Attempted a move while already active moving.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_MOTIONACTIVE
Public Const MF_MOTIONACTIVE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_MOTIONACTIVE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NAME_TO_LONG Field

MOTION_FAULTS..::..MF_NAME_TO_LONG Field

The PLC request mailbox name is too long? Limited to 8 characters maximum.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NAME_TO_LONG
Public Const MF_NAME_TO_LONG As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NAME_TO_LONG

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NO_ERROR Field

MOTION_FAULTS..::..MF_NO_ERROR Field

No Error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NO_ERROR
Public Const MF_NO_ERROR As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NO_ERROR

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NOCAMFILE Field

MOTION_FAULTS..::..MF_NOCAMFILE Field

Attempted to load CAM file but failed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NOCAMFILE
Public Const MF_NOCAMFILE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NOCAMFILE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NOMSBFILE Field

MOTION_FAULTS..::..MF_NOMSBFILE Field

Attempted to load MSB file but failed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NOMSBFILE
Public Const MF_NOMSBFILE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NOMSBFILE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NOTENABLED Field

MOTION_FAULTS..::..MF_NOTENABLED Field

Drive not enabled.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NOTENABLED
Public Const MF_NOTENABLED As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NOTENABLED

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NOTINSLEW Field

MOTION_FAULTS..::..MF_NOTINSLEW Field

Not in slew mode and it is required for this operation.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NOTINSLEW
Public Const MF_NOTINSLEW As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NOTINSLEW

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NOTINTRACK Field

MOTION_FAULTS..::..MF_NOTINTRACK Field

Not in tracking mode and it is required for this command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NOTINTRACK
Public Const MF_NOTINTRACK As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NOTINTRACK

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_NTX_TYPE_RT_PROCESS Field

MOTION_FAULTS..::..MF_NTX_TYPE_RT_PROCESS Field

Attempted to attached to a process other than real time?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_NTX_TYPE_RT_PROCESS
Public Const MF_NTX_TYPE_RT_PROCESS As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_NTX_TYPE_RT_PROCESS

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_ONLYINBG Field

MOTION_FAULTS..::..MF_ONLYINBG Field

This command can only run in background mode and foreground was attempted.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_ONLYINBG
Public Const MF_ONLYINBG As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_ONLYINBG

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_READONLY Field

MOTION_FAULTS..::..MF_READONLY Field

Attempted to write to read only

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_READONLY
Public Const MF_READONLY As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_READONLY

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_REMOTE_READ Field

MOTION_FAULTS..::..MF_REMOTE_READ Field

Host read error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_REMOTE_READ
Public Const MF_REMOTE_READ As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_REMOTE_READ

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_REMOTE_WRITE Field

MOTION_FAULTS..::..MF_REMOTE_WRITE Field

Host write error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_REMOTE_WRITE
Public Const MF_REMOTE_WRITE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_REMOTE_WRITE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_SDO_READ Field

MOTION_FAULTS..::..MF_SDO_READ Field

SDO Read error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_SDO_READ
Public Const MF_SDO_READ As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_SDO_READ

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_SDO_WRITE Field

MOTION_FAULTS..::..MF_SDO_WRITE Field

SDO Write error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_SDO_WRITE
Public Const MF_SDO_WRITE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_SDO_WRITE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_SESGMOVE_ERROR Field

MOTION_FAULTS..::..MF_SESGMOVE_ERROR Field

Segmove error, current velocity is not zero.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_SESGMOVE_ERROR
Public Const MF_SESGMOVE_ERROR As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_SESGMOVE_ERROR

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_SESGMOVE_SIZE Field

MOTION_FAULTS..::..MF_SESGMOVE_SIZE Field

Not enough room to add segment.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_SESGMOVE_SIZE
Public Const MF_SESGMOVE_SIZE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_SESGMOVE_SIZE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_STACK_ERROR Field

MOTION_FAULTS..::..MF_STACK_ERROR Field

MSB stack error

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_STACK_ERROR
Public Const MF_STACK_ERROR As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_STACK_ERROR

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_TIMEOUT Field

MOTION_FAULTS..::..MF_TIMEOUT Field

Command timeout, typically Wait For In Position optional timeout or other command supporting it.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_TIMEOUT
Public Const MF_TIMEOUT As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_TIMEOUT

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_UNIMPLEMENTED Field

MOTION_FAULTS..::..MF_UNIMPLEMENTED Field

Attempted to execute unimplemented command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_UNIMPLEMENTED
Public Const MF_UNIMPLEMENTED As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_UNIMPLEMENTED

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


MF_WRONGMODE Field

MOTION_FAULTS..::..MF_WRONGMODE Field

Attempting to set mode but pstate is not in proper state.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOTION_FAULTS MF_WRONGMODE
Public Const MF_WRONGMODE As Controller..::..Axis..::..MOTION_FAULTS
public:
literal Controller..::..Axis..::..MOTION_FAULTS MF_WRONGMODE

See Also

Controller..::..Axis..::..MOTION_FAULTS Enumeration


ABSTIMETRAP Field

MOVE_CMD..::..ABSTIMETRAP Field

The abstimetrap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTIMETRAP
Public Const ABSTIMETRAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTIMETRAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


ABSTIMETRAP_N Field

MOVE_CMD..::..ABSTIMETRAP_N Field

The abstimetra p_ n

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTIMETRAP_N
Public Const ABSTIMETRAP_N As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTIMETRAP_N

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


ABSTRAP Field

MOVE_CMD..::..ABSTRAP Field

The abstrap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTRAP
Public Const ABSTRAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTRAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


ABSTRAP3 Field

MOVE_CMD..::..ABSTRAP3 Field

The abstra p3

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTRAP3
Public Const ABSTRAP3 As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTRAP3

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


ABSTRAP_EXT Field

MOVE_CMD..::..ABSTRAP_EXT Field

The abstrap returning with drive information

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTRAP_EXT
Public Const ABSTRAP_EXT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTRAP_EXT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


ABSTRI Field

MOVE_CMD..::..ABSTRI Field

The abstri

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD ABSTRI
Public Const ABSTRI As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD ABSTRI

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


CON_MASTER Field

MOVE_CMD..::..CON_MASTER Field

The co n_ master

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD CON_MASTER
Public Const CON_MASTER As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD CON_MASTER

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


CON_SLAVE Field

MOVE_CMD..::..CON_SLAVE Field

The co n_ slave

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD CON_SLAVE
Public Const CON_SLAVE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD CON_SLAVE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


DEFINE_PLS Field

MOVE_CMD..::..DEFINE_PLS Field

The defin e_ PLS

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD DEFINE_PLS
Public Const DEFINE_PLS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD DEFINE_PLS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


DEFINE_PLS_EXTENDED Field

MOVE_CMD..::..DEFINE_PLS_EXTENDED Field

The defin e_ pl s_ extended

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD DEFINE_PLS_EXTENDED
Public Const DEFINE_PLS_EXTENDED As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD DEFINE_PLS_EXTENDED

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


GEAR_AT Field

MOVE_CMD..::..GEAR_AT Field

The gea r_ at

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD GEAR_AT
Public Const GEAR_AT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD GEAR_AT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


GEAR_AT_IN Field

MOVE_CMD..::..GEAR_AT_IN Field

The gea r_ a t_ in

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD GEAR_AT_IN
Public Const GEAR_AT_IN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD GEAR_AT_IN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


GEAR_AT_IN_AFTER Field

MOVE_CMD..::..GEAR_AT_IN_AFTER Field

The gea r_ a t_ i n_ after

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD GEAR_AT_IN_AFTER
Public Const GEAR_AT_IN_AFTER As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD GEAR_AT_IN_AFTER

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


GEAR_FOR_IN Field

MOVE_CMD..::..GEAR_FOR_IN Field

The gea r_ fo r_ in

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD GEAR_FOR_IN
Public Const GEAR_FOR_IN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD GEAR_FOR_IN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


GEAR_FOR_IN_AFTER Field

MOVE_CMD..::..GEAR_FOR_IN_AFTER Field

The gea r_ fo r_ i n_ after

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD GEAR_FOR_IN_AFTER
Public Const GEAR_FOR_IN_AFTER As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD GEAR_FOR_IN_AFTER

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTIMETRAP Field

MOVE_CMD..::..INCTIMETRAP Field

The inctimetrap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTIMETRAP
Public Const INCTIMETRAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTIMETRAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTIMETRAP_N Field

MOVE_CMD..::..INCTIMETRAP_N Field

The inctimetra p_ n

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTIMETRAP_N
Public Const INCTIMETRAP_N As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTIMETRAP_N

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTRAP Field

MOVE_CMD..::..INCTRAP Field

The inctrap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTRAP
Public Const INCTRAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTRAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTRAP3 Field

MOVE_CMD..::..INCTRAP3 Field

The inctra p3

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTRAP3
Public Const INCTRAP3 As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTRAP3

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTRAP_EXT Field

MOVE_CMD..::..INCTRAP_EXT Field

The inctrap returning with drive information

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTRAP_EXT
Public Const INCTRAP_EXT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTRAP_EXT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


INCTRI Field

MOVE_CMD..::..INCTRI Field

The inctri

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD INCTRI
Public Const INCTRI As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD INCTRI

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MOVE_MASTER Field

MOVE_CMD..::..MOVE_MASTER Field

The mov e_ master

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MOVE_MASTER
Public Const MOVE_MASTER As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MOVE_MASTER

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MOVE_MASTER_FOREVER Field

MOVE_CMD..::..MOVE_MASTER_FOREVER Field

The mov e_ maste r_ forever

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_FOREVER
Public Const MOVE_MASTER_FOREVER As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_FOREVER

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MOVE_MASTER_FOREVER_RAMP Field

MOVE_CMD..::..MOVE_MASTER_FOREVER_RAMP Field

The mov e_ maste r_ foreve r_ ramp

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_FOREVER_RAMP
Public Const MOVE_MASTER_FOREVER_RAMP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_FOREVER_RAMP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MOVE_MASTER_RAMP Field

MOVE_CMD..::..MOVE_MASTER_RAMP Field

The mov e_ maste r_ ramp

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_RAMP
Public Const MOVE_MASTER_RAMP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MOVE_MASTER_RAMP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MOVESLAVE Field

MOVE_CMD..::..MOVESLAVE Field

The moveslave

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MOVESLAVE
Public Const MOVESLAVE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MOVESLAVE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_CBIT Field

MOVE_CMD..::..MSB_CBIT Field

The ms b_ cbit

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_CBIT
Public Const MSB_CBIT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_CBIT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_CLROUT Field

MOVE_CMD..::..MSB_CLROUT Field

The ms b_ clrout

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_CLROUT
Public Const MSB_CLROUT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_CLROUT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_CLRTRACKVARS Field

MOVE_CMD..::..MSB_CLRTRACKVARS Field

The ms b_ clrtrackvars

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_CLRTRACKVARS
Public Const MSB_CLRTRACKVARS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_CLRTRACKVARS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_CVAR Field

MOVE_CMD..::..MSB_CVAR Field

The ms b_ cvar

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_CVAR
Public Const MSB_CVAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_CVAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_DELAY Field

MOVE_CMD..::..MSB_DELAY Field

The ms b_ delay

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_DELAY
Public Const MSB_DELAY As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_DELAY

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_DRDIS Field

MOVE_CMD..::..MSB_DRDIS Field

The ms b_ drdis

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_DRDIS
Public Const MSB_DRDIS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_DRDIS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_DREN Field

MOVE_CMD..::..MSB_DREN Field

The ms b_ dren

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_DREN
Public Const MSB_DREN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_DREN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_ONFALL Field

MOVE_CMD..::..MSB_ONFALL Field

The ms b_ onfall

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_ONFALL
Public Const MSB_ONFALL As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_ONFALL

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_ONRISE Field

MOVE_CMD..::..MSB_ONRISE Field

The ms b_ onrise

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_ONRISE
Public Const MSB_ONRISE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_ONRISE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_PULSEOUT_EXT Field

MOVE_CMD..::..MSB_PULSEOUT_EXT Field

The ms b_ pulseou t_ ext

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_PULSEOUT_EXT
Public Const MSB_PULSEOUT_EXT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_PULSEOUT_EXT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_RELAX Field

MOVE_CMD..::..MSB_RELAX Field

The ms b_ relax

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_RELAX
Public Const MSB_RELAX As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_RELAX

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_REM_DCSYNC Field

MOVE_CMD..::..MSB_REM_DCSYNC Field

The ms b_ re m_ dcsync

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_REM_DCSYNC
Public Const MSB_REM_DCSYNC As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_REM_DCSYNC

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_REMOTE_SDO_READ Field

MOVE_CMD..::..MSB_REMOTE_SDO_READ Field

The ms b_ remot e_ sd o_ read

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_REMOTE_SDO_READ
Public Const MSB_REMOTE_SDO_READ As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_REMOTE_SDO_READ

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_REMOTE_SDO_WRITE Field

MOVE_CMD..::..MSB_REMOTE_SDO_WRITE Field

The ms b_ remot e_ sd o_ write

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_REMOTE_SDO_WRITE
Public Const MSB_REMOTE_SDO_WRITE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_REMOTE_SDO_WRITE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETCAP Field

MOVE_CMD..::..MSB_SETCAP Field

The ms b_ setcap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETCAP
Public Const MSB_SETCAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETCAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETCAPWIN Field

MOVE_CMD..::..MSB_SETCAPWIN Field

The ms b_ setcapwin

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETCAPWIN
Public Const MSB_SETCAPWIN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETCAPWIN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETCBIT Field

MOVE_CMD..::..MSB_SETCBIT Field

The ms b_ setcbit

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETCBIT
Public Const MSB_SETCBIT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETCBIT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETCVAR Field

MOVE_CMD..::..MSB_SETCVAR Field

The ms b_ setcvar

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETCVAR
Public Const MSB_SETCVAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETCVAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETM Field

MOVE_CMD..::..MSB_SETM Field

The ms b_ setm

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETM
Public Const MSB_SETM As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETM

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETMS Field

MOVE_CMD..::..MSB_SETMS Field

The ms b_ setms

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETMS
Public Const MSB_SETMS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETMS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_SETOUT Field

MOVE_CMD..::..MSB_SETOUT Field

The ms b_ setout

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_SETOUT
Public Const MSB_SETOUT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_SETOUT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_STOP Field

MOVE_CMD..::..MSB_STOP Field

The ms b_ stop

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_STOP
Public Const MSB_STOP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_STOP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_WAITCAP Field

MOVE_CMD..::..MSB_WAITCAP Field

The ms b_ waitcap

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_WAITCAP
Public Const MSB_WAITCAP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_WAITCAP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_WAITCBIT Field

MOVE_CMD..::..MSB_WAITCBIT Field

The ms b_ waitcbit

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_WAITCBIT
Public Const MSB_WAITCBIT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_WAITCBIT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_WAITCVAR_INRANGE Field

MOVE_CMD..::..MSB_WAITCVAR_INRANGE Field

The ms b_ waitcva r_ inrange

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_WAITCVAR_INRANGE
Public Const MSB_WAITCVAR_INRANGE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_WAITCVAR_INRANGE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_WAITCVAR_NOT_INRANGE Field

MOVE_CMD..::..MSB_WAITCVAR_NOT_INRANGE Field

The ms b_ waitcva r_ no t_ inrange

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_WAITCVAR_NOT_INRANGE
Public Const MSB_WAITCVAR_NOT_INRANGE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_WAITCVAR_NOT_INRANGE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_WAITIP Field

MOVE_CMD..::..MSB_WAITIP Field

The ms b_ waitip

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_WAITIP
Public Const MSB_WAITIP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_WAITIP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


MSB_ZERO Field

MOVE_CMD..::..MSB_ZERO Field

The ms b_ zero

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD MSB_ZERO
Public Const MSB_ZERO As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD MSB_ZERO

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


NEWENDPOSITION Field

MOVE_CMD..::..NEWENDPOSITION Field

The newendposition

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD NEWENDPOSITION
Public Const NEWENDPOSITION As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD NEWENDPOSITION

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


NEWENDPOSITION_RELATIVE Field

MOVE_CMD..::..NEWENDPOSITION_RELATIVE Field

The newendpositio n_ relative

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD NEWENDPOSITION_RELATIVE
Public Const NEWENDPOSITION_RELATIVE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD NEWENDPOSITION_RELATIVE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


OFFSET_POS Field

MOVE_CMD..::..OFFSET_POS Field

The offse t_ position

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD OFFSET_POS
Public Const OFFSET_POS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD OFFSET_POS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_OFF Field

MOVE_CMD..::..PLS_OFF Field

The pl s_ off

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_OFF
Public Const PLS_OFF As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_OFF

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_ON Field

MOVE_CMD..::..PLS_ON Field

The pl s_ on

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_ON
Public Const PLS_ON As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_ON

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_SETINPUT_FALLING Field

MOVE_CMD..::..PLS_SETINPUT_FALLING Field

The pl s_ setinpu t_ falling

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_SETINPUT_FALLING
Public Const PLS_SETINPUT_FALLING As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_SETINPUT_FALLING

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_SETINPUT_RISING Field

MOVE_CMD..::..PLS_SETINPUT_RISING Field

The pl s_ setinpu t_ rising

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_SETINPUT_RISING
Public Const PLS_SETINPUT_RISING As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_SETINPUT_RISING

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_SETMOD Field

MOVE_CMD..::..PLS_SETMOD Field

The pl s_ setmod

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_SETMOD
Public Const PLS_SETMOD As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_SETMOD

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PLS_SETOUTPUT Field

MOVE_CMD..::..PLS_SETOUTPUT Field

The pl s_ setoutput

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PLS_SETOUTPUT
Public Const PLS_SETOUTPUT As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PLS_SETOUTPUT

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


PWM_GEN Field

MOVE_CMD..::..PWM_GEN Field

The pw m_ gen

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD PWM_GEN
Public Const PWM_GEN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD PWM_GEN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


READ_DRIVE_PROPERTIES Field

MOVE_CMD..::..READ_DRIVE_PROPERTIES Field

Read drive properties as a block instead of individually

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD READ_DRIVE_PROPERTIES
Public Const READ_DRIVE_PROPERTIES As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD READ_DRIVE_PROPERTIES

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


READ_VAR Field

MOVE_CMD..::..READ_VAR Field

The rea d_ variable

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD READ_VAR
Public Const READ_VAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD READ_VAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


RESET Field

MOVE_CMD..::..RESET Field

The reset

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD RESET
Public Const RESET As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD RESET

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


RESTART_NETWORK Field

MOVE_CMD..::..RESTART_NETWORK Field

Invoke this command to reset the EtherCAT Network.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD RESTART_NETWORK
Public Const RESTART_NETWORK As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD RESTART_NETWORK

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SEEK_TPOS Field

MOVE_CMD..::..SEEK_TPOS Field

The see k_ tpos

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SEEK_TPOS
Public Const SEEK_TPOS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SEEK_TPOS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SET_FPOS Field

MOVE_CMD..::..SET_FPOS Field

The se t_ fpos

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SET_FPOS
Public Const SET_FPOS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SET_FPOS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SET_LOOPPERIOD Field

MOVE_CMD..::..SET_LOOPPERIOD Field

The se t_ loopperiod

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SET_LOOPPERIOD
Public Const SET_LOOPPERIOD As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SET_LOOPPERIOD

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SET_SIMFBK Field

MOVE_CMD..::..SET_SIMFBK Field

The se t_ simfbk

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SET_SIMFBK
Public Const SET_SIMFBK As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SET_SIMFBK

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SET_TPOS Field

MOVE_CMD..::..SET_TPOS Field

The se t_ tpos

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SET_TPOS
Public Const SET_TPOS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SET_TPOS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SLEWATIN Field

MOVE_CMD..::..SLEWATIN Field

The slewatin

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SLEWATIN
Public Const SLEWATIN As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SLEWATIN

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SLEWFOR Field

MOVE_CMD..::..SLEWFOR Field

The slewfor

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SLEWFOR
Public Const SLEWFOR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SLEWFOR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SM_AD_FOR Field

MOVE_CMD..::..SM_AD_FOR Field

The s m_ a d_ for

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SM_AD_FOR
Public Const SM_AD_FOR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SM_AD_FOR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SM_AD_USING Field

MOVE_CMD..::..SM_AD_USING Field

The s m_ a d_ using

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SM_AD_USING
Public Const SM_AD_USING As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SM_AD_USING

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SM_CLEAR Field

MOVE_CMD..::..SM_CLEAR Field

The s m_ clear

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SM_CLEAR
Public Const SM_CLEAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SM_CLEAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SM_SLEW_UNTIL_POS Field

MOVE_CMD..::..SM_SLEW_UNTIL_POS Field

The s m_ sle w_ unti l_ position

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SM_SLEW_UNTIL_POS
Public Const SM_SLEW_UNTIL_POS As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SM_SLEW_UNTIL_POS

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


SM_STOP_AT_USING Field

MOVE_CMD..::..SM_STOP_AT_USING Field

The s m_ sto p_ a t_ using

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD SM_STOP_AT_USING
Public Const SM_STOP_AT_USING As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD SM_STOP_AT_USING

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


START_REL Field

MOVE_CMD..::..START_REL Field

The star t_ relative

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD START_REL
Public Const START_REL As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD START_REL

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_ADDPAIR Field

MOVE_CMD..::..TABLE_ADDPAIR Field

The tabl e_ addpair

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_ADDPAIR
Public Const TABLE_ADDPAIR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_ADDPAIR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_ADDSERIES Field

MOVE_CMD..::..TABLE_ADDSERIES Field

The tabl e_ addseries

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_ADDSERIES
Public Const TABLE_ADDSERIES As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_ADDSERIES

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_CLEAR Field

MOVE_CMD..::..TABLE_CLEAR Field

The tabl e_ clear

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_CLEAR
Public Const TABLE_CLEAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_CLEAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_COMPUTE Field

MOVE_CMD..::..TABLE_COMPUTE Field

The tabl e_ compute

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_COMPUTE
Public Const TABLE_COMPUTE As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_COMPUTE

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_CONTINUE_CAM Field

MOVE_CMD..::..TABLE_CONTINUE_CAM Field

The tabl e_ continu e_ cam

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_CONTINUE_CAM
Public Const TABLE_CONTINUE_CAM As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_CONTINUE_CAM

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_COPY Field

MOVE_CMD..::..TABLE_COPY Field

The tabl e_ copy

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_COPY
Public Const TABLE_COPY As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_COPY

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_LOADOFFSET Field

MOVE_CMD..::..TABLE_LOADOFFSET Field

The tabl e_ loadoffset

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_LOADOFFSET
Public Const TABLE_LOADOFFSET As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_LOADOFFSET

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_LOADSERIES Field

MOVE_CMD..::..TABLE_LOADSERIES Field

The tabl e_ loadseries

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_LOADSERIES
Public Const TABLE_LOADSERIES As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_LOADSERIES

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_START Field

MOVE_CMD..::..TABLE_START Field

The tabl e_ start

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_START
Public Const TABLE_START As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_START

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_START_CAM Field

MOVE_CMD..::..TABLE_START_CAM Field

The tabl e_ star t_ cam

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_START_CAM
Public Const TABLE_START_CAM As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_START_CAM

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


TABLE_STOP Field

MOVE_CMD..::..TABLE_STOP Field

The tabl e_ stop

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD TABLE_STOP
Public Const TABLE_STOP As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD TABLE_STOP

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


WRITE_VAR Field

MOVE_CMD..::..WRITE_VAR Field

The writ e_ variable

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..MOVE_CMD WRITE_VAR
Public Const WRITE_VAR As Controller..::..Axis..::..MOVE_CMD
public:
literal Controller..::..Axis..::..MOVE_CMD WRITE_VAR

See Also

Controller..::..Axis..::..MOVE_CMD Enumeration


COMPLETE Field

PSTATES..::..COMPLETE Field

Completed move, ready for command.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES COMPLETE
Public Const COMPLETE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES COMPLETE

See Also

Controller..::..Axis..::..PSTATES Enumeration


CONT_CAM Field

PSTATES..::..CONT_CAM Field

continue cam from where stopped (assumes did jog)

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES CONT_CAM
Public Const CONT_CAM As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES CONT_CAM

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_COMPLETE_PENDING Field

PSTATES..::..ECAT_COMPLETE_PENDING Field

EtherCAT Complete pending mode

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_COMPLETE_PENDING
Public Const ECAT_COMPLETE_PENDING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_COMPLETE_PENDING

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_INIT Field

PSTATES..::..ECAT_HOMING_INIT Field

HOMING mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_INIT
Public Const ECAT_HOMING_INIT As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_INIT

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_RUNNING Field

PSTATES..::..ECAT_HOMING_RUNNING Field

HOMING mode RUNNING state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_RUNNING
Public Const ECAT_HOMING_RUNNING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_RUNNING

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_STARTING1 Field

PSTATES..::..ECAT_HOMING_STARTING1 Field

HOMING mode STARTING1 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING1
Public Const ECAT_HOMING_STARTING1 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING1

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_STARTING1A Field

PSTATES..::..ECAT_HOMING_STARTING1A Field

HOMING mode STARTING1A state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING1A
Public Const ECAT_HOMING_STARTING1A As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING1A

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_STARTING2 Field

PSTATES..::..ECAT_HOMING_STARTING2 Field

HOMING mode STARTING2 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING2
Public Const ECAT_HOMING_STARTING2 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_STARTING2

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_WAIT_INPOS Field

PSTATES..::..ECAT_HOMING_WAIT_INPOS Field

HOMING mode WAIT_INPOS state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS
Public Const ECAT_HOMING_WAIT_INPOS As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_WAIT_INPOS_IAI Field

PSTATES..::..ECAT_HOMING_WAIT_INPOS_IAI Field

HOMING mode WAIT_INPOS_IAI state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS_IAI
Public Const ECAT_HOMING_WAIT_INPOS_IAI As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS_IAI

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_HOMING_WAIT_INPOS_KOLLMORGEN Field

PSTATES..::..ECAT_HOMING_WAIT_INPOS_KOLLMORGEN Field

HOMING mode WAIT_INPOS_KOLLMORGEN state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS_KOLLMORGEN
Public Const ECAT_HOMING_WAIT_INPOS_KOLLMORGEN As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_HOMING_WAIT_INPOS_KOLLMORGEN

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_MODE_WAIT_CSP Field

PSTATES..::..ECAT_MODE_WAIT_CSP Field

Cyclic Sync Position mode WAIT_CSP state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_CSP
Public Const ECAT_MODE_WAIT_CSP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_CSP

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_MODE_WAIT_INTERPOLATED Field

PSTATES..::..ECAT_MODE_WAIT_INTERPOLATED Field

Interpolated Position mode WAIT_INTERPOLATED state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_INTERPOLATED
Public Const ECAT_MODE_WAIT_INTERPOLATED As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_INTERPOLATED

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_MODE_WAIT_PROFILE Field

PSTATES..::..ECAT_MODE_WAIT_PROFILE Field

Profile mode WAIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_PROFILE
Public Const ECAT_MODE_WAIT_PROFILE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_MODE_WAIT_PROFILE

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_OFFLINE Field

PSTATES..::..ECAT_OFFLINE Field

EtherCAT Offline mode

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_OFFLINE
Public Const ECAT_OFFLINE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_OFFLINE

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_AT_TORQUE Field

PSTATES..::..ECAT_PROFILE_AT_TORQUE Field

EtherCAT Profile At Torque state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_AT_TORQUE
Public Const ECAT_PROFILE_AT_TORQUE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_AT_TORQUE

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_AT_VEL Field

PSTATES..::..ECAT_PROFILE_AT_VEL Field

EtherCAT Profile At Velocity state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_AT_VEL
Public Const ECAT_PROFILE_AT_VEL As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_AT_VEL

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_INIT_CSP Field

PSTATES..::..ECAT_PROFILE_INIT_CSP Field

Cyclic Sync Position mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_CSP
Public Const ECAT_PROFILE_INIT_CSP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_CSP

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_INIT_INTERPOLATED Field

PSTATES..::..ECAT_PROFILE_INIT_INTERPOLATED Field

Interpolated Position mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_INTERPOLATED
Public Const ECAT_PROFILE_INIT_INTERPOLATED As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_INTERPOLATED

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_INIT_QSTOP Field

PSTATES..::..ECAT_PROFILE_INIT_QSTOP Field

Quick Stop mode INIT_QSTOP state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_QSTOP
Public Const ECAT_PROFILE_INIT_QSTOP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_INIT_QSTOP

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_INIT Field

PSTATES..::..ECAT_PROFILE_POS_INIT Field

Profile Position mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_INIT
Public Const ECAT_PROFILE_POS_INIT As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_INIT

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_RUNNING Field

PSTATES..::..ECAT_PROFILE_POS_RUNNING Field

Profile Position mode RUNNING state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_RUNNING
Public Const ECAT_PROFILE_POS_RUNNING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_RUNNING

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_STARTING1 Field

PSTATES..::..ECAT_PROFILE_POS_STARTING1 Field

Profile Position mode STARTING1 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING1
Public Const ECAT_PROFILE_POS_STARTING1 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING1

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_STARTING1A Field

PSTATES..::..ECAT_PROFILE_POS_STARTING1A Field

Profile Position mode STARTING1A state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING1A
Public Const ECAT_PROFILE_POS_STARTING1A As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING1A

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_STARTING2 Field

PSTATES..::..ECAT_PROFILE_POS_STARTING2 Field

Profile Position mode STARTING2 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING2
Public Const ECAT_PROFILE_POS_STARTING2 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_STARTING2

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_WAIT_ABORTING Field

PSTATES..::..ECAT_PROFILE_POS_WAIT_ABORTING Field

HOMING mode WAIT_ABORTING state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_WAIT_ABORTING
Public Const ECAT_PROFILE_POS_WAIT_ABORTING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_WAIT_ABORTING

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_POS_WAIT_INPOS Field

PSTATES..::..ECAT_PROFILE_POS_WAIT_INPOS Field

Profile Position mode WAIT_INPOS state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_WAIT_INPOS
Public Const ECAT_PROFILE_POS_WAIT_INPOS As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_POS_WAIT_INPOS

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_TORQUE_INIT Field

PSTATES..::..ECAT_PROFILE_TORQUE_INIT Field

Profile Torque mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_TORQUE_INIT
Public Const ECAT_PROFILE_TORQUE_INIT As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_TORQUE_INIT

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_VEL_INIT Field

PSTATES..::..ECAT_PROFILE_VEL_INIT Field

Profile Velocity mode INIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_INIT
Public Const ECAT_PROFILE_VEL_INIT As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_INIT

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_VEL_WAIT Field

PSTATES..::..ECAT_PROFILE_VEL_WAIT Field

Profile Velocity mode WAIT state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT
Public Const ECAT_PROFILE_VEL_WAIT As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_VEL_WAIT_DELAY1 Field

PSTATES..::..ECAT_PROFILE_VEL_WAIT_DELAY1 Field

Profile Velocity mode DELAY1 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY1
Public Const ECAT_PROFILE_VEL_WAIT_DELAY1 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY1

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_VEL_WAIT_DELAY2 Field

PSTATES..::..ECAT_PROFILE_VEL_WAIT_DELAY2 Field

Profile Velocity mode DELAY2 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY2
Public Const ECAT_PROFILE_VEL_WAIT_DELAY2 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY2

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_VEL_WAIT_DELAY3 Field

PSTATES..::..ECAT_PROFILE_VEL_WAIT_DELAY3 Field

Profile Velocity mode DELAY3 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY3
Public Const ECAT_PROFILE_VEL_WAIT_DELAY3 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_VEL_WAIT_DELAY3

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_WAIT_CSP1 Field

PSTATES..::..ECAT_PROFILE_WAIT_CSP1 Field

Cyclic Sync Position mode WAIT_CSP1 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_CSP1
Public Const ECAT_PROFILE_WAIT_CSP1 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_CSP1

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_WAIT_CSP2 Field

PSTATES..::..ECAT_PROFILE_WAIT_CSP2 Field

Cyclic Sync Position mode WAIT_CSP2 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_CSP2
Public Const ECAT_PROFILE_WAIT_CSP2 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_CSP2

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_WAIT_QSTOP Field

PSTATES..::..ECAT_PROFILE_WAIT_QSTOP Field

Quick Stop mode WAIT_QSTOP state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP
Public Const ECAT_PROFILE_WAIT_QSTOP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_WAIT_QSTOP1 Field

PSTATES..::..ECAT_PROFILE_WAIT_QSTOP1 Field

Quick Stop mode WAIT_QSTOP1 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP1
Public Const ECAT_PROFILE_WAIT_QSTOP1 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP1

See Also

Controller..::..Axis..::..PSTATES Enumeration


ECAT_PROFILE_WAIT_QSTOP2 Field

PSTATES..::..ECAT_PROFILE_WAIT_QSTOP2 Field

Quick Stop mode WAIT_QSTOP2 state

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP2
Public Const ECAT_PROFILE_WAIT_QSTOP2 As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES ECAT_PROFILE_WAIT_QSTOP2

See Also

Controller..::..Axis..::..PSTATES Enumeration


EXIT_TRACKING Field

PSTATES..::..EXIT_TRACKING Field

exiting TRACKING mode

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES EXIT_TRACKING
Public Const EXIT_TRACKING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES EXIT_TRACKING

See Also

Controller..::..Axis..::..PSTATES Enumeration


IDLE Field

PSTATES..::..IDLE Field

Axis is idle.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES IDLE
Public Const IDLE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES IDLE

See Also

Controller..::..Axis..::..PSTATES Enumeration


INCAM Field

PSTATES..::..INCAM Field

in 'CAM' move

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES INCAM
Public Const INCAM As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES INCAM

See Also

Controller..::..Axis..::..PSTATES Enumeration


INSPLINE Field

PSTATES..::..INSPLINE Field

in 'SPLINE' move

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES INSPLINE
Public Const INSPLINE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES INSPLINE

See Also

Controller..::..Axis..::..PSTATES Enumeration


PRECAM Field

PSTATES..::..PRECAM Field

pre 'CAM' move

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES PRECAM
Public Const PRECAM As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES PRECAM

See Also

Controller..::..Axis..::..PSTATES Enumeration


PRECAM_REVERSE Field

PSTATES..::..PRECAM_REVERSE Field

run cam table in reverse

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES PRECAM_REVERSE
Public Const PRECAM_REVERSE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES PRECAM_REVERSE

See Also

Controller..::..Axis..::..PSTATES Enumeration


PRESPLINE Field

PSTATES..::..PRESPLINE Field

pre 'SPLINE' move

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES PRESPLINE
Public Const PRESPLINE As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES PRESPLINE

See Also

Controller..::..Axis..::..PSTATES Enumeration


PRETRACKING Field

PSTATES..::..PRETRACKING Field

initialization for TRACKING (geared) mode

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES PRETRACKING
Public Const PRETRACKING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES PRETRACKING

See Also

Controller..::..Axis..::..PSTATES Enumeration


RUNNING Field

PSTATES..::..RUNNING Field

Axis is running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES RUNNING
Public Const RUNNING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES RUNNING

See Also

Controller..::..Axis..::..PSTATES Enumeration


SLEWING Field

PSTATES..::..SLEWING Field

Slewing

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES SLEWING
Public Const SLEWING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES SLEWING

See Also

Controller..::..Axis..::..PSTATES Enumeration


SLEWSTOP Field

PSTATES..::..SLEWSTOP Field

Slewed Stop

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES SLEWSTOP
Public Const SLEWSTOP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES SLEWSTOP

See Also

Controller..::..Axis..::..PSTATES Enumeration


STOP Field

PSTATES..::..STOP Field

STOP.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES STOP
Public Const STOP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES STOP

See Also

Controller..::..Axis..::..PSTATES Enumeration


TABLESTOP Field

PSTATES..::..TABLESTOP Field

stop table

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES TABLESTOP
Public Const TABLESTOP As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES TABLESTOP

See Also

Controller..::..Axis..::..PSTATES Enumeration


TRACKING Field

PSTATES..::..TRACKING Field

geared and tracking

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..PSTATES TRACKING
Public Const TRACKING As Controller..::..Axis..::..PSTATES
public:
literal Controller..::..Axis..::..PSTATES TRACKING

See Also

Controller..::..Axis..::..PSTATES Enumeration


CUBIC Field

TABLE_MOVES..::..CUBIC Field

CUBIC computational move.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..TABLE_MOVES CUBIC
Public Const CUBIC As Controller..::..Axis..::..TABLE_MOVES
public:
literal Controller..::..Axis..::..TABLE_MOVES CUBIC

See Also

Controller..::..Axis..::..TABLE_MOVES Enumeration


LINEAR Field

TABLE_MOVES..::..LINEAR Field

Linear computational move.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..TABLE_MOVES LINEAR
Public Const LINEAR As Controller..::..Axis..::..TABLE_MOVES
public:
literal Controller..::..Axis..::..TABLE_MOVES LINEAR

See Also

Controller..::..Axis..::..TABLE_MOVES Enumeration


QUADRATIC Field

TABLE_MOVES..::..QUADRATIC Field

Quadratic computational move.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..Axis..::..TABLE_MOVES QUADRATIC
Public Const QUADRATIC As Controller..::..Axis..::..TABLE_MOVES
public:
literal Controller..::..Axis..::..TABLE_MOVES QUADRATIC

See Also

Controller..::..Axis..::..TABLE_MOVES Enumeration


INITIALIZING Field

SCAN_STATES..::..INITIALIZING Field

EtherCAT scan engine is initializing the system.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..AxisSupervisor..::..SCAN_STATES INITIALIZING
Public Const INITIALIZING As Controller..::..AxisSupervisor..::..SCAN_STATES
public:
literal Controller..::..AxisSupervisor..::..SCAN_STATES INITIALIZING

See Also

Controller..::..AxisSupervisor..::..SCAN_STATES Enumeration


OFFLINE Field

SCAN_STATES..::..OFFLINE Field

EtherCAT scan engine is offline, thread not running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..AxisSupervisor..::..SCAN_STATES OFFLINE
Public Const OFFLINE As Controller..::..AxisSupervisor..::..SCAN_STATES
public:
literal Controller..::..AxisSupervisor..::..SCAN_STATES OFFLINE

See Also

Controller..::..AxisSupervisor..::..SCAN_STATES Enumeration


RUNNING Field

SCAN_STATES..::..RUNNING Field

EtherCAT scan engine is fully operational, running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..AxisSupervisor..::..SCAN_STATES RUNNING
Public Const RUNNING As Controller..::..AxisSupervisor..::..SCAN_STATES
public:
literal Controller..::..AxisSupervisor..::..SCAN_STATES RUNNING

See Also

Controller..::..AxisSupervisor..::..SCAN_STATES Enumeration


CONNECT_ONLY Field

PLC_CONNECT_MODES..::..CONNECT_ONLY Field

Connect only.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_ONLY
Public Const CONNECT_ONLY As Controller..::..PLCLogic..::..PLC_CONNECT_MODES
public:
literal Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_ONLY

See Also

Controller..::..PLCLogic..::..PLC_CONNECT_MODES Enumeration


CONNECT_STOPQB Field

PLC_CONNECT_MODES..::..CONNECT_STOPQB Field

Connect and ensure QuickBuilder is stopped.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_STOPQB
Public Const CONNECT_STOPQB As Controller..::..PLCLogic..::..PLC_CONNECT_MODES
public:
literal Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_STOPQB

See Also

Controller..::..PLCLogic..::..PLC_CONNECT_MODES Enumeration


CONNECT_STOPQB_RESTARTECAT Field

PLC_CONNECT_MODES..::..CONNECT_STOPQB_RESTARTECAT Field

Connect, stop QuickBuilder and then restart the EtherCAT network.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_STOPQB_RESTARTECAT
Public Const CONNECT_STOPQB_RESTARTECAT As Controller..::..PLCLogic..::..PLC_CONNECT_MODES
public:
literal Controller..::..PLCLogic..::..PLC_CONNECT_MODES CONNECT_STOPQB_RESTARTECAT

See Also

Controller..::..PLCLogic..::..PLC_CONNECT_MODES Enumeration


ALTERNATE_ERROR_ILLEGAL_INST Field

PLC_RETVAL..::..ALTERNATE_ERROR_ILLEGAL_INST Field

Use this instead of 1 since success can be 1 or 0 depending where used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ALTERNATE_ERROR_ILLEGAL_INST
Public Const ALTERNATE_ERROR_ILLEGAL_INST As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ALTERNATE_ERROR_ILLEGAL_INST

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


END_ALL_TASKS Field

PLC_RETVAL..::..END_ALL_TASKS Field

Last task has successfully completed..

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL END_ALL_TASKS
Public Const END_ALL_TASKS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL END_ALL_TASKS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


END_OF_STEP Field

PLC_RETVAL..::..END_OF_STEP Field

"End of Step" was found, not an error..

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL END_OF_STEP
Public Const END_OF_STEP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL END_OF_STEP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_AIN_SCALING Field

PLC_RETVAL..::..ERROR_AIN_SCALING Field

Error in fetching or calculating analog scaling.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_AIN_SCALING
Public Const ERROR_AIN_SCALING As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_AIN_SCALING

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_ANALOG_NOT_READY Field

PLC_RETVAL..::..ERROR_ANALOG_NOT_READY Field

Analog module not responding.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ANALOG_NOT_READY
Public Const ERROR_ANALOG_NOT_READY As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ANALOG_NOT_READY

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_AOUT_SCALING Field

PLC_RETVAL..::..ERROR_AOUT_SCALING Field

Error in fetching or calculating analog scaling.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_AOUT_SCALING
Public Const ERROR_AOUT_SCALING As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_AOUT_SCALING

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_ATMEL_ISP Field

PLC_RETVAL..::..ERROR_ATMEL_ISP Field

5300 only, not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ATMEL_ISP
Public Const ERROR_ATMEL_ISP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ATMEL_ISP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_BAD_THUMB Field

PLC_RETVAL..::..ERROR_BAD_THUMB Field

Not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_BAD_THUMB
Public Const ERROR_BAD_THUMB As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_BAD_THUMB

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_COMM_PROTOCOL Field

PLC_RETVAL..::..ERROR_COMM_PROTOCOL Field

Error in request/reply handshake.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_COMM_PROTOCOL
Public Const ERROR_COMM_PROTOCOL As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_COMM_PROTOCOL

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_CORRUPT Field

PLC_RETVAL..::..ERROR_CORRUPT Field

Corrupt program data.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_CORRUPT
Public Const ERROR_CORRUPT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_CORRUPT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_CORRUPT_QUICKSTEP Field

PLC_RETVAL..::..ERROR_CORRUPT_QUICKSTEP Field

Quickstep memory corrupted.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_CORRUPT_QUICKSTEP
Public Const ERROR_CORRUPT_QUICKSTEP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_CORRUPT_QUICKSTEP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_DELAY_REJECTED Field

PLC_RETVAL..::..ERROR_DELAY_REJECTED Field

Time delay not accepted not necessarily an error .

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DELAY_REJECTED
Public Const ERROR_DELAY_REJECTED As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DELAY_REJECTED

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_DIG_INP Field

PLC_RETVAL..::..ERROR_DIG_INP Field

No such digital input #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIG_INP
Public Const ERROR_DIG_INP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIG_INP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_DIG_OUT Field

PLC_RETVAL..::..ERROR_DIG_OUT Field

No such digital output #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIG_OUT
Public Const ERROR_DIG_OUT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIG_OUT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_DIV_ZERO Field

PLC_RETVAL..::..ERROR_DIV_ZERO Field

Divide-by-zero error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIV_ZERO
Public Const ERROR_DIV_ZERO As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DIV_ZERO

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_DUALPORT_TIMEOUT Field

PLC_RETVAL..::..ERROR_DUALPORT_TIMEOUT Field

Dualport memory timeout.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DUALPORT_TIMEOUT
Public Const ERROR_DUALPORT_TIMEOUT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_DUALPORT_TIMEOUT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_EXT_DATA_DESC Field

PLC_RETVAL..::..ERROR_EXT_DATA_DESC Field

Invalid extended data descriptor.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_EXT_DATA_DESC
Public Const ERROR_EXT_DATA_DESC As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_EXT_DATA_DESC

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_FILE_FGETS Field

PLC_RETVAL..::..ERROR_FILE_FGETS Field

fgets returned null pointer, not found .

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FILE_FGETS
Public Const ERROR_FILE_FGETS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FILE_FGETS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_FILE_OPEN Field

PLC_RETVAL..::..ERROR_FILE_OPEN Field

Error trying to open file requested, not exist?.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FILE_OPEN
Public Const ERROR_FILE_OPEN As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FILE_OPEN

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_FTP_COMMAND Field

PLC_RETVAL..::..ERROR_FTP_COMMAND Field

General FTP command failed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_COMMAND
Public Const ERROR_FTP_COMMAND As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_COMMAND

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_FTP_CONNECT Field

PLC_RETVAL..::..ERROR_FTP_CONNECT Field

Attempted FTP Client operation but not connected.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_CONNECT
Public Const ERROR_FTP_CONNECT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_CONNECT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_FTP_DISCONNECT Field

PLC_RETVAL..::..ERROR_FTP_DISCONNECT Field

Attempted to connect on something already connected.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_DISCONNECT
Public Const ERROR_FTP_DISCONNECT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_FTP_DISCONNECT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_HARDWARE Field

PLC_RETVAL..::..ERROR_HARDWARE Field

Hardware fault.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_HARDWARE
Public Const ERROR_HARDWARE As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_HARDWARE

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_ILLEGAL_INST Field

PLC_RETVAL..::..ERROR_ILLEGAL_INST Field

Illegal instruction opcode.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ILLEGAL_INST
Public Const ERROR_ILLEGAL_INST As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ILLEGAL_INST

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_ILLEGAL_VAL Field

PLC_RETVAL..::..ERROR_ILLEGAL_VAL Field

Illegal (data table) value.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ILLEGAL_VAL
Public Const ERROR_ILLEGAL_VAL As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_ILLEGAL_VAL

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_INVALID_PCA Field

PLC_RETVAL..::..ERROR_INVALID_PCA Field

5300 only, not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_INVALID_PCA
Public Const ERROR_INVALID_PCA As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_INVALID_PCA

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_IO_DUALPORT_UNDEFINED Field

PLC_RETVAL..::..ERROR_IO_DUALPORT_UNDEFINED Field

Dualport device on IO bus ID seen but cpu not running...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IO_DUALPORT_UNDEFINED
Public Const ERROR_IO_DUALPORT_UNDEFINED As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IO_DUALPORT_UNDEFINED

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_IOACCESS Field

PLC_RETVAL..::..ERROR_IOACCESS Field

IError Accessing Hardware I/O.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IOACCESS
Public Const ERROR_IOACCESS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IOACCESS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_IODRIVER Field

PLC_RETVAL..::..ERROR_IODRIVER Field

Generic Error in IODRIVER.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IODRIVER
Public Const ERROR_IODRIVER As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_IODRIVER

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_LOST_EXPANSION Field

PLC_RETVAL..::..ERROR_LOST_EXPANSION Field

Lost Expansion during operation.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_LOST_EXPANSION
Public Const ERROR_LOST_EXPANSION As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_LOST_EXPANSION

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_MALLOC Field

PLC_RETVAL..::..ERROR_MALLOC Field

Memory malloc failed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MALLOC
Public Const ERROR_MALLOC As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MALLOC

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_MAX_TASKS Field

PLC_RETVAL..::..ERROR_MAX_TASKS Field

Too many tasks.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MAX_TASKS
Public Const ERROR_MAX_TASKS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MAX_TASKS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_MESSAGE_RESULT Field

PLC_RETVAL..::..ERROR_MESSAGE_RESULT Field

Message result length != 4? Possible bytes left in mailbox from old message...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MESSAGE_RESULT
Public Const ERROR_MESSAGE_RESULT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_MESSAGE_RESULT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NAME_TO_LONG Field

PLC_RETVAL..::..ERROR_NAME_TO_LONG Field

The PLC request mailbox name is too long? Limit is 8 characters.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NAME_TO_LONG
Public Const ERROR_NAME_TO_LONG As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NAME_TO_LONG

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_ACCESS Field

PLC_RETVAL..::..ERROR_NET_ACCESS Field

Network access problem.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_ACCESS
Public Const ERROR_NET_ACCESS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_ACCESS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_BAD_MSG Field

PLC_RETVAL..::..ERROR_NET_BAD_MSG Field

Network bad return message.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BAD_MSG
Public Const ERROR_NET_BAD_MSG As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BAD_MSG

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_BAD_RESPONSE Field

PLC_RETVAL..::..ERROR_NET_BAD_RESPONSE Field

Network bad response.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BAD_RESPONSE
Public Const ERROR_NET_BAD_RESPONSE As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BAD_RESPONSE

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_BUSY Field

PLC_RETVAL..::..ERROR_NET_BUSY Field

Network access busy.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BUSY
Public Const ERROR_NET_BUSY As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_BUSY

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_RQST_LOST Field

PLC_RETVAL..::..ERROR_NET_RQST_LOST Field

Network request lost.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_RQST_LOST
Public Const ERROR_NET_RQST_LOST As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_RQST_LOST

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NET_TIMEOUT Field

PLC_RETVAL..::..ERROR_NET_TIMEOUT Field

Network access timeout.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_TIMEOUT
Public Const ERROR_NET_TIMEOUT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NET_TIMEOUT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_AIN Field

PLC_RETVAL..::..ERROR_NO_AIN Field

No such analog input # .

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_AIN
Public Const ERROR_NO_AIN As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_AIN

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_AOUT Field

PLC_RETVAL..::..ERROR_NO_AOUT Field

No such analog output #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_AOUT
Public Const ERROR_NO_AOUT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_AOUT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_COL Field

PLC_RETVAL..::..ERROR_NO_COL Field

No such data table col.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COL
Public Const ERROR_NO_COL As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COL

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_COMM_PORT Field

PLC_RETVAL..::..ERROR_NO_COMM_PORT Field

No such communications port.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COMM_PORT
Public Const ERROR_NO_COMM_PORT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COMM_PORT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_COUNTER Field

PLC_RETVAL..::..ERROR_NO_COUNTER Field

No counters available?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COUNTER
Public Const ERROR_NO_COUNTER As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_COUNTER

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_DELAYTIMER Field

PLC_RETVAL..::..ERROR_NO_DELAYTIMER Field

Bad delaytimer selected.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_DELAYTIMER
Public Const ERROR_NO_DELAYTIMER As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_DELAYTIMER

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_DISP Field

PLC_RETVAL..::..ERROR_NO_DISP Field

No such display #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_DISP
Public Const ERROR_NO_DISP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_DISP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_FLAG Field

PLC_RETVAL..::..ERROR_NO_FLAG Field

Bad flag number selected.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_FLAG
Public Const ERROR_NO_FLAG As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_FLAG

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_PROTO Field

PLC_RETVAL..::..ERROR_NO_PROTO Field

Not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_PROTO
Public Const ERROR_NO_PROTO As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_PROTO

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_PWM Field

PLC_RETVAL..::..ERROR_NO_PWM Field

No PWM available?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_PWM
Public Const ERROR_NO_PWM As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_PWM

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_REG Field

PLC_RETVAL..::..ERROR_NO_REG Field

No such register exists.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_REG
Public Const ERROR_NO_REG As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_REG

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_ROW Field

PLC_RETVAL..::..ERROR_NO_ROW Field

No such data table row.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_ROW
Public Const ERROR_NO_ROW As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_ROW

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_SERVO Field

PLC_RETVAL..::..ERROR_NO_SERVO Field

No such servo #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_SERVO
Public Const ERROR_NO_SERVO As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_SERVO

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_STEP Field

PLC_RETVAL..::..ERROR_NO_STEP Field

Destination step doesnt exist.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEP
Public Const ERROR_NO_STEP As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEP

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_STEP_1 Field

PLC_RETVAL..::..ERROR_NO_STEP_1 Field

Step#1 doesnt exist.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEP_1
Public Const ERROR_NO_STEP_1 As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEP_1

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_STEPPER Field

PLC_RETVAL..::..ERROR_NO_STEPPER Field

No such stepping motor #.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEPPER
Public Const ERROR_NO_STEPPER As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_STEPPER

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NO_THUMB Field

PLC_RETVAL..::..ERROR_NO_THUMB Field

Not used.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_THUMB
Public Const ERROR_NO_THUMB As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NO_THUMB

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NOT_CALIBRATED Field

PLC_RETVAL..::..ERROR_NOT_CALIBRATED Field

Device not calibrated, analog?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_CALIBRATED
Public Const ERROR_NOT_CALIBRATED As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_CALIBRATED

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NOT_DEFINED Field

PLC_RETVAL..::..ERROR_NOT_DEFINED Field

Virtual table function call not defined.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_DEFINED
Public Const ERROR_NOT_DEFINED As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_DEFINED

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NOT_PROF Field

PLC_RETVAL..::..ERROR_NOT_PROF Field

Stepping motor not profiled.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_PROF
Public Const ERROR_NOT_PROF As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_PROF

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NOT_SET Field

PLC_RETVAL..::..ERROR_NOT_SET Field

Used for dual port to set error to not defined yet.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_SET
Public Const ERROR_NOT_SET As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NOT_SET

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_NTX_TYPE_RT_PROCESS Field

PLC_RETVAL..::..ERROR_NTX_TYPE_RT_PROCESS Field

Attempted to attached to a process other than real time?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NTX_TYPE_RT_PROCESS
Public Const ERROR_NTX_TYPE_RT_PROCESS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_NTX_TYPE_RT_PROCESS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_OO_RANGE Field

PLC_RETVAL..::..ERROR_OO_RANGE Field

Generic data-out-of range.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_OO_RANGE
Public Const ERROR_OO_RANGE As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_OO_RANGE

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_OUT_OF_SOFTCNTRS Field

PLC_RETVAL..::..ERROR_OUT_OF_SOFTCNTRS Field

Out-of-softcounters.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_OUT_OF_SOFTCNTRS
Public Const ERROR_OUT_OF_SOFTCNTRS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_OUT_OF_SOFTCNTRS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_PLCQue_REQUEST Field

PLC_RETVAL..::..ERROR_PLCQue_REQUEST Field

The PLC request mailbox is missing? Possibly invalid name or duplicate?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQue_REQUEST
Public Const ERROR_PLCQue_REQUEST As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQue_REQUEST

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_PLCQue_RESPONSE Field

PLC_RETVAL..::..ERROR_PLCQue_RESPONSE Field

The PLC response mailbox is missing? Possibly invalid name or duplicate?

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQue_RESPONSE
Public Const ERROR_PLCQue_RESPONSE As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQue_RESPONSE

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_PLCQueAPI Field

PLC_RETVAL..::..ERROR_PLCQueAPI Field

The PLC mailbox is missing? Possibly not running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQueAPI
Public Const ERROR_PLCQueAPI As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_PLCQueAPI

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_SAMPLE_T Field

PLC_RETVAL..::..ERROR_SAMPLE_T Field

Illegal sample time.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SAMPLE_T
Public Const ERROR_SAMPLE_T As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SAMPLE_T

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_SERVO Field

PLC_RETVAL..::..ERROR_SERVO Field

Servo error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SERVO
Public Const ERROR_SERVO As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SERVO

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_SERVO_NOT_READY Field

PLC_RETVAL..::..ERROR_SERVO_NOT_READY Field

Servo not ready.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SERVO_NOT_READY
Public Const ERROR_SERVO_NOT_READY As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SERVO_NOT_READY

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_SPI_OVERRUN Field

PLC_RETVAL..::..ERROR_SPI_OVERRUN Field

SPI data overrun.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SPI_OVERRUN
Public Const ERROR_SPI_OVERRUN As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SPI_OVERRUN

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_SPI_TIMEOUT Field

PLC_RETVAL..::..ERROR_SPI_TIMEOUT Field

SPI device timed out.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SPI_TIMEOUT
Public Const ERROR_SPI_TIMEOUT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_SPI_TIMEOUT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_STEPPER_NOT_READY Field

PLC_RETVAL..::..ERROR_STEPPER_NOT_READY Field

Stepping motor not ready.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_STEPPER_NOT_READY
Public Const ERROR_STEPPER_NOT_READY As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_STEPPER_NOT_READY

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_TASK Field

PLC_RETVAL..::..ERROR_TASK Field

Task error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_TASK
Public Const ERROR_TASK As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_TASK

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_TASK_STATUS Field

PLC_RETVAL..::..ERROR_TASK_STATUS Field

Task status error.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_TASK_STATUS
Public Const ERROR_TASK_STATUS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_TASK_STATUS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_VIRTUALIO_CONNECTION Field

PLC_RETVAL..::..ERROR_VIRTUALIO_CONNECTION Field

Lost connection with Virtual Controller.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_VIRTUALIO_CONNECTION
Public Const ERROR_VIRTUALIO_CONNECTION As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_VIRTUALIO_CONNECTION

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


ERROR_XMIT Field

PLC_RETVAL..::..ERROR_XMIT Field

Transmitter busy.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL ERROR_XMIT
Public Const ERROR_XMIT As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL ERROR_XMIT

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


INVALID_PARAMETER Field

PLC_RETVAL..::..INVALID_PARAMETER Field

Invalid parameter was passed.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL INVALID_PARAMETER
Public Const INVALID_PARAMETER As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL INVALID_PARAMETER

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


SUCCESS Field

PLC_RETVAL..::..SUCCESS Field

No Error, success.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_RETVAL SUCCESS
Public Const SUCCESS As Controller..::..PLCLogic..::..PLC_RETVAL
public:
literal Controller..::..PLCLogic..::..PLC_RETVAL SUCCESS

See Also

Controller..::..PLCLogic..::..PLC_RETVAL Enumeration


AT_RESET Field

PLC_STATES..::..AT_RESET Field

Controller is at Reset.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES AT_RESET
Public Const AT_RESET As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES AT_RESET

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


FAULT Field

PLC_STATES..::..FAULT Field

Write: Continue to fault as usual. Read: Faulting.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES FAULT
Public Const FAULT As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES FAULT

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


FAULT_STOPPED Field

PLC_STATES..::..FAULT_STOPPED Field

Read: System stopped after fault encountered.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES FAULT_STOPPED
Public Const FAULT_STOPPED As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES FAULT_STOPPED

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


PROGRAMMING Field

PLC_STATES..::..PROGRAMMING Field

Read: Program is loading...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES PROGRAMMING
Public Const PROGRAMMING As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES PROGRAMMING

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


RESET Field

PLC_STATES..::..RESET Field

Reset the controller and begin running the Quickstep or QuickBuilder again from start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES RESET
Public Const RESET As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES RESET

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


RESET_STOP Field

PLC_STATES..::..RESET_STOP Field

Reset the controller and stop the program... Will enter STOPPED state when done...

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES RESET_STOP
Public Const RESET_STOP As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES RESET_STOP

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


RESTART Field

PLC_STATES..::..RESTART Field

Reset the controller and begin running the Quickstep or QuickBuilder again from start. Clears a fault.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES RESTART
Public Const RESTART As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES RESTART

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


RUNNING Field

PLC_STATES..::..RUNNING Field

Write: Ignore the fault and continue running. Read: Program is running.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES RUNNING
Public Const RUNNING As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES RUNNING

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


SHUTDOWN Field

PLC_STATES..::..SHUTDOWN Field

Reset the controller and shutdown, requires a power cycle to exit and continue.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES SHUTDOWN
Public Const SHUTDOWN As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES SHUTDOWN

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


STOPPED Field

PLC_STATES..::..STOPPED Field

Stop the controller but do not reset, used to clear a FAULT before restarting. State will change to FAULT_STOPPED.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES STOPPED
Public Const STOPPED As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES STOPPED

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


WARM_RESTART Field

PLC_STATES..::..WARM_RESTART Field

Warm restart, restart only, do not reload the program.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..PLC_STATES WARM_RESTART
Public Const WARM_RESTART As Controller..::..PLCLogic..::..PLC_STATES
public:
literal Controller..::..PLCLogic..::..PLC_STATES WARM_RESTART

See Also

Controller..::..PLCLogic..::..PLC_STATES Enumeration


ANALOG_IN_END Field

REGISTERS..::..ANALOG_IN_END Field

Analog input end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS ANALOG_IN_END
Public Const ANALOG_IN_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS ANALOG_IN_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


ANALOG_IN_START Field

REGISTERS..::..ANALOG_IN_START Field

Analog input start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS ANALOG_IN_START
Public Const ANALOG_IN_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS ANALOG_IN_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


ANALOG_OUT_END Field

REGISTERS..::..ANALOG_OUT_END Field

Analog output end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS ANALOG_OUT_END
Public Const ANALOG_OUT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS ANALOG_OUT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


ANALOG_OUT_START Field

REGISTERS..::..ANALOG_OUT_START Field

Analog output start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS ANALOG_OUT_START
Public Const ANALOG_OUT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS ANALOG_OUT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_IN_BITS_START Field

REGISTERS..::..DIGITAL_IN_BITS_START Field

Digital input bits start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_BITS_START
Public Const DIGITAL_IN_BITS_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_BITS_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_IN_BYTES_START Field

REGISTERS..::..DIGITAL_IN_BYTES_START Field

Digital input 8 bit start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_BYTES_START
Public Const DIGITAL_IN_BYTES_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_BYTES_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_IN_INT_START Field

REGISTERS..::..DIGITAL_IN_INT_START Field

Digital input 32 bit integer start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_INT_START
Public Const DIGITAL_IN_INT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_INT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_IN_SHORT_START Field

REGISTERS..::..DIGITAL_IN_SHORT_START Field

Digital input 16 bit start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_SHORT_START
Public Const DIGITAL_IN_SHORT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_IN_SHORT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_OUT_BITS_START Field

REGISTERS..::..DIGITAL_OUT_BITS_START Field

Digital output bits start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_BITS_START
Public Const DIGITAL_OUT_BITS_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_BITS_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_OUT_BYTES_START Field

REGISTERS..::..DIGITAL_OUT_BYTES_START Field

Digital output 8 bit start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_BYTES_START
Public Const DIGITAL_OUT_BYTES_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_BYTES_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_OUT_INT_START Field

REGISTERS..::..DIGITAL_OUT_INT_START Field

Digital output 32 bit integer start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_INT_START
Public Const DIGITAL_OUT_INT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_INT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


DIGITAL_OUT_SHORT_START Field

REGISTERS..::..DIGITAL_OUT_SHORT_START Field

Digital output 16 bit short start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_SHORT_START
Public Const DIGITAL_OUT_SHORT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS DIGITAL_OUT_SHORT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


FLAG_BIT_EXT_END Field

REGISTERS..::..FLAG_BIT_EXT_END Field

Extended flag bit end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS FLAG_BIT_EXT_END
Public Const FLAG_BIT_EXT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS FLAG_BIT_EXT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


FLAG_BIT_EXT_START Field

REGISTERS..::..FLAG_BIT_EXT_START Field

Extended flag bit start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS FLAG_BIT_EXT_START
Public Const FLAG_BIT_EXT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS FLAG_BIT_EXT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


FLAG_BYTE_EXT_END Field

REGISTERS..::..FLAG_BYTE_EXT_END Field

Extended flag byte end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS FLAG_BYTE_EXT_END
Public Const FLAG_BYTE_EXT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS FLAG_BYTE_EXT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


FLAG_BYTE_EXT_START Field

REGISTERS..::..FLAG_BYTE_EXT_START Field

Extended flag byte start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS FLAG_BYTE_EXT_START
Public Const FLAG_BYTE_EXT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS FLAG_BYTE_EXT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


FLAG_INT Field

REGISTERS..::..FLAG_INT Field

General Flag 32 bit integer.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS FLAG_INT
Public Const FLAG_INT As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS FLAG_INT

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


MASTER_BOARD_ONLINE_STATUS Field

REGISTERS..::..MASTER_BOARD_ONLINE_STATUS Field

Online status of EtherCAT board selected

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS MASTER_BOARD_ONLINE_STATUS
Public Const MASTER_BOARD_ONLINE_STATUS As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS MASTER_BOARD_ONLINE_STATUS

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


MASTER_BOARD_SELECT Field

REGISTERS..::..MASTER_BOARD_SELECT Field

EtherCAT board/process select, 1 for first, 2 for second.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS MASTER_BOARD_SELECT
Public Const MASTER_BOARD_SELECT As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS MASTER_BOARD_SELECT

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


MILLISECOND_COUNTER Field

REGISTERS..::..MILLISECOND_COUNTER Field

PLC logic millisecond tick.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS MILLISECOND_COUNTER
Public Const MILLISECOND_COUNTER As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS MILLISECOND_COUNTER

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_END Field

REGISTERS..::..NON_VOLATILE_END Field

Non-Volatile integer memory end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_END
Public Const NON_VOLATILE_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_EXT_END Field

REGISTERS..::..NON_VOLATILE_EXT_END Field

Non-Volatile extended integer memory end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_EXT_END
Public Const NON_VOLATILE_EXT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_EXT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_EXT_START Field

REGISTERS..::..NON_VOLATILE_EXT_START Field

Non-Volatile extended integer memory start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_EXT_START
Public Const NON_VOLATILE_EXT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_EXT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_START Field

REGISTERS..::..NON_VOLATILE_START Field

Non-Volatile extended integer memory start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_START
Public Const NON_VOLATILE_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_VARIENT_END Field

REGISTERS..::..NON_VOLATILE_VARIENT_END Field

Non-Volatile memory varient end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_VARIENT_END
Public Const NON_VOLATILE_VARIENT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_VARIENT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


NON_VOLATILE_VARIENT_START Field

REGISTERS..::..NON_VOLATILE_VARIENT_START Field

Non-Volatile memory varient start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_VARIENT_START
Public Const NON_VOLATILE_VARIENT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS NON_VOLATILE_VARIENT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


PROGRAM_EXECUTION_STATE Field

REGISTERS..::..PROGRAM_EXECUTION_STATE Field

PLC logic Quickbuilder program execution state.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS PROGRAM_EXECUTION_STATE
Public Const PROGRAM_EXECUTION_STATE As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS PROGRAM_EXECUTION_STATE

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


VOLATILE_END Field

REGISTERS..::..VOLATILE_END Field

Volatile integer memory end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS VOLATILE_END
Public Const VOLATILE_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS VOLATILE_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


VOLATILE_START Field

REGISTERS..::..VOLATILE_START Field

Volatile integer memory start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS VOLATILE_START
Public Const VOLATILE_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS VOLATILE_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


VOLATILE_VARIANT_END Field

REGISTERS..::..VOLATILE_VARIANT_END Field

Volatile memory varient end.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS VOLATILE_VARIANT_END
Public Const VOLATILE_VARIANT_END As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS VOLATILE_VARIANT_END

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration


VOLATILE_VARIANT_START Field

REGISTERS..::..VOLATILE_VARIANT_START Field

Volatile memory varient start.

Namespace: CTC_Incentive
Assembly: CTC_Incentive (in CTC_Incentive.dll)

Syntax

C#
VB
C++
public const Controller..::..PLCLogic..::..REGISTERS VOLATILE_VARIANT_START
Public Const VOLATILE_VARIANT_START As Controller..::..PLCLogic..::..REGISTERS
public:
literal Controller..::..PLCLogic..::..REGISTERS VOLATILE_VARIANT_START

See Also

Controller..::..PLCLogic..::..REGISTERS Enumeration